SeisNet# is an on-line data capture and quality assurance system designed to interface to virtually any marine or land seismic recording systems. The system is comprised of a tape emulator capture card and software running on a Windows host computer.

System features are as follows:

Data Capture | Up to 40 Mbytes/Second sustained capture rate direct to disk, utilizing DCT tape emulator card.
Data Processing | Filtering, Trace Attribute Calculation & Display, Single Trace Gather, Dead Trace Detection, Correlation, Stacking, First Break Picking, SEG Y I/O, Spectrum Attributtes, Marine QC, SPS Merge.
Plotting | V80 Compatible including OYO 612/622/624 and DFM 480 and Isys V12/24
Tape I/O | 3480/3490/3590, DLT, LTO, 4mm & 8mm. Tape Copy & Dual Write capability.
Network Link | Network link to ProMAX+ , Focusl, Gator*, Windows and UNIX workstations.

# SeisNet is a trademark of Software Sciences, Inc.

· Windows is a trademark of Microsoft Corporation

+ ProMAX is a trademark of Landmark Geophysics Corporation

*Gator is a trademark of Concept Systems Ltd.

lFocus is a trademark of Paradigm Geophysical Corporation

*GeoRes is a trademark of Geospace Technologies


System Architecture

SeisNet System Architecture

Introduction

SeisNet is a hardware and software system that operates under the Windows operating system and provides the ability to capture seismic data direct to disk, process, archive and network to processing systems. This is achieved by emulating a tape drive on virtually any marine or land seismic recording system. The SeisNet system provides the user with these four key capabilities as follows:

Data Capture

Data capture is achieved by SeisNet's DCT capture card, which emulates a tape drive and captures seismic data direct to disk. Data is captured at speeds up to 40 Mb/sec depending on the recording systems capabilities and then written to dual hot swap hard drives or RAID. Data files are stored as SEG-D image files on disk with a .raw extension. Tape blocking files may also be captured to disk with .blk extension. These blocking files are utilized by SeisNet’s Tape Archive Utility to ensure that blocking to tape is identical to the recording system blocking. Optimization of data transfer rates enables faster recorder cycle times and also eliminates other tape drive related problems which may limit production.

Data Processing

SeisNet provides a suite of processing modules to allow analysis, manipulation and display of the captured data.

The following processing modules are currently available:

Data Input |  | Tape Emulator, Tape, Disk, DC20, Raw Data In/Out, Raw Data from Disk and SEG-2 Files from Disk, SEG-Y Tape Input, SEG-Y Disk Input, DC20 To Disk
Data Output | Disk, Tape, Tape with Verify, Tape for Syntron's Split Recording, GeoRes Tape Output, Tape Out SEG-Y, Disk Out SEG-Y, RAW Data to Disk, SEG-D Tape Image to Disk
Filters | Lowpass, Highpass, Notch, Correlation
Display | Display Seismic Traces, Plot Seismic Traces, Display Single Trace Gather, Plot Single Trace Gather (Real Time), Capture Screen to Printer, Plot Traces on HP LaserJet, Trace Highlight
Scaling | Apply Scale Factor, Convert to Microbars
Stacking & Geometry | Simple Marine Geometry, Real-Time Brute Stack, SPS Geometry
Attributes | Calculate Attributes, Display RMS Values Top Window, Display RMS Values Bottom Window, Display Peak Values Top Window, Display Peak Values Bottom Window
Utilities | Detect Dead Traces, Select Traces from Telseis System, QC Link, Pick First Breaks, Vertical Stacking, Spectrum Attributes, Observer’s Log, Single Trace Power Spectrum, Marine QC, Vib Pro Index File, Marine Source Logging

In keeping with our philosophy of increasing product value, Software Sciences will continue to develop new processing modules to meet customer requirements as they are identified.

Data Archiving

Captured data can be stored to disk and/or tape for archival purposes. Tape storage to all standard tape drives including the IBM 3590 drive is currently supported in SEG-D Rev.1 & 2, 8015, 8036, 8048, 8058 and SEG-Y formats.

Data Networking

Utilizing the Windows operating system enables SeisNet to network to other processing workstations operating under UNIX, or Windows.

Details of SeisNet's native disk data format will be made available to users wishing to create input tools to other networked processing systems.

System Block Diagram

Figure SA-1 illustrates the standard interface configuration of the SeisNet system. Other interface configurations are available to allow connection to read after write ports and other custom data buses. The system can also be configured to bypass the tape drive.

Figure SA-1. Standard interface configuration of the SeisNet system.

Data Handling Formats

As a seismic data record is transferred to SeisNet's host computer from either a data capture card, disk or tape, the associated software data input module converts it to a data object format which is then passed from module to module in the processing flow created by the user. The data object structure stores all the information contained in the original shot record including record header and trace headers and the seismic data which is converted to an internal IEEE format.

If data are output to a peripheral device, such as a disk drive, plotter or tape drive, the associated software data output module converts the data object back to either a native format in the case of the disk drive, or the appropriate peripheral device format, in the case of the plotter or tape drive.

Data Processing Flows

Data processing flows are created by the user utilizing the graphical user interface detailed in section 2 of this manual and provide the ability to set up multiple parallel processing tasks which may be conveniently stored and retrieved. A data processing flow consists of user selected processing modules configured and linked in the desired order of process execution.

Multithread Processing

SeisNet's software is designed to utilize the multithread processing capabilities of Windows that enable SeisNet to perform parallel asynchronous processing tasks. Each parallel processing task is assigned a process thread which runs independently and allows data to be handled by differing speed processes and peripherals simultaneously.

Scaleable Multiprocessor Support

SeisNet is designed with scaleable multiprocessor support which enables the utilization of multiprocessor host computers in order to share parallel processing tasks between available processors, thereby achieving optimum speed and data throughput.


User Interface

Seisnet User Interface

Introduction

The SeisNet system user interface is based on a graphical flow design which allows the user to create process flows by simply dropping process modules into a process flow window and linking them in the order in which they are required to be executed. Once a desired process flow has been created the user may save it as a named flow file for future retrieval and use.

Running SeisNet

To execute a flow design, ensure the desired flow design window is active (indicated by the title bar being colored) and select the Execute option from the main menu bar. To stop a flow that is running, select the Kill option from the main menu bar. The result of a flow execution will depend on the flow configuration in terms of the process modules present in the flow and the order in which they are linked. The following paragraphs detail module specific operations and their effect on SeisNet’s overall performance and output.

Interactive Process Modules

The Display Seismic Traces and Attribute Display process modules are interactive, which means that they offer the user the opportunity to manipulate the data object in order to produce the desired display output. This feature is achieved by providing the user with the ability to hold a data object captive until the desired display output is obtained after which the data object may be released and passed on to the next module in the flow.

The mechanism controlling this is the Auto/Manual option in the display window toolbar. When the Manual mode is selected the flow is halted and the various data display manipulation tools are visible in the display window toolbar and active. When the Auto mode is selected the data object is released and passed on to the next module in the flow and the all subsequently captured data objects will be automatically displayed. The data display manipulation tools are inactive whenever the display module is in the Auto mode and are therefore not displayed in this mode.

Potential Impact

An important point to realize and keep in mind when using these display modules is that the flow is effectively halted whenever the user selects the manual setting in order to manipulate the display data. The implication of this is that the data capture process can be halted and data records can be missed. The one exception to this is when the display module resides in a split flow design which only halts a secondary thread and allows the primary thread and hence the data capture process to proceed uninterrupted.

Display Seismic Traces

The Display Trace Data module provides the ability to display user selected traces and to apply filters, AGC and a data mute function. All data manipulation is for display purposes only and does not affect the data object passed on to the next process module in the flow. Note the Control Bar along the top of the display window, which provides various data manipulation tools. These tools are only visible in the manual mode since the data tools are not operative in the auto mode.

Attribute Displays

There are Five process modules related to the attribute display feature as follows:

Calculate Attributes

Display RMS Values Top Window

Display RMS Values Bottom Window

Display Peak Values Top Window

Display Peak Values Bottom Window

In order to display attribute data the user must first insert a Calculate Attributes module into the flow design followed by the desired attribute display module/modules.

On Line Help Facilities

General on line help may be accessed via the help option in the main menu or pressing the F1 key. Context sensitive help is also available by selecting Context Help button in the toolbar, then selecting the item of interest. Process specific help can be accessed by selecting the "H" within each process module.

Process Flow Window

The process flow window is used to store process flows created by the user. Selected process modules are placed in the process flow window, linked and finally executed. Multiple process flow windows can be opened and displayed on screen, however only the one active process window can be executed at a time.


Data Objects

SeisNet Data Objects

As a seismic data record is transferred to SeisNet’s host computer from either a data capture card, disk or tape, the associated software data input module converts it to a data object format which is then passed from module to module in the processing flow created by the user. The data object structure stores all the information contained in the original shot record including record header and trace headers and the seismic data which is converted to an internal IEEE format.

If data is output to a peripheral device, such as a disk drive, plotter or tape drive, the associated software data output module converts the data object back to either a native format or MicroMAX format in the case of the disk drive, or the appropriate peripheral device format in the case of the plotter or tape drive.


Creating Process Flows

Creating Process Flows in SeisNet

Introduction

Setting up process flows is achieved by creating a process flow window containing the required process modules linked in accordance with the desired order of process execution. Each process module has associated parameters that must be set up by the user before the flow is executed. However, in most cases the default parameters will work. The whole creation process can be achieved by mouse operations with the possible exception of parameter that may need to be typed in.

Creating Flows

When the SeisNet program is started a default process flow window named "NEWFLOW1" is displayed. A flow design is created by first selecting the desired process modules from the "Processing" option under the main menu bar. The selected modules and will appear within the "NEWFLOW1" window where they may be repositioned simply by dragging them with the mouse. You may enable the "Grid" option under the toolbar in order to place modules in an orderly fashion within the process flow window.

Inserting Flow Modules

Insert flow modules by using the mouse to select the desired module from the main menu bar "Processing" option drop down list. Once selected, a module will appear in the active flow window.

Flow Module Features

The figure below represents an example flow module with features identified.

Positioning Flow Modules

Modules can be positioned within the flow windows by placing the mouse cursor in the center of the module, holding down the left mouse button and dragging the module to the desired location.

Deleting Flow Modules

Flow modules can be deleted by placing the mouse cursor on the top left corner of the module and pressing the right mouse button.

Linking Flow Modules

Once the desired modules have been placed and arranged within the process flow window they must be linked in the appropriate order by clicking the left mouse key on the link point of a module and dragging a line to the next module in the flow sequence. Practice this process in order to become familiar with the process.

Setting Module Parameters

Once a process flow has been created, parameters must be set up for each of the process modules contained in the process flow before it can be successfully executed. This is achieved by selecting the "P" within each module in order to access the parameter dialog box for the module. The user must then input the appropriate parameters to accomplish the desired process within each module.

Module Help

Select the "H" within each module in order to access help on parameter selection.

Saving Flows

A process flow may be saved at any time by selecting the save to disk icon in the toolbar or the file save option under the main menu bar.

Retrieving Flows

A saved process flow may be retrieved at any time by selecting the open file icon in the toolbar or the open file option under the main menu bar.

Executing Flows

To execute a completed process flow design select the "Execute" option under the main menu bar.

Killing Flows

To stop a flow that is currently running, select the "Kill" option under the main menu bar. A status message will appear in the status bar indicating "Starting thread termination" followed by "Flow running". Once the "Flow running" status disappears the flow has successfully been killed. To check that a flow is no longer running, selecting the "Kill" option a second time should result in the message "No flow is running" display.

Multiple Input Devices

Processing flows can only have one input module. If the data are required to be processed from multiple input devices, separate SeisNet applications may be executed. Note that separate applications cannot be executed to access the same input device simultaneously.

Flow Design Considerations

Each processing module in the SeisNet system can be thought of as a mini-program which takes the output from the previous module, performs the required processing, then passes the data object to the next module in the flow. The ability to use split flow modules provides the advantage of parallel processing but also requires some consideration of the impact on system resources. A flow is split by cloning the data object and creating a new thread of execution that processes the data object clone in parallel to the original data object. This process is totally asynchronous as the cloned data object is stored in extended memory or a Windows NT Paging File until needed by a particular thread. The speed of execution of each flow is dependent on the process modules and peripheral devices involved as well as the host computer configuration in terms of number of processors and hardware performance. In split flow designs involving a relatively slow peripheral device such as a plotter, there is a strong likelihood that data objects will accumulate in the paging file and possibly exceed the space allocated causing an out-of-memory error. This potential problem can be avoided by a combination of system configuration tuning and performance monitoring.

System Configuration Tuning

The host computer configuration will impact the overall performance of the SeisNet system in terms of split flow designs and parallel processing. The following system configuration changes may alleviate problems associated with these processes:

a) | Increasing the amount of extended memory.
b) | Increasing the space allocated to the paging file. Setting up a separate SeisNet application flow for the plotting process using a disk input module instead of utilizing a split flow design.
c) | Setting up a separate SeisNet application flow for the plotting process using a disk input module instead of utilizing a split flow design.

The use of a multiprocessor host computer allows SeisNet’s scaleable design to perform parallel CPU intensive processing tasks with optimum efficiency as these tasks are automatically shared between available processors.

Performance Monitoring

The "Task Manager" program that comes with Windows NT can be used for performance monitoring. You get to "Task Manager" by placing the mouse cursor on the status bar and right clicking. From the pop-up menu, select the "Task Manager" option.

Task manager enables you to monitor and control the computer and what's running on it. The "Applications" tab shows the status of the programs that are currently running on the computer, and from this window, you can end, switch to, or start a program. The "Processes" tab shows information about the processes that are currently running, and from this window, you can end a process. To view other information about a process, click "View" and then click "Select Columns". The "Performance" tab displays a dynamic overview of the computer's performance, including:

Graphs for CPU and memory usage,

The number of items running (including handles, threads, and processes), and

Information about the physical kernel and the amount of committed memory.

You can get even more information on your computer's performance by running the "Performance Monitor" program. The "Performance Monitor" program is started by clicking the "Start" button, selecting "Administrative Tools" followed by the selection of "Performance Monitor". The on-line help tells you how to use the program.


Main Menu

Commands on SeisNet's Main Menu Bar

File

Processing

Tape

Parms

View

Window

Help

Execute

Pause

Kill

Exit


File Menu Commands

The File menu offers the following commands:

New | Creates a new flow.
Open | Opens an existing flow.
Close | Closes an opened flow.
Save | Saves an opened flow using the same file name.
Save As | Saves an opened flow to a specified file name.
Delete Flow | Deletes an existing flow.
Delete Dataset | Deletes an existing dataset.
Print | Prints a flow.
Print Setup | Selects a printer and printer connection.
Delete Tape Log | Erases the tape log file.
Exit | Exits the SeisNet system.


File New command

New command Under SeisNet's File Menu

The first task in setting up a processing flow is to create a new flow and save it with a name that makes sense to you and that will remind you of its contents. SeisNet opens a new, unsaved flow ready for you to start using. If you have already been working with SeisNet, however, you might need to open a new flow.

If there is a flow currently displayed on the computer screen, you do not have to close the current flow to create a new flow. When you create a new flow, SeisNet displays a blank flow on the screen. In order to use the new flow you must drop processing modules into the window representing the flow. Refer to the article Creating Process Flows to learn how to construct a SeisNet processing flow.

While you can have several flows open and displayed on computer screen, only a single flow can be executed. The flow that will be executed, when you click on the Execute button, is the active flow. The active flow is determined by activating the window representing the flow you wish to execute.

You should use the Open command, under SeisNet's file menu to open an existing flow.

There are three ways to create a new flow:

Method #1 employs the shortcut keys CTRL+N. Simply press the CTRL and N keys simultaneously and a new unsaved flow will be created.

Method #2 uses the New option under File on the SeisNet main menu bar.

Method #3 involves clicking on the New icon on the SeisNet toolbar.


File Open command

Open command Under SeisNet's File Menu

You can open a saved flow and display it on the computer screen. This allows you to review and edit an existing flow. Multiple flows can opened and edited, but only a single flow can be executed at a time. When multiple flows are open you can use the Window option on SeisNet's main menu bar to switch among the multiple open flows. See Window 1, 2, ... command

When you request that an existing flow be opened, the following dialog box is displayed. If you cannot see the flow you want to open, make sure that the file type is correct. All flows in SeisNet must have an extension of .FLW. If you think that a flow has been mislabeled, change the file type to "All Files". This will let you see all the files in the currently selected folder.

A new flow can be created with the New command.

There are three ways to open an existing flow:

Method #1 employs the shortcut key CTRL+O. Simply press the CTRL and O keys simultaneously and the above dialog box will be displayed.

Method #2 uses the Open option under File on the SeisNet main menu bar.

Method #3 involves clicking on the Open icon on the SeisNet toolbar.


File Close command

Close command Under SeisNet's File Menu

Use this command to close all windows containing the active flow. The SeisNet system suggests that you save changes to your flow before you close it. If you close a flow without saving, you lose all changes made since the last time you saved it. Before closing an untitled flow, SeisNet displays the Save As dialog box and suggests that you name and save the flow.

You can also close a flow by using the Close icon on the flow's window, as shown below:


File Save command

Save command Under SeisNet's File Menu

The save command is used to save the active flow to its current name and directory. When you save a flow for the first time, the SeisNet system displays the Save As dialog box so you can name your flow. If you want to change the name and directory of an existing flow before you save it, choose the Save As command.

You should save your flow to store it for future use. This lets you later retrieve the flow for reviewing and editing. To avoid losing your work, you should regularly save changes you make to a flow

When you finish working with a flow, you can close the flow to remove it from your screen. You can continue to work with other flows until you exit SeisNet.

You can save a flow using the shortcut keys CTRL+S. Simply press the CTRL and S keys simultaneously and the flow will be closed. Another way to close a flow is to use the Save or Save As commands under SeisNet's File Menu, as shown below:


File Save As command

Save As command Under SeisNet's File Menu

Use this command to save and name the active flow. The SeisNet system displays the "Save As" dialog box when you issue this command. To save a flow with its existing name and directory, use the Save command.

You should save your flow to store it for future use. This lets you later retrieve the flow for reviewing and editing. To avoid losing your work, you should regularly save changes you make to you flow. When you save a flow, you must give it a name. SeisNet my suggest a name for the flow, such as "NEWFLOWX", where X can be any number. It would be best if you named your flow something other than NEWFLOWX. A flow's name should be something that makes sense to you, so that later on you know what it is without having to open and examine it.

A flow's name can have up to 255 characters, including spaces and upper and lower case letters. You cannot use the /, \, <, >, *, ?, ", |, :, or ; characters to name a flow.

When you are finished working with a flow you can close it to remove it from the computer screen. You can continue to work with other flows until you exit SeisNet.


File Delete Flow

Delete Flow command Under SeisNet's File Menu

Use this command to delete an existing flow. You can type-in a flow name, or choose from the list of existing flows shown.

When you choose to delete a flow from your computer's hard disk, the following dialog box is displayed. It is assumed that all of your SeisNet flow have been stored in the same directory, or folder, as the SeisNet executable. This is the default location used to store the flows and it is called the current working directory. If you have flows stored in other locations you will have to use Windows NT Explorer to remove them.


File Delete Dataset

Delete Dataset command Under SeisNet's File Menu

Use this command to delete an existing data set from you hard disk. In SeisNet, a data set is simply a directory, or folder, where a group of seismic data files are stored.

When you click on the Delete Dataset option, a dialog box is displayed that lets you select the data set to be deleted. You can either type in the name of the data set or select one from the list box. The data sets shown in the list box are the folders under the path that is specified in the Input Data Path option under Parms on the Main Menu Bar.

It is a good idea to store all of your data sets under the path you specify for the input data path. This way, they are easy to find and manage. When we configure a system, we normally put the NT operating system and SeisNet on the C: drive and set the input data path to point to a folder on the D: drive. Under NT, the boot drive can not be larger than 2GB. However, there is no practical limit on the size of a non-boot drive. It could be, for example, 280GB if you had 10 physical drives of 28GB each. That is, under NT, a logical drive can span several physical drives.

Recommended configuration for SeisNet follows:

C-Drive

Windows NT Operating System.

SeisNet Program.

D-Drive

Storage of Captured Data. Choose a folder name for the input data path something like <D:\SeisNet\Data>.


File Print command

Print command Under SeisNet's File Menu

Use this command to display the current screen image on the printer. This command presents a Print dialog box, where you may specify the range of pages to be printed, the number of copies, the destination printer, and other printer setup options.

There are three ways to plot the screen image on the printer:

Method #1 employs the shortcut keys CTRL+P. Simply press the CTRL and P keys simultaneously.

Method #2 uses the Print option under File on the SeisNet main menu bar.

Method #3 involves clicking on the Print icon on the SeisNet toolbar.


File Print Setup command

Print Setup command Under SeisNet's File Menu

This command selects the printer and paper setting. The settings you can adjust depend on the printer you have installed. The settings are valid until you exit the SeisNet program. Clicking on the Print Setup command displays a Print Setup dialog box, where you can specify the printer and its settings.


File Delete Tape Log

Delete Tape Log command Under SeisNet's File Menu

This command will delete the file <tapelog.rec> from the directory where the SeisNet executable has been stored. It is noted that some tape output modules do not write tape logging information to the <tapelog.rec> file. For example, the SeisNet module that writes four-component data from the Syntrak recording system writes logging information to a file, whose name is generated from the date of recording. In this case you, you will have to delete the logging file manually, using the Window Explorer program.

SeisNet's standard tape output module does write logging information to the <tapelog.rec> file. When you are archiving data to tape, it is a good idea to keep track of the logging files in your current working directory, so you can delete them when they are no longer needed. The current working directory is by definition the directory, or folder, where the SeisNet executable is stored.

All logging files created by SeisNet are formatted in ASCII, which means that you can read them using Microsoft's Notepad program. Notepad is supplied as part of the NT operating system.


Exit menu command

Exit command Under SeisNet's File Menu or the Exit Selection on SeisNet's Main Menu Bar

The 'Exit' command allows you to exit, or terminate, the SeisNet program. The SeisNet program can be terminated in one of two ways. The first way involves clicking on the 'File' option on SeisNet's Main Menu Bar, and selecting 'Exit' from the drop-down menu, as shown below.

The second way to terminate the SeisNet program is to simply click on the 'Exit' option on SeisNet's Main Menu Bar, as shown below.

When you issue the command to terminate the SeisNet program, a dialog box is displayed asking you if you want to save your flows. If no changes have been made to your flows then you would want to answer 'No'. However, if changes have been made changes, you would want to answer 'Yes'. Selecting 'Cancel' will resume execution of the program. The dialog box that is displayed is shown below.

If you answer 'Yes' in the above dialog box, you will be asked about whether or not to save each of your active flows. An example of such a question, asking if you want to save changes made to the flow named <BadSeg2.FLW>, is shown below.

Answer 'Yes' if you want to save changes made to flow. Otherwise, answer either 'No' or 'Cancel'.


SeisNet's Processing Categories

Data Input | Modules that Input Data into SeisNet
Data Output | Modules that Output Data from SeisNet
Filters | Modules used to Filter the Seismic Data
Display | Modules for Displaying Seismic Traces on the Computer Screen and on the Plotter
Scaling | Modules for Scaling the Data
Stacking | Modules for Geometry and Stacking
Attributes | Modules used for Attribute Analysis
Utilities | General Purpose Utility Modules
Split Flow | Module to Split a Processing Flow
End Module | Debugging Module used as Last Module in Flow


Data Input Under SeisNet's Processing Menu

DC10XX | Data Acquired from the DC10XX Capture Card
Tape | SEG-D Read from SCSI Tape Drive
Disk | Data In Data Object Format Read Hard Disk
DC20 Card | Data Acquired from the DC20 Card Capture Card
Raw Data In/Out | Raw Data from the DC20 Card is Stored on Hard Disk
Raw Data From Disk | Reads Raw Data Stored on Hard Disk
SEG-2 Files from Disk | Reads SEG-2 Files from Hard Disk
SEG-Y Tape Input | Reads SEG-Y Tapes
SEG-Y Disk Input | Reads SEG-Y Files
DC20 to Disk | Captures Data using the DC20 Card and Writes it to Hard Disk.
Synthetic Input | Generates Synthetic Trace Data
Tape Emulator | Emulates Tape Drives for Data Capture
IO RSR SEGY Disk Input | Read SEGY data from a Large Single File
ARAM Aries Disk Input | Reads ARAM Aries Data, SEGY and SEG-D
IO System 4 SEGY Input | Reads IO System 4 SEGY Data from Disk Files


Data Input from the DC10XX Card

SeisNet Module: Data Input DC10XX

The Data Input DC10XX module interfaces SeisNet to Software Sciences, Inc.'s DC10 data capture card. The DC10 capture card is an ISA card that can capture data up to 10 MB/sec and unload it at 1.5 MB/sec.

You may learn more about this module by selecting one of the following:

Desciption

Parameters


Description for Data Input from the DC10XX Card

SeisNet Module: Data Input DC10XX

Description:

The Data Input DC10XX module provides a powerful interface for obtaining data from a seismic recording system using Software Sciences, Inc.'s DC10 data capture card. With this card it is possible to capture data at a rate of 10MB/sec, and unload it at a rate of 1.5MB/sec. The DC10 capture card connects either to the SCSI interface on the recording system or to the read-after-write port on the tape drive. The data are captured as it is being read from or written to the tape drive.

After the data are captured by the DC10 card, it is transferred to the memory on the CPU board over the ISA bus. After the data have been transferred, it is either stored on hard disk or converted to the SeisNet internal format. Data must be formatted in the SeisNet format before it can be processed by SeisNet.

Click Here for Explanation of the Parameters


Parameters for Data Input from the DC10XX Card

SeisNet Module: Data Input DC10XX

Parameters:

The Data Input DC10XX parameters are defined as follows:

Parameter names are shown in the color Green.

Input Parameters -- determines how most of the input parameters are obtained. There are two options: The first is "Get From You" and the second is "Get From Header". The second method is normally the preferred mode of operation. The "Get From You" option allows you to manually set such things as the sampling interval and record length. It is generally used when the header values are incorrect and must be overwritten.

Data Format -- is displayed only when Input Parameters is set to "Get From You". When Data Format is displayed you must select from one of the supported SEG-D formats. Currently, the supported formats are 8058, 8048, 8015 and 8024.

Triggering Method -- determines how end-of-record is determined. When the Triggering Method is set to "Terminal Count Only", the acquisition of data is terminated after a specified number of bytes have been acquired. The number of bytes to acquire is set using the Total Number of Bytes in Record parameter. When the Triggering Method is set to "Timer Only", the acquisition of data is terminated after the SCSI busy signal has been inactive for a specified amount of time. The amount of time the busy signal must be inactive to terminate acquisition is set using the Triggering Timeout parameter. Finally, when the Triggering Method is set to "Terminal Count OR Timer", the termination of acquisition is based on either of the above two conditions, whichever occurs first. The preferred Triggering Method is "Timer Only" with a Triggering Timeout of 0.5 seconds.

Triggering Timeout -- sets the amount of time to wait before termination of data acquisition. It is used when the Triggering Method is either "Timer Only" or "Terminal Count OR Timer".

Sampling Interval -- is the time interval (expressed in seconds) between samples. The Sampling Interval parameter is displayed only when the Input Parameters parameter is set to "Get From You". When you specify a Sampling Interval, the value in the record header is ignored.

Record Length -- is the length (expressed in seconds) of a recorded seismic trace. The Record Length parameter is displayed only when the Input Parameters parameter is set to "Get From You". When you specify the Record Length, the value in the record header is ignored.

System Type -- specifies the type of recording system that was used to acquire the data. Currently, there five types of recording systems supported: "Standard SEG-D", "Standard SEG-D Rev1", "I/O System II", "Syntron SEG-D Rev1" and "Sercel 388". You should choose the System Type that best matches you recording system. Choosing "Standard SEG-D Rev1" as the System Type is normally a good choice for most recording systems.

Total Number of Traces (Data + Aux) -- is the total number of traces in a shot record. This parameter is displayed only when Input Parameters is set to "Get From You".

Number of Bytes in Record Header -- specifies the number of bytes in the SEG-D record header, which is the number of bytes in the general, scan, extended and external headers. This parameter is displayed only when Input Parameters is set to "Get From You".

Total Number of Bytes in Record -- is the total number of byte in a shot record. It includes the all the bytes in the headers and the seismic data.

Number of Sync Bytes -- specifies the number of extra bytes added to end of each trace.

Bytes Between Header and Data -- is the number of bytes placed between the record header and the actual trace data. This value is normally zero.

No. Bytes Between Channel Sets -- is the number of extra bytes placed between the channel sets.

No. Bytes in Trace Header -- is the number of bytes in the trace header. This value is normally 20 for standard SEG-D recording and 52 for SEG-D Rev1 recording.

Check here to ENABLE blind tape copy -- enables a blind tape copy of the captured data. This function is analogous to dual tape copy where a byte-for-byte copy of the data is created. It is useful when the client requires extra copies of the recorded data.

Enter the Data Traces to Process -- allows you to select the data traces to process. The syntax for entering trace numbers is a follows: sel-sel(inc), where sel is a trace number and inc stands for increment. For example, if you were to type: 1,5,10-15, 20-30(2), then traces 1, 5, 10, 11, 12, 13, 14, 15, 20, 22, 24, 26, 28, 30 would be processed.

Enter the Aux Traces to Process -- allows you to select the aux traces to process. The syntax for entering trace numbers is the same as described for parameter Enter the Data Traces to Process.

Click Here to View Description of Module


Data Input from Tape

SeisNet Module: Data Input Tape

The Data Input Tape module is used to read the data stored on magnetic tape in SEG-D format into the SeisNet system.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Data Input from Tape Module

SeisNet Module: Data Input Tape

Description

You can use the Data Input Tape module to input data from tape into the SeisNet system. This module assumes that the data have been stored on tape in one of the following SEG-D formats: 8058, 8048, 3036, 8015 or 8024. After the data is read-in, it is converted to SeisNet's data object format so it can be processed by SeisNet. When logical end-of-tape is reached, you will be given the option to input another tape or exit the program. If you elect to input another tape, the current tape will be rewound and ejected from the drive. You must then insert the next tape to be read.

Click Here for Explanation of the Parameters


Parameters for Data Input from Tape Parms

SeisNet Module: Data Input Tape

Parameters

The parameters for the Data Input Tape module are defined as follows:

Parameter names are shown in the color Green.

Sampling Interval (in seconds) -- is used to specify the sampling interval in seconds. If you choose the Sampling Interval to be "Get From Header", the actual value will be taken from the first block of the general header. If you do not choose "Get From Header", you can choose one of the predefined values. Predefined values are followed by the word "milliseconds". If you choose to type-in a value, do not include the word "milliseconds". For example, to enter three milliseconds for the Sampling Interval, you would type-in 0.003, not 3 milliseconds. Normally, you would want to choose "Get From Header" as the Sampling Interval.

Trace Length (in seconds) -- specifies the length of a trace, expressed in seconds. You can choose to "Get From Header", choose one of the predefined values or type-in a value. Normally, you would want to choose "Get From Header" so that the trace length is taken from the first block of the general header.

Seismic Data Type -- defines the format of the data stored on tape. You must choose on of the types in the drop-down menu or select "Get From Header". When you select "Get From Header", the data format is determined from the first block of the general header. It is recommended that you choose "Get From Header", to let SeisNet determine the data format.

Drive to Read From -- lets you select the tape drive to read. You must select the drive number from those specified in the drop-down menu. SeisNet supports from one to four tape drives, which are identified as: MT0, MT1, MT2 and MT3.

Trace Read Options -- lets you select the amount of data to be processed. You can limit the data input by channel set, data type, FFID, sequential trace number or you can process all the data in a shot record. If you choose to limit you data by channel set you will be asked to enter the channel set numbers of the channel sets to process. If you choose to limit the data to be processed by data type, you will be asked to enter the data traces to process and the aux traces to process. If you choose to limit the number of FFID's to process, you will be asked to enter a list of FFID's. If you choose to limit the amount of data processed by sequential trace number, you will be asked to enter a list of trace numbers. Finally, if you choose to process all the data, then you should select "Read All Data."

Type of recording system -- specifies the type recording system used to record the data. The main reason for having to specify the type of recording system has to do with how the different recording systems handle shot and station numbers.

Check here to Support Super Blocking -- determines if super blocking was employed when the data were recorded on tape. Super blocking is defined in the paper "Digital field tape format standards -- SEG-D, REVISION 1" Geophysics, Vol. 59, No. 4, (April 1994), pages 668-684.

Enter channel sets to read in -- is displayed whenever Trace Read Options is set to "Limit By Channel Set". The syntax for entering channel set number is : sel-sel(inc), where sel is a channel set number and inc is an increment. For example, if you enter 1,2,10-13,20-30(2), then channel sets 1, 2, 10, 11, 12, 13, 20, 22, 24, 26, 28 and 30 would be processed.

Enter data traces to read in -- is displayed whenever Trace Read Options is set to "Limit By Data Type". The syntax for entering the data trace numbers is the same as described under Enter Channel sets to read in above.

Enter aux traces to read in -- is displayed whenever Trace Read Options is set to "Limit By Data Type". The syntax for entering the aux trace number is the same as described under Enter Channel sets to read in above.

Enter FFID's to read in -- is displayed whenever Trace Read Options is set to "Limit By FFID". The syntax for entering the FFID numbers is the same as described under Enter Channel sets to read in above.

Enter sequential trace numbers to read in -- is displayed when ever Trace Read Options is set to "Limit By Seq Trace No". The syntax for entering the trace sequential numbers is the same as described under Enter Channel sets to read in above.

Click Here to View Description of Module.


Data Input from Disk

SeisNet Module: Data Input Disk

The Data Input Disk module is used to input data into SeisNet from hard disk where it was stored in SeisNet's data object format.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Data Input from Disk

SeisNet Module: Data Input Disk

Description

The Data Input Disk module allows you to read data that has been stored on hard disk into the SeisNet system. Data which is stored on hard disk by other modules in the SeisNet system can be read by the Data Input Disk module. Because of the structured format employed by the SeisNet system, data that is stored on disk by other programs cannot normally be read. A data object file can be a shot record, single trace gather, seismic section, or other type of seismic data. The type of data held in a data object is carried internal to the data object.

In normal field recording, each shot record is stored in a separate file. A group of files, in turn, produces a dataset. Therefore, a dataset is nothing more than a directory where a group of files is stored. As an example, consider the pathname:

D:\SSI\DATA\SHOT_RECORDS.

Here <D:\SSI\DATA> is the path to the dataset and <SHOT_RECORDS> is the name of the dataset. To find all the files in the <SHOT_RECORDS> dataset, simply go to the directory <D:\SSI\DATA\SHOT_RECORDS>. Note that the path to the datasets is set under the Parms heading on the main menu. To change the path to the datasets, select the option "Input Data Path" under the Parms heading and either type-in or click on the Browse button to specify a new pathname.

Adopting a naming convention for the file names optimizes sorting of the data. Data object files have an extension of ".SEIS", and when the data stored in the files are shot records, the filename has a particular structure. That structure consists of the five characters: 'FFID_' followed by the field file number. This is followed by the "%" character, which is followed by the number of seconds from one second after midnight January 1, 1970. For example, a shot record with field file number 152 and recorded on September 18, 1996 at 11:37:57, would have the filename:

FFID_152%843068277.SEIS

The number 843068277, is translated by the computer to September 18, 1996 at 11:37:57.

You can choose how you want the files sorted by selecting the sorting method in the parameters dialog box. Sorting can be FFID ascending, FFID Descending, Date Ascending or Date Descending.

Click Here for an Explanation of the Parameters


Parameters for Data Input from Disk Parms

SeisNet Module: Data Input Disk

Parameters

The Data Input Disk parameters are defined as follows:

Parameter names are shown in the color Green.

Name of first file to process -- specifies the name of the first file to process. You can use the Browse button, which brings up the standard Windows file open dialog box, to help you select the first file. It is important to note that when doing real-time processing and no data has yet been acquired in the requested directory, you should choose <DefaultFirstFile> (do not type the < and > symbols) for the name of the first file. The will force SeisNet to accept the first file acquired to be the first file processed.

Sorting method -- determines how the data are sorted for processing. You can choose, "FFID Ascending", "FFID Descending", "Date Ascending" or "Date Descending". Regardless of the Sorting method you choose, the Name of first file to process parameter, above, determines the beginning of the list of files to process. For example, if you choose: 1. A Sorting method of "FFID Ascending", 2. The dataset to process holding files corresponding to FFID's 100, 101, 102, 103 and 104, and 3. You choose the file corresponding to FFID 102 as the first file. Then, files corresponding to FFID's 102, 103 and 104 will be processed.

Click Here to View Description of Module


Data Input from DC20 Card

SeisNet Module: Data Input From DC20 Card

The Data Input From DC20 Card module is used to input data from Software Sciences, Inc.'s DC20 card into the SeisNet system. The DC20 card is a high performance data capture card that can capture data up to 20MB/sec and unload it to memory on the Windows NT motherboard at a rate of up to 70MB/sec. The DC20 capture card sets in a PCI slot on the Windows NT motherboard. To achieve the 70MB/sec unload rate requires dual 450 MHz Pentium processors that are basically idle during the unload process. If you have slower processors and/or a busy system, you will not achieve this unload rate.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Data Input from DC20 Card

SeisNet Module: Data Input From DC20 Card

Description

The DC20 capture card is designed to capture SCSI-2 Fast/Wide data at a sustained rate of 20 Mbytes/sec and consists of a processor card and personality module. The DC-20D personality module provides 8 or 16 bit differential capture, programmable by jumpers on the card. For single ended 8 or 16 bit interfaces the DC-20S personality module must be installed.

Click Here for an Explanation of the Parameters


Parameters for Data Input from DC20 Card

SeisNet Module: Data Input From DC20 Card

Parameters

The Data Input From DC20 Card parameters are defined as follows:

Parameter names are shown in the color Green.

Input Parameters -- determines how most of the input parameters are obtained. There are two options: The first is "Get From You" and the second is "Get From Header". The second method is normally the preferred mode of operation. The "Get From You" option allows you to manually set such things as the sampling interval and record length. It is generally used when the header values are incorrect and must be overwritten.

Data Format -- is displayed only when Input Parameters is set to "Get From You". When Data Format is displayed you must select from one of the supported SEG-D formats. Currently, the supported formats are 8058, 8048, 8015 and 8024.

Triggering Method -- determines how end-of-record is determined. When the Triggering Method is set to "Let DC20 Card Decide" the termination of data acquisition is determined by the DC20 card based on the identification of the different SCSI bus phases. When the Triggering Method is set to "Terminal Count Only", the acquisition of data is terminated after a specified number of bytes have been acquired. The number of bytes to acquire is set using the Total Number of Bytes in Record parameter. When the Triggering Method is set to "Timer Only", the acquisition of data is terminated after the SCSI busy signal has been inactive for a specified amount of time. The amount of time the busy signal must be inactive to terminate acquisition is set using the Triggering Timeout parameter. Finally, when the Triggering Method is set to "Terminal Count OR Timer", the termination of acquisition is based on either of the above two conditions, whichever occurs first. The preferred Triggering Method is "Let DC20 Card Decide".

Triggering Timeout -- sets the amount of time to wait before the termination of data acquisition. It is displayed when the Triggering Method is either "Timer Only" or "Terminal Count OR Timer".

Sampling Interval -- is the time interval (expressed in seconds) between samples. The Sampling Interval parameter is displayed only when the Input Parameters parameter is set to "Get From You". When you specify the Sampling Interval, the value in the record header is ignored.

Record Length -- is the length (expressed in seconds) of a recorded seismic trace. The Record Length parameter is displayed only when the Input Parameters parameter is set to "Get From You". When you specify the Record Length, the value in the record header is ignored.

System Type -- specifies the type of recording system that was used to acquire the data. Currently, there are five types of recording systems supported: "Standard SEG-D", Standard SEG-D Rev1", "I/O System II", "Syntron SEG-D Rev1" and "Sercel 388". You should choose the System Type that best matches your recording system. Choosing "Standard SEG-D Rev1" for the System Type is normally a good choice for most recording systems.

Total Number of Traces (Data + Aux) -- is the total number of traces in a shot record. This parameter is displayed only when Input Parameters is set to "Get From You".

Number of Bytes in Record Header -- specifies the number of bytes in the SEG-D record header, which is the total number of bytes in the general, scan, extended and external header. This parameter is displayed only when Input Parameters is set to "Get From You".

Total Number of Bytes in Record -- is the total number of bytes in a shot record. It includes all the bytes in the record header, the trace headers and the seismic data.

Number of Sync Bytes -- specifies the number of extra bytes added to the end of each trace.

No. Bytes Between Header and Data -- is the number of bytes placed between the record header and the actual trace data. This value is normally zero.

No. Bytes Between Channel Sets -- is the number of extra bytes placed between the channel sets. This value should normally be zero.

No. Bytes in Trace Header -- is the number of bytes in the trace header. This value is normally 20 for standard SEG-D recording and 52 for SEG-D Rev1 recording. This parameter is only displayed when Input Parameters is set to "Get From You".

Check here to LIMIT the record length -- is checked when you want to limit the length of the seismic traces. For example, if the record length is 6.144 seconds and you want to process only the first 4.096 seconds of data, you would check this parameter and enter 4.096 for the Desired Record Length (seconds) parameter. The Desired Record Length (seconds) parameter is displayed only when the Check here to LIMIT the record length parameter is checked. It is a good idea to make your record length a multiple of 1.024 seconds to be compatible with the SEG-D standard.

Desired Record Length (seconds) -- lets you limit the length (expressed in seconds) of a trace that is processed. This parameter is displayed only when the Check here to LIMIT the record length parameter is checked.

Check here to ENABLE blind tape copy -- enables a blind tape copy of the captured data. This function is analogous to dual tape copy where a byte-for-byte copy of the data is created. This function is very useful when the client requires extra copies of the recorded data.

Enter Trace Numbers for Data Traces to Process -- allows you to select the data traces to process. The syntax for entering trace numbers is as follows: sel-sel(int), where sel is a trace number and inc stands for increment. For example, if you were to type: 1,5,10-15,20-30(20), then data traces 1, 5, 10, 11, 12, 13, 14, 15, 20, 22, 24, 26, 28, and 30 would be processed.

Enter Trace Numbers for Aux Traces to Process -- allows you to select the aux traces to process. The syntax for entering trace numbers is the same as described for the parameter Enter Trace Numbers for Data Traces to Process.

Click Here to View Description of Module


Raw Data From DC20 Card Stored on Disk

SeisNet Module: Raw Data From DC20 Card Stored on Disk

The Raw Data From DC20 Card Stored on Disk module is used to take the data captured by the DC20 and write it to hard disk. The data stored on disk is a memory image of the data captured by the DC20 card. That is, the data are simply transferred from memory on the DC20 card to a directory that you specify. Because this module does not format the data to SeisNet's data object format, it cannot pass the data to the next module in the flow. Therefore, this module is stand-alone and cannot be a part of normal SeisNet flow. This module exists strictly to enhance performance; there is no faster way to get data from the DC20 card and stored on hard disk.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Raw Data From DC20 Card Stored on Disk

SeisNet Module: Raw Data From DC20 Card Stored On Disk

Description

The "Raw Data From DC20 Card Stored on Disk" module is a stand-alone module that takes data captured by the DC20 card and stores it on hard disk. It was developed to optimize the task of capturing data and writing it to hard disk. As a consequence of the optimization, no error checking is performed after the data have been acquired. The data are simply taken from the DC20 card and written to hard disk. The module or program that reads the raw data from files stored on disk must perform the error detection and correction. A short record that occurs because of a bad spot on the tape is an example of such an error.

Data storage can be on a local or network drive. You specify where the data are stored when you enter the directory name for data storage.

The "Raw Data From DC20 Card Stored on Disk" module is given the highest priority over all other processes running on the system. This means that anytime the module is placed into a flow, it will be executed regardless of any other modules in the flow. Furthermore, it is executed with the highest priority in the system. Other processes, including additional SeisNet programs, will run at lower priorities than the process holding this module.

Click Here for an Explanation of the Parameters


Parameters for Raw Data From DC20 Card Stored on Disk

SeisNet Module: Raw Data From DC20 Card Stored on Disk

Parameters

The parameters for the Raw Data From DC20 Card Stored on Disk are defined as follows:

Parameter names are shown in the color Green.

Triggering Method -- determines how end-of-record is determined. When the Triggering Method is set to "Let DC20 Card Decide" the termination of data acquisition is determined by the DC20 card based on the identification of the different SCSI bus phases. When the Triggering Method is set to "Terminal Count Only", the acquisition of data is terminated after a specified number of bytes have been acquired. The number of bytes to acquire is set using the Total Number of Bytes in Record parameter. When the Triggering Method is set to "Timer Only", the acquisition of data is terminated after the SCSI busy signal has been inactive for a specified amount of time. The amount of time the busy signal must be inactive to terminate acquisition is set using the Triggering Timeout parameter. Finally, when the Triggering Method is set to "Terminal Count OR Timer", the termination of acquisition is based on either of the above two conditions, whichever occurs first. The preferred Triggering Method is "Let DC20 Card Decide".

Number of Bytes in Record -- is the total number of bytes in the shot record. It is displayed only when the Triggering Method is either "Terminal Count Only" or "Terminal Count OR Timer".

Triggering Timeout (in seconds) -- sets the amount of time to wait before termination of data acquisition. It is used when the Triggering Method is either "Timer Only" or "Terminal Count OR Timer".

Directory Where to Store the Data -- lets you specify the directory (or folder) of where to store the captured data. Simply type-in the name of the directory where the data are to be stored. This can be either a network or local drive. If the directory does not exist, it will be created.

Click Here to View Description of Module


Read Raw Data From Hard Disk

SeisNet Module: Read Raw Data From Hard Disk

The Read Raw Data From Hard Disk module reads the raw data files that have been stored on hard disk. These files are normally created by other SeisNet modules, such as the “Tape Emulator” module.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of the Read Raw Data From Hard Disk Module

SeisNet Module: Read Raw Data From Hard Disk

Description

The Read Raw Data From Hard Disk module is an input module that reads the .RAW SEG-D image files stored on hard disk by the Tape Emulator module.

All of the raw data files in the tape reel directory you specify are sorted from the oldest to the most current. You specify the first file to read, and all subsequent files are read sequentially. When the last file has been read, the system will search for the next sequential reel directory and continues on until all reels and files have been processed or the program flow is either killed or exited by the user.

Most input parameters will be determined automatically by SeisNet. However, the ability to enter certain parameters manually is also provided for situations where SeisNet cannot decode the parameters directly from the data.

When you are setting the parameters for this module and you select the System Type to be "Syntron SEG-D Rev 1", a check box is displayed asking you if you want to copy the raw data file to tape. Placing a check mark in this check box will tell the system to copy the raw data file to tape. A log of the records written to tape is kept in the file <tapelog.rec> in the current working directory. You can view this file, as the data are being written to tape, by double clicking on the "tapelog" filename in Windows Explorer.

Click Here for an Explanation of the Parameters


Parameters for the Read Raw Data From Hard Disk Module

SeisNet Module: Read Raw Data From Hard Disk

Parameters

The Read Raw Data From Hard parameters are defined as follows:

Parameter names are shown in the color Green.

Enter Name of First File to Read -- specifies the first raw data file to be read. The easiest way to obtain the first file's name is to use the browse button at the right side of the edit box. When you click on the browse button the standard file open dialog box appears. Select the directory and file desired and click on the open button.

Input Parameters -- allows you to set the way in which input parameters are determined. You must select either "Get From Header" or "Get From You" from the drop-down menu. The "Get From Header" option is the preferred mode of operation. Only use the "Get From You" option when SeisNet cannot correctly decode the SEG-D headers.

System Type -- tells the SeisNet system about the recording system used to record the data so that the headers can be decoded correctly. This is a drop down menu selection and you must choose one from the list of supported systems. When you choose the System Type to be "Syntron SEG-D Rev 1", a check box is displayed asking you if you want to copy the raw data file to tape. Placing a check mark in the check box enables the option to save the raw data file to tape. A log of the records stored on tape is kept in the file <tapelog.rec>, which can be found in the current working directory. You can view this log file as the data are being processed using Windows Explorer. The program Notepad that is shipped with Windows is a convenient program for viewing the log file.

Data Type -- allows you to select from the different types of SEG-D data that was stored on the hard disk. Currently, the supported formats are: 8058, 8048, 8015 and 8024. You can select the Data Type only when Input Parameters is set to "Get From You".

Total Number Traces (data + aux) -- sets the total number of traces stored in a file. This number includes both data and aux traces. You can select the Total Number Traces (data + Aux) only when Input Parameters is set to "Get From You".

Number of Bytes in Record Header -- is the total number of bytes in the SEG-D record header. This number is the total number of bytes in the general , scan, extended and external headers. You can select the Number of Bytes in Record Header only when Input Parameters is set to "Get From You".

No. Bytes Between Header and Data -- is the number of extra bytes that may occur between the record header and the trace data. This number is almost always zero. You can select the No. Bytes Between Header and Data only when Input Parameters is set to "Get From You".

Sampling Interval -- is the time between samples expressed in seconds. You can select the Sampling Interval only when Input Parameters is set to "Get From You".

Record Length -- is the length of a seismic trace expressed in seconds. You can select the Record Length only when Input Parameters is set to "Get From You".

No. Bytes Between Chan Sets -- is the number of extra bytes that can occur between channel sets. This number is almost always zero. You can select the No. Bytes Between Chan Sets only when Input Parameters is set to "Get From You".

Number of Sync Bytes -- is the number of extra bytes that can occur between the traces. This number is normally zero, but it could be different from zero if an extra sample has been appended to the end of each trace. You can select Number of Sync Bytes only when Input Parameters is set to "Get From You".

No. of Bytes in Trace Header -- is the number of bytes in the trace header. It is 20 for standard SEG-D recording. It can be 52 or greater for SEG-D Rev1 recording. You can select the No. of Bytes in Trace Header only when Input Parameters is set to "Get From You".

Check here if you want to copy the raw data file to tape -- lets you copy the raw data file to tape. This option is displayed only when System Type is set to "Syntron SEG-D Rev1". When this option is selected, you basically get a byte-for-byte copy of the data that was written to tape by the Syntrak recording system.

Check here to limit the length of trace inserted in the data object -- allows you to limit the length of the traces stored in the data object created by this input module. If you check this box, you will be asked to enter the Desired Trace Length (seconds).

Desired Trace Length (seconds) -- sets the length of the trace that will be stored in the data object. If you enter a number here that is greater than the original trace length, it will be ignored.

File Extension on the RAW Data Files – selects the file extension on the RAW data files that are to be processed by SeisNet.

Check here if the data are formatted with block data files – is checked when block data files are present that have been created by the SeisNet “Tape Emulator” module. The block data files are very useful when have data acquired with varying sampling intervals and/or variable trace lengths.

Check here to force sort on FFID’s – will force the sorting of how the RAW data files are sequenced for processing to be based on the FFID. Normally, the sorting is performed on the time of acquisition, but when this parameter is checked the sorting is based on the FFID.

Enter Trace Numbers for Data Traces to Process -- is used to limit the traces that get processed by the SeisNet system. You specify the trace sequential to process by entering either individual trace numbers, trace number ranges or a trace number ranges with an increment. For example, if you entered "1,5,7,8,22-25, 30-33,40-50(2), 60-70(3), then traces "1,5,7,8,22,23,24,25,30,31,32,33,40,42,44, 46,48,50,60,63,66,69" would be selected. Traces selected that are unavailable will be ignored. For example, if you choose traces "1-9999" and only have traces "1-120" available, then only traces "1-120" will be processed.

Enter Trace Number for Aux Traces to Process trace numbers of the Aux traces to process. See explanation above for Enter Trace Numbers for Data Traces to Process for how to specify the aux trace numbers to process.

Click Here to View Description of Module


Data Input SEG-2 Files From Disk

SeisNet Module: SEG-2 Files From Disk

The SEG-2 Files From Disk module reads SEG-2 files that were created on disk into the SeisNet system. Normally, the recording system writes to a local hard drive on the SeisNet system using a 100-Base-T network. SeisNet then creates the data tapes.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description for Data Input SEG-2 Files From OYO DAS Module

SeisNet Module: SEG-2 Files From Disk

Description

The SEG-2 Files From Disk module allows you to read data that has been stored on hard disk by the recording system into the SeisNet system. Normally, the recording system writes data on the hard disk via a network interface. That is, the recorder is connected to the SeisNet system over either a 10-Base-T or 100-Base-T cable.

It is assumed that each shot record is written in a differenct file. The file naming conventon used by the recorder consists of a five to eight character filename followed by the extension ".DAT". The first four characters of the filename are "FILE" and the last one to four characters are the Field File Identification Number, FFID. For example, a file named:

FILE1234.DAT

holds a shot record that has an FFID of 1234.

The file written by the recording system is formatted according to the recommended standard from the Society of Exploration Geophysicist for seismic (/radar) data files on a personal computer. This format is known as the SEG-2 format and it is documented in the publication:"Geophysics" Vol. 55, No. 9, September 1990.

Before the recording system can write data to a network drive, a directory on that drive must exist. As a consequence, when you specify a directory for locating the SEG-2 files to be read by this module. The directory will be created if it does not already exist.

You have the option of specifying the name of the first file to be read. If you do not specify this first file, then the file with the oldest date will be read. After the first file specified is processed, the file that has the next to oldest date will be processed. Remember that the order in which the files are processed is based on the files creation dates. They are processed from the oldest to the youngest.

Click Here for an Explanation of the Parameters


Parameters for Input SEG-2 Files From OYO DAS Module

SeisNet Module: SEG-2 Files From Disk

Parameters

The SEG-2 Files From Disk parameters are defined as follows:

Parameter names are shown in the color Green.

Enter the Directory Name where the SEG-2 Files are stored -- specifies where the recorder writes, and the SeisNet system, reads the data. Because the recording system cannot create a directory, the directory you specify here will be created if it does not already exist.

Enter Name of First File to Read -- specifies the first SEG-2 file to be read. The easiest way to obtain the first file's name is to use the browse button at the right side of the edit box for this option. When you click on the browse button the standard file open dialog box appears. Select the directory and file desired and click on the open button. The name of the directory for locating the SEG-2 files is automatically updated when you use the browse button.

Click Here to View Description of Module


SEG-Y Data Read From Tape Module

SeisNet Module: SEG-Y Data Read From Tape

The SEG-Y Data Read From Tape module reads data that has been stored on tape in the SEG-Y format into the SeisNet system. The SEG-Y tape standard is explained in the publication "digital tape standards", published by the Society of Exploration Geophysicists.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description for SEG-Y Read From Tape Module

SeisNet Module: SEG-Y Data Read From Tape

Description

The SEG-Y Data Read From Tape module reads data that has been stored on tape in the SEG-Y format into the SeisNet system. The drive used for data input can be selected when that is more than one drive connected to the SeisNet system. In addition, you have the capability to limit (based on FFID) the amount of data processed by SeisNet.

As the data are read from tape, it is converted from the SEG-Y format to SeisNet's internal data object format. The SEG-Y standard is explained in the publication "digital tape standards" published by the Society of Exploration Geophysicists. SeisNet can only process data that is formatted in its own internal format.

Click Here for an Explanation of the Parameters


Parameters for SEG-Y Data Read From Tape Module

SeisNet Module: SEG-Y Data Read From Tape

Parameters

The SEG-Y Data Read From Tape parameters are defined as follows:

Parameter names are shown in the color Green.

Drive to read from -- specifies the number of the tape drive number that holds the SEG-Y tape. The SeisNet system supports from one to four tape drives that are identified as MT0, MT1, MT2 and MT3. You must select one of these from the drop-down menu.

Data is sorted on tape by -- tells SeisNet how the data has been stored on tape. The sort order can be either shot records, cdp gathers or seismic sections. If you choose Data is sorted on tape by to be "FFID, Shot Records", then you will be given the option to limit the amount of data processed based on the FFID number.

Check here to limit input based on FFID -- is displayed whenever Data is sorted on tape by is set to "FFID, Shot Records". If you check this option, you will be asked to enter a list of FFID's to process.

Enter list of FFID's to process -- is displayed whenever you choose Data is sorted on type by to be "FFID, Shot Records" and Check here to limit input based on FFID has been checked. The syntax for selecting the FFID's to process is: sel-sel(inc), where sel is an FFID number and inc is an increment. For example, if you were to type-in 1,5,10-15, 20-30(2), then FFID's 1, 5, 10, 11, 12, 13, 14, 15, 20, 22, 24, 26, 28 and 30 would be processed.

Click Here to View Descripton of Module


SEG-Y Data Read From Disk

SeisNet Module: SEG-Y Data Read From Disk

The SEG-Y Data Read From Disk module reads data that has been stored on hard disk in the SEG-Y format into the SeisNet system. It is assumed that each shot record is stored in a separate file. The format of the stored data is assumed to be the same as that for tape, but without the inter-block gaps.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of SEG-Y Data Read From Disk Module

SeisNet Module: SEG-Y Data Read From Disk

Description

The SEG-Y Data Read From Disk module reads data from hard disk, that is in the SEG-Y format, into the SeisNet system. It is assumed that a file contains a single shot record. The format of the stored data is assumed to be the same as the SEG-Y tape format, but without the inter-block gaps.

The files are ordered according to date before being read. That is, the oldest file is read first, the next to oldest file next, etc. You can choose a particular file to read-in and the next file read will be the next file that is slightly younger than the chosen file. The thing to remember is that the files are read in ascending order based on date.

Click Here for an Explanation of the Parameters


Parameters for SEG-Y Data Read From Disk Module

SeisNet Module: SEG-Y Data Read From Disk

Parameters

The SEG-Y Data Read From Disk parameters are defined as follows:

Parameter names are shown in the color Green.

Enter name of the first file to process -- specifies the first file to process. You can use the Browse button to help you locate the name of the file. When you click on the Browse button, the standard windows file dialog box appears and you simply point-and-click until you locate the required file. If you want SeisNet to choose the name of the first file to process, then create a file named "Undefined" in the directory where the SEG-Y files are stored or where they will be stored.

Click Here to View Description of Module


Tape Copy

SeisNet Module: DC20 To Disk

This module automatically captures data, using the DC20 card, from a recording system and writes it to hard disk. You can make either single or dual copies.

To learn more about this module select one of the following:

Description

Parameters


Description of Tape Copy Module

SeisNet Module: DC20 To Disk

Description

The DC20 To Disk module provides the ability to write data files, captured by the DC20 card, to disk. Files are written as SEG-D image files with a .RAW extension. The tape reel number is read from the header of each captured file and a TAPEXXXX.REEL directory is created on the D: (and E: drive if dual write option selected) to contain the individual .RAW files.

When the system detects that the reel number has changed, an EOT.RAW file is written to the current TAPEXXXX.REEL directory to indicate that it is complete and the new TAPEXXXX.REEL directory is created to contain the new reel .RAW data files.

The EOT.RAW file is utilized by the SeisNet system to identify the last file of each reel and allow it to auto increment to the next sequential reel for data display purposes.

Whenever the operator exits the SeisNet application containing the DC20 To Disk module, an EOT.RAW file is written to the current data directory, assuming no further data will be written to that reel. Data can however be appended to a particular reel by manually deleting the EOT.RAW file in that directory.

Recommended Flow Configuration

In order to maximize capture reliability, it is recommended that the flow containing the DC20 To Disk module be kept as simple as possible and consist only of the DC20 To Disk followed by an End Module. The create SeisNet Data Object option should also be disabled for the same reason.

Click Here for Explanation of the Parameters


Parameters for Tape Copy Module

SeisNet Module: DC20 To Disk

Parameters

The parameters for the DC20 To Disk module are defined as follows:

Parameter names are shown in the color Green.

Single Hard Drive -- is selected if captured data is to be written to only one hard drive (Default Setting). By default the data will be written to the D: drive when the single drive option is selected otherwise the system will assume that two drives are available and write to drives D: & E:

Type of Seismic Recording System – selects the host recording system from the list of supported systems.

Timer Trigger – is selected to enable record gap detection based on timer setting. The default for this option is off which allows the DC20 capture card to determine record gaps based on File Mark detection for optimum efficiency and reliability in cases where inter-record gap times are varying. When Timer Trigger is selected, a parameter entry box appears in which the user can specify the timeout value (in seconds). The timeout value refers to the duration of inactivity on the SCSI bus that will be interpreted as the end of a record in order to initiate the capture card unload and re-arm ready for the next file capture. This option is primarily a diagnostic tool and would not be used in normal operation.

Create SeisNet Data Object – select this option only in the case where a display module is placed in the flow after the DC20 To Disk module. The most efficient/recommended DC20 To Disk flow is with only a DC20 To Disk module followed by an End Module, in which case the Create SeisNet Data Object option would not be selected . By not creating the SeisNet Data Object, overhead is minimized for applications where large file sizes and short cycle times present a potential data capture hazard. Inclusion of a display module in the DC20 To Disk flow also creates the potential hazard of halting the data capture function by placing the display module in manual mode. Data displays can be achieved most efficiently by starting a second SeisNet application with a flow consisting of a Raw Data From Disk module followed by a Display module, in which case the DC20 To Disk flow will automatically have priority over the secondary Raw Data/Display flow and the capture to disk function is most reliable.

Enable RAM Data Buffering – Enables 4 Record RAM buffer which reduces potential impact of varying recorder cycle times.

Click Here to View Description of Module.


Tape Copy

SeisNet Module: Synthetic Input

Work in Progress.

To learn more about this module select one of the following:

Description

Parameters


Description of Tape Copy Module

SeisNet Module: Synthetic Input

Description

Work in Progress.

Click Here for Explanation of the Parameters


Parameters for Tape Copy Module

SeisNet Module: Synthetic Input

Parameters

Click Here to View Description of Module.


Tape Copy

SeisNet Module: Tape Emulator

This module provides the capability to emulate 3590 or 3490 tape drives and write data Direct to Disk at increased data rates up to 40 MB/Sec.

To learn more about this module select one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: Tape Emulator

Description

The Tape Emulator module provides Direct to Disk recording capability by emulating 3590 or 3490 tape drives. Data files are recorded to hard disk in Tape Reel directories as SEG-D Image files and can then be ported via network for processing and archived to tape or other media. Advantages include increased data transfer rates (up to 40MB/Sec), which may allow faster recording cycle timing and increased production, elimination of tape drive related production problems and Read After Write quality assurance.

Files are written to disk with unique names in the form:

Rxxxxxx_yyyyyyyyyy.RAW

where xxxxxx represents the file number (FFID) & yyyyyyyyyy represents a computer time stamp. This ensures that duplicated file numbers will not result in overwritten data.

E.g. R001063_1118376542.RAW would represent file number 1063 at a precise time.

The corresponding blocking information files, if enabled, would take the form:

R001063_1118376542.BLK

These .BLK files are used by SeisNet’s TapeArchiveBLK utility to ensure exact duplication of the recording system’s tape blocking scheme when creating archive tapes.

The Tape Reel directory naming format is:

TAPExxxx.REEL where xxxx represents the reel number decoded from the record header of the captured file.

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: Tape Emulator

Parameters

The parameters dialog box for the Tape Emulator module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Type of Recording System -- Select type of recording system from a drop down list including all major systems currently in use.

Number of directories to keep for data storage -- This parameter determines how many Tape Reel directories will be maintained on disk and is basically limited by the hard disk drive size available. Once the selected number has been achieved, the oldest Tape Reel directory is deleted as a new one is created, thereby maintaining the most recent Tape Reel directories on disk. Directory names are created in the form: TAPExxxx.REEL where xxxx is the reel number decoded from the record header. Note: The default value 9999 disables any automatic directory deletion.

Generate a SeisNet Data Object – Creates a reformatted data object for use by additional modules in the data flow such as the Correlator or Data Display modules. The default setting is OFF.

Archive Data to Hard Disk in .RAW Format -- Stores data in .RAW format in Tape Reel directories on the system D: drive. The default setting is ON

Generate Blocking Information File – Stores blocking information file in Tape Reel directories on the system D: drive. The file name matches the corresponding .RAW file but with a .BLK extension. These blocking information files are used by SeisNet’s TapeArchiveBLK utility to assure correct tape output blocking and assist in error diagnostics. The default setting is OFF

Choose Directory for Data Archival – This option allows the user to specify a directory to which all captured data will be written. The default setting is OFF

Click Here to View Description of Module


Processing Utilities Detect Bad Traces command

SeisNet Module: IO RSR SEGY Disk Input

The “IO RSR SEGY Disk Input” module reads SEGY data from a single large file, that was created with the IO RSR recording system. Shot records are parsed sequentially from the large SEGY file and placed into a SeisNet data object for processing. An option exists that permits the selection of particular shot records (based on the FFID) to be processed.

You may learn more about this module by selecting one of the following:

Description

Parameters


Processing Utilities Detect Bad Traces Description

SeisNet Module: IO RSR SEGY Disk Input

Description

The “IO RSR SEGY Disk Input” module is an input module that reads SEGY data from a single large SEGY file that has been stored on hard disk. The data is assumed to have been recorded using an IO RSR recording system. This module is specific to the RSR recording system because of where parameters such as line and receiver numbers are stored in the SEGY trace headers.

When the RSR recording system stores shot records, it places them in a single large file in the SEGY format. The “IO RSR SEGY Disk Input” module parses shot records sequentially from the large SEGY file. After reading a single shot record from the large SEGY file, it is reformatted and placed in a SeisNet data object to be processed. An option exists that permits the selection of particular shot records (based on the FFID) to be processed. There is no practical limit on the size of the large SEGY file.

While the large SEGY file can be very large, it is assumed that all the traces that have been stored in the SEGY file are of the same length. That is, the same number of bytes is assumed to be in each and every trace. This is necessary to be able to sequence thru the data quickly.

Click Here for an Explanation of the Parameters


Processing Utilities Detect Bad Traces Parms

SeisNet Module: IO RSR SEGY Disk Input

Parameters

The “IO RSR SEGY Disk Input” parameters are defined as follows:

Parameter names are shown in the color Green.

This above figure shows an example of a filled-out parameters dialog box for the “IO RSR SEGY Disk Input” module.

Enter name of the SEGY file to process – specifies the name of the large SEGY file holding the shot records to process. The easiest way to input this file name is to use the browse button at the right side of the edit box holding the file name. When you click on the browse button, the standard windows file open dialog box is displayed. Select the name of the directory and file you want to process and click on the Open button.

Enter name of the Log File – identifies the file name and the location of where the log file will be created. You can use the associated Browse Button to open a standard “File Open” windows dialog box. The format of the log file is fixed column, where: FFID is in columns 1-6, Number of Traces in Shot Record is in columns 8-14, Source Line Number is in columns 16-27, Source Station Number is in columns 29-40, and the Shot ID (a unique number that identifies the shot) is in columns 42-52. All values are Right Justified within the specified columns. You should use only fixed-spaced fonts in a display program like “Microsoft’s Notepad” so that the columns line-up correctly. If you use Proportional spaced fonts, which is normally the default”, the columns may have a jagged appearance.

Enter the FFID’s you want to Process – is used to limit the shot records (based on the FFID) that get processed. The FFID’s you want processed is determined by what you enter in this parameter’s edit box. You specify the FFID’s to process by entering either individual FFID numbers, FFID number ranges or FFID number ranges with and increment. For example, if you entered “1, 5, 7, 8, 22-25, 30-33, 40-50(2), 60-70(3), then FFID’s “1, 5, 7, 8, 22, 23, 24, 25, 30, 31, 32, 33, 40, 42, 44, 46, 48, 50, 60 ,63, 66, 69 would be processed. FFID’s selected that are unavailable will be ignored. For example, if you choose FFID’s “1-9999” to be processed and only FFID’s “10-120” were store in the SEGY file, then only FFID’s “10-120” would be processed.

Click Here to View Description of Module


Processing Utilities Detect Bad Traces command

SeisNet Module: ARAM Aries Disk Input

The “ARAM Aries Disk Input” module reads

You may learn more about this module by selecting one of the following:

Description

Parameters


Processing Utilities Detect Bad Traces Description

SeisNet Module: ARAM Aries Disk Input

Description

The “ARAM Aries Disk Input” module is an input module

Click Here for an Explanation of the Parameters


Processing Utilities Detect Bad Traces Parms

SeisNet Module: ARAM Aries Disk Input

Parameters

The “IO RSR SEGY Disk Input” parameters are defined as follows:

Parameter names are shown in the color Green.

Enter name of the SEGY file to process – specifies

Enter name of the Log File – identifies

Enter the FFID’s you want to Process – is used

Click Here to View Description of Module


Processing Utilities Detect Bad Traces command

SeisNet Module: IO System 4 SEGY Input

The “IO System 4 SEGY Input” module reads SEGY data that was recorded with the either the Scorpion or System Four recording systems from hard disk files.

You may learn more about this module by selecting one of the following:

Description

Parameters


Processing Utilities Detect Bad Traces Description

SeisNet Module: IO System 4 SEGY INPUT

Description

The “IO System 4 SEGY Input” module is an input module that reads SEGY data from hard disk files that have been created with either the Scorpion or System Four recording systems. It is assumed that the shot records have been stored in individual files that have “.SGY” extensions, and Reel Identification headers at the beginning of each file.

Each file is read by this module and converted to a SeisNet data object where it can be processed by other SeisNet modules. Information, such as the FFID and time stamp, is obtained from the first trace to build the data object. The Reel Identification header is stored in the record header of the SeisNet data object and the SEGY trace headers are stored in the data object’s trace headers.

It is important to note that the order in which the files are processed is based on the FFID found in the header of the first trace. The files will be processed beginning with the name of the first file specified in the parameter’s dialog box. The FFID of the first file is determined, and all other files are processed in increasing order of the FFID.

Click Here for an Explanation of the Parameters


Processing Utilities Detect Bad Traces Parms

SeisNet Module: IO System 4 SEGY Input

Parameters

The “IO System 4 SEGY Input” parameters are defined as follows:

Parameter names are shown in the color Green.

Directory and Name of the First File to process – identifies the directory where the SEGY files are located and the name of the first file to process. You can use the Browse button for point-and-click operation. Files are processed in increasing order of the FFID, starting with the FFID of the first file selected.

Click Here to View Description of Module


Data Output Under SeisNet's Processing Menu

Disk | Hard Disk in SeisNet's Data Object Format
Tape | Tape in SEG-D 8048 or 8058 Format
MicroMax Dataset | Hard Disk in MicroMax Format
Tape with Verify | Tape in SEG-D Format with Verify Option
Tape Output Chk EOD Then Verify | Check for EOD before Writing to Tape. Has Option for Data Verification.
Tape for Syntron 4C Split Recording | Tape for use with Syntron's 4C Recording System
Tape for I/O 2 Split Recording | Tape for use with the I/O 2 Recording System
Disk Output in SEG-Y Format | Data Stored on Hard Disk in SEG-Y Format
GeoRes Tape Output | Tape Output for GeoRes Recording System
SEG-D Tape Image to Disk | Stores Tape Image of SEG-D data on Hard Disk


Data Output Disk Module

SeisNet Module: Data Output Disk

The Data Output Disk module stores seismic data on hard disk in SeisNet's internal data object format. You must specify the name of a directory or folder of where you want the data stored. The Browse button can be used for point-and-click operation.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Data Output Disk Module

SeisNet Module: Data Output Disk

Description

The Data Output Disk module is used to store seismic data, that is in SeisNet's internal data object format, on hard disk. A data object file can be a shot record, single trace gather, seismic section, or other type of seismic data. The type of data is carried internal in the data object. In normal field recording, each shot record is stored in a separate file, and a group of files, in turn, produces a dataset. Therefore, a dataset is nothing more than a directory, or folder, where a group of files is stored. As an example, consider the pathname:

D:\SSI\DATA\SHOT_RECORDS.

Here <D:\SSI\DATA> is the path to the dataset and <SHOT_RECORDS> is the name of the dataset. To find all the files in the <SHOT_RECORDS> dataset, simply go to the directory <D:\SSI\DATA\SHOT_RECORDS>. Note that the default path to the datasets is set under the Parms heading on the main menu bar. To change the default path to the datasets, select the option "Input Data Path" under the Parms heading and either type-in or click on the Browse button to specify a new pathname.

A naming convention as been adopted for naming SeisNet data object files. This convention is useful because it optimizes data sorting. Data object file have an extension of ".SEIS", and when the data stored in the files are shot records, the filename has a particular structure. That structure consists of the five characters: 'FFID_' followed by the field file number, FFID. This is followed by the '%' character, which is followed by the number of seconds from one second after midnight January 1, 1970. For example, a shot record with an FFID of 152 and recorded on September 18, 1996 at 11:37:57, would have the filename:

FFID_152%843068277.SEIS.

The number 843068277, is translated by the computer to September 18, 1996 at 11:37:57.

Click Here for an Explanation of the Parameters


Parameters for Data Output Disk Module

SeisNet Module: Data Output Disk

Parameters

The Data Output Disk parameters are defined as follows:

Parameter names are shown in the color Green.

Type-in the name of the folder (directory) where to store the data files -- tells SeisNet where to store the data. You can click on the Browse button for point-and-click operation. Note that you are specifying a directory or folder and not a particular file.

Click Here to View Description of Module


Data Output Tape Module

SeisNet Module: Data Output Tape

The Data Output Tape module is used to archive data to magnetic tape. You can choose to output data in either SEG-D 8048 or SEG-D 8058 format.

You may learn more about this module selecting one of the following:

Description

Parameters


Description of Data Output Tape Module

SeisNet Module: Data Output Tape

Description

The Data Output Tape module is used to archive seismic data to tape. You can choose the tape drive where the data are archived. SeisNet supports from one to four tape drives. If you have more that one drive connected to SeisNet, you can hot swap to another drive when the current drive becomes full. Hot swapping means that an unload command is issued to the current drive and data is immediately written to the next available drive. Therefore, when hot swapping is enabled, you do not have to wait for the current drive to rewind and unload before the data can be archived. SeisNet simply switchs drives and continues on.

When data are archived to tape, it can be stored in either the SEG-D 8048 or SEG-D 8058 format. Furthermore, the SEG-D headers generated for the data can either be derived from an internal procedure or from the original SEG-D headers. It is recommended that you choose to derive the archived SEG-D headers form the original SEG-D header whenever possible. You may have to use the internal procedure if the data were input to SeisNet over a network using SEG-2 files. This is because there are no SEG-D headers in a SEG-2 file. Whenever possible, SeisNet will store the orginal SEG-D headers in its data object.

You also have the capability to generate a log file for the data archived to tape. If you choose to generate a log file, it will be stored in the same directory as the SeisNet executable, and it will be named <tapelog.rec>.

Click Here for an Explanation of the Parameters


Parameters for Data Output Tape Module

SeisNet Module: Data Output Tape

Parameters

The Data Output Tape parameters are defined as follows:

Parameter names are shown in the color Green.

Tape drive, where to send data -- specifies the tape drive where the data are archived. SeisNet can have up to four tape drives, which are MT0, MT1, MT2 and MT3. You must choose one from the list in the drop-down menu. If more than an single drive is connected to the SeisNet system and the Check here to Enable Hot swapping of drives when EOT is reached is checked, then the next available drive with will automatically be selected when the current drive becomes full.

Format of output data -- determines the format of the data when it is archived to tape. There are two supported formats, which "SEG-D 8048" and "SEG-D 8058". Both are 32-bit formats, but the 8058 format is generally preferred, because it has better resolution and it is the standard I.E.E.E. floating point format used by most computers today.

Source of SEG-D headers to use for the output tape -- tells SeisNet how to generate the SEG-D headers for the archived data. If possible, you should select "Original SEG-D Headers" for this parameter because SeisNet stores the original SEG-D headers in its data object. When data is input from SEG-2 files, you will have to choose "Internal Structure" for this parameter, because SEG-2 files do not have SEG-D headers.

Check here to Enable Hot swapping of drives when EOT is reached -- enables the hot swapping of drives when the current tape drive becomes full. Obviously, there must be more than one drive to enable hot swapping. If only a single drive is connected to SeisNet and you enable hot swapping, the request to hot swap will be ignored. When the current drive becomes full, SeisNet will issue a command to rewind and unload the current drive and immediately start writing to the next available drive. This will be done without waiting for the current drive to unload.

Check here to generate log of records written to tape -- is an option, that when enabled (checked), that will generate a log of the data written to tape. The file holding the log is named <tapelog.rec> is stored in the directory that holds the SeisNet executable.

Click Here to View Description of Module


Output MicroMax Dataset Module

SeisNet Module: Output MicroMAX Dataset

The Output MicroMAX Dataset module write data to hard disk in MicroMAX (a trademark of Advance Geophysical) format. You have the option to add extensions, that were defined by Western Geophysical, to the MicroMax dataset by selecting the add Western extensions option.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Output MicroMax Dataset Module

SeisNet Module: Output MicroMAX Dataset

Description

The Output MicroMAX Dataset module is used for the creation of MicroMAX datasets, with possible Western Geophysical extensions. When you choose to create MicroMAX datasets, it is not necessary to generate all the MicroMAX files. You can, for example, choose not to create the file (DAT file) that holds the actual trace data, which saves a tremendous amount of disk space when you only want the MicroMAX header files. The Western Geophysical extension files (the HD3 and HD4 files) will not be created when you disable the option to create them. The MicroMAX main header file (the HD1 file) and the MicroMAX trace header file (the HD2 file) are always created.

Whenever data are input to the SeisNet system, they are immediately converted to an internal format called a data object. The Output MicroMAX Dataset module takes data stored in the data object, converts it to MicroMAX format and stores it in files on hard disk. The hard disks can be located on the local computer or on a network drive. You choose where the data are stored by specifying a directory name.

In addition to the standard MicroMAX files, two additional files representing the Western Geophysical extensions can be created. The first additional file, the HD3 file, holds the original SEG-D record headers, and the second additional file holds the original SEG-D trace headers for the traces that are stored in the data object.

A scheme has been established for automatically creating and limiting the number of shots stored in any particular MicroMAX dataset. That scheme consists of naming the datasets from both your input and software naming counter. You supply the first part of the dataset name and the SeisNet system appends additional characters derived from the naming counter. When the requested number of shots stored in a dataset is reached, the naming counter is incremented by one and a new dataset is created.

Click Here for an Explanation of the Parameters


Parameters for Output MicroMax Dataset Module

SeisNet Module: Output MicroMAX Dataset

Parameters

The Output MicroMAX Dataset parameters are defined as follows:

Parameter names are shown in the color Green.

Directory Where to Store MicroMAX Dataset -- allows you to specify where the MicroMax datasets will be stored. For example, if you type-in "G:\SSI\Data" for the directory name and the G: drive is a network drive, then the MicroMAX dataset will be created on a remote computer. The remote computer does not necessarily have to be another Windows NT machine, it could be a networked Unix machine.

User Supplied Part of the MicroMAX Dataset Name -- is your part of the MicroMAX dataset name. It is probably a good idea to keep your dataset names short, because the older MicroMAX software does not support long filenames. One to five characters are recommended, because the value of the naming counter is appended to your part of the dataset name. Windows NT and most Unix systems support the longer filenames, while DOS and Windows 3.1 do not. To see how the MicroMAX datasets are named, consider the following example where the directory name is "G:\SSI\Data". Your part of the dataset name is "test", the naming counter is set at 12, you have chosen to create the Western extensions, and you want to store the trace data. Then, the following files are created:

G:\SSI\Data\test12.HD1, the MicroMAX main header file,

G:\SSI\Data\test12.HD2, the MicroMAX trace header file,

G:\SSI\Data\test12.DAT, the MicroMAX trace data file,

G:\SSI\Data\test12.HD3, the Western Geophysical HD3 file, and

G:\SSI\Data\test12.HD4, the Western Geophysical HD4 file.

Maximum Number of Shots to Store in a Dataset -- is the maximum number of shots to store in a single MicroMAX dataset. A new dataset is created when the number of shots specified here has been stored in the currently selected dataset.

Starting Value of the Naming Counter -- is the starting value of the naming counter. If the value you specify here represents a full dataset, as determined by the Maximum Number of Shots to Store in a Dataset parameter, the value of the naming counter will be incremented by one. In other words, the SeisNet system will not destroy old MicroMAX datasets, even when you specify a bad value for the naming counter. The SeisNet system will keep incrementing the naming counter until it finds or creates a valid dataset name.

Beginning Trace Time (in seconds) -- is the time of the first sample stored.

Ending Trace Time (in seconds) -- is the time of the last sample stored.

Check here to create the Western extensions -- determines whether or not to create the additional files representing the Western Geophysical extensions. The default condition is to create the Western extensions.

Check here if you want to only create the header files -- determines whether or not to create the trace data file. If you only want the header files, then this check box should be checked. The default is NOT checked, which means that the trace data file will be created.

Click Here to View Description of Module


Tape Output with Verify Module

SeisNet Module: Tape Output with Verify

The Tape Output with Verify module provides you with the capability to ensure that your seismic data is correctly stored on magnetic tape. This is accomplished by selecting specific records to be verified.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Tape Output with Verify Module

SeisNet Module: Tape Output with Verify

Description

The "Tape Output with Verify" module provides you with the capability to ensure that your seismic data is correctly stored on magnetic tape. This is accomplished by selecting specific shot records to be verified. The record just written to tape is compared with what is stored in the computer's memory. When an error is detected, a message is displayed informing you of the error.

Regardless of whether or not an error is detected, the verified record is always plotted on either a plotter or LaserJet printer. The format of the plot is easily tailored to meet your specific needs. You have the capability to apply filter, mutes and other playback processing functions.

When the "Do NOT Plot Data" option for the type of plotter is selected, the data will be written to tape, but no verification will be performed. Furthermore, no plots will be generated.

When filling-in the parameter property sheets, you will observe that some parameters are only requested when you choose a particular type of plotter. For example, choosing "HP LaserJet' as the plotter type results in you being asked for the number of pages in the horizontal and vertical directions. If the plotter type is not "HP LaserJet", then you will be asked for the number of traces per inch to plot and the fields asking you for the number of pages in the horizontal and vertical directions will not be displayed.

You can use this module to write data to magnetic tape without verification by simply selecting "Do NOT Plot Data" as the type of plotter. When the "Do NOT Plot Data" option is selected as the plotter type, the only parameters that have meaning are listed on the "Tape" property page.

Particular traces can be selected for plotting by enabling the option to limit the number of traces plotted. When you choose to limit the number of traces plotted, you must type-in the sequential trace number of the traces to be plotted. For example, to plot every 10th trace, you might type-in something like: 1-9999(5).

It is generally not necessary to verify every record written to tape. You can choose the particular shot records to verify by enabling the option to limit the FFID's plotted. If, for example, you wanted to verify and plot every 20th record, you would type-in something like this

1-9999(20),

which says to plot every 20th record. The formula used to determine if a shot record is to be verified is:

if the (FFID - 1) is divisible by the increment ,

then the record is verified. In the above example, the increment is 20, and if the FFID of the shot record is one of the following: 1,21,41, ..., 9981, it will be verified.

There are several options for processing the data before it is plotted. The data can be scaled using either an AGC operator, the RMS value of each trace, the RMS value of a particular trace or the average RMS value of all the traces. The aux traces are always scaled on the peak value of each trace.

Options are available for applying lowpass, highpass and notch filters. When a particular filtering operation is requested, edit boxes are displayed for you to enter the filter parameters. For example, if you check the box to apply a highcut (or lowpass) filter, three edit boxes appear asking you to enter the cutoff frequency, the filter slope and the phase response of the filter.

An automatic mute can be applied to remove the noise at the beginning of the trace. To achieve optimum results when using the automatic mute, you may have to play around with the automatic mute threshold. Generally, the default value of 3.0 gives pretty good results.

The parameters for the "Tape Output with Verify" module are listed on six different property pages:

Tape - holds the parameters specific to how the data is to be written to tape.

Display - holds the parameters needed for creating the plot. The parameters on this property page include the trace overlap factor, display method, number of timing lines, trace annotation increment, minimum and maximum times to display, and number of traces per inch.

Processing - holds the parameters used to process the data before plotting. Here you choose such things as the polarity, whether or not to interpolate between samples, whether or not to apply a T-ramp and the type of filtering to apply.

Scaling - is the property page that sets the scaling parameters for plotting the trace data, including options to apply an AGC operator, scaling on the RMS value of each trace, a particular trace, or scaling on the average RMS value of the entire record.

Info/Mute - sets the mute function for plotting the trace data. This property also has fields for entering information that gets printed on the side label.

Attribute - determines whether or not you want to automatically scale the attribute data displayed beneath the seismic data (cannot display attribute data when the plotter type is an "HP LaserJet"). This property page also has a parameter that lets you set the type of annotation for the trace data.

Click Here for an Explanation of the Parameters


Parameters for Tape Output with Verify Module

SeisNet Module: Tape Output with Verify

Parameters

The Tape Output with Verify parameters are defined as follows:

Parameter names are shown in the color Green.

Parameters on the "Tape" Property Page

Tape Drive ID, where to send the data -- identifies the ID of the tape drive of where to write the data. The SeisNet system supports from zero to four tape drives. Obviously, there must be at least one tape drive connected to the SeisNet system to store data on magnetic tape. Tape drives connected to the SeisNet system are identified as either, "MT0, Drive #1", "MT1, Drive #2", "MT2, Drive #3", or "MT3, Drive #4". If there is only one drive connected to the system, then it will be identified as "MT0, Drive #1". When more than one drive is connected to the system, you can choose the drive where the data are stored from the supplied list.

Format of the output data -- determines the format of the data stored on magnetic tape. SeisNet supports two output formats. The supported formats are SEG-D Rev1 8048 and 8058. The paper "Digital field tape format standards - SEG-D, REVISION 1", Geophysics , vol. 59, (April 1994) explains these formats in detail.

Source of where to get information to build the SEG-D headers -- tells SeisNet where to information to build the SEG-D record and trace headers. When the data source is either a DC10 or DC20 capture card, the original SEG-D headers are stored in the SeisNet data object and can be used to create the headers for the data written to tape. However, if the data come from a source such as a SEG-2 file, there are no original SEG-D headers and you should set this parameter to "Internal Structure".

Check here to Enable Hot Swapping of drives when EOT is reached -- enables the option to hot swap the tape drives when the media on one drive is filled. In order for this option to work, you must have more than one tape drive connected to the SeisNet system. In addition, the tape drives must be able to accept the command to rewind and unload immediately. If the tape drives you are using do not support the rewind and unload immediately command, hot swapping will not improve your cycle time.

Check here to generate a log of the records written to tape. Filename <tapelog.rec> -- enables the option to generate a log of the records written to tape. The name of the log file is <tapelog.rec> and is located in the current working directory.

Parameters on the "Display" Property Sheet

Trace overlap factor -- controls the amount that one trace is permitted to overlap another before clipping occurs. There are several pre-defined values that you can choose by simply clicking the left mouse button. If you want a value different from those that are pre-defined, you will have to type-in the desired value.

Display method -- determines how the data are to be displayed. You only have two choices, which are "Wiggle Trace" amd "Variable Area". If you type-in something, it must be either "Wiggle Trace" or "Variable Area". It is much easier if you simply use the left mouse button to make you choice.

Number of Timing lines -- sets the number of timing lines that will be generated when the data are displayed on the plotter or HP LaserJet. You can choose from several predefined values by simply clicking the left mouse button. If you want a value different from those that are predefined, you will have to type-in the desired value.

Trace annotation increment -- determines how often the traces are annotated. There are several predefined values that you can choose from by simpley clicking the left mouse button. If you want a value different from one of the predefined values, you will have to type it in.

Minimum time to display (in seconds) -- is the parameter that set the minimum time that gets plotted. This parameter has units of seconds. You can choose from the list of predefined values or type-in one.

Maximum time to display (in seconds) -- is the parameter that sets the maximum time that gets plotted. This parameter has units of seconds. You can choose a value from the list of predefined values or you can type-in one.

Number of traces per inch to plot -- determines the spacing between the traces when they are plotted. This parameter is displayed only when the plot is being generated on a V80 compatible plotter., and it has no meaning when the plot is being generated on an HP LaserJet. You can choose a value from the predefined list or you can type-in a value.

Number of pages horizontally -- sets the number of pages the plot will span in the horizontal direction when the plot is being generated on an HP LaserJet. This parameter is only displayed when the plotter type is "HP LaserJet" You can choose a value from the pre-defined list or type one in.

Number of pages vertically -- sets the number of pages the plot will span in the vertically direction when the plot is being generated on an HP LaserJet. This parameter is only displayed when the plotter type is "HP LaserJet". You can choose a value from the pre-defined list or type one in.

Attribute to display at the bottom of the plot -- lets you select whether or not to plot an attribute at the bottom of the plot. You can plot either RMS or peak values from either the top or bottom time window. You can also choose not to plot an attribute at the bottom of the plot. You should make you selection using the left mouse button. This parameter is only valid when the plot is being generate on a V80 compatible plotter. You cannot display attributes on the plot when the plot is being generated on an HP LaserJet.

Plotter type -- tells SeisNet the type of plotter to use when generating the check plots. You should choose a type from the list of supported plotter, using the left mouse button. Note that if you choose a plotter type of "Do NOT Plot Data", then NO verification of the data will be performed and NO check plots will be generated.

Check here to reverse the order that the traces are plotted -- is the parameter that determines if the traces are plotted in reverse order. This option is only available when plotting on V80 compatible plotters. It is not displayed when the check plot is being generated on an HP LaserJet. Normally, sequential trace number one is plotted first. When this option is enabled the last trace is plotted first.

Check here if you want to limit the number of traces plotted -- is an option that lets you choose the trace that get plotted. If you enable this option an edit box appears asking you to enter the sequential trace numbers to be processed.

Enter the sequential trace numbers to be processed -- allows you to specify the traces to be plotted. This parameters is available only when the option to limit the number of traces plotted is enabled. The format for selecting the trace numbers is sel#-sel#(inc). For example, if you enter the string "3,5,20-25,30-40(2)", then the following traces will be plotted: 3,5,20, 31, 22, 23, 24,25, 30, 32, 34, 36, 38, 40.

Check here if you want limit the FFID's plotted -- is an option that lets you specify which shot records are verified an plotted. When this option is enabled an edit box is displayed asking you to type-in the FFID's you want verified an processed. If this option is disabled, then every shot record will be verified and plotted.

Enter the list of FFID's to Plot -- allows you to specify the FFID's of the shot records you want to plot. For example, when you enter "3,5,100-110(2), the shot records with FFID's 3, 5, 100, 102, 104, 106, 108, 110 will be verified an plotted. If you wanted, for example, to verify and plot every 10th record you might enter something like: 1-9999(10).

Parameters on the "Processing" Property Page

Polarity (normal or Reverse) -- determines the polarity of the data for plotting. There are two choices for the polarity. They are "Normal" and "Reverse". Use the left mouse button to make the choice. The data are multiplied by a minus one prior to plotting when you select "Reverse".

Interpolate Data (Yes or No) -- is set to "Yes" when you want to interpolate values between samples. If you select "Yes", inter-sample values will be calculated using a fourth order polynomial. Otherwise, the nearest sample is chosen.

Apply T-ramp (Yes or No) -- is a parameter that when set to "Yes" will tell SeisNet to multiply each trace in the data object by time before it is displayed. This feature is useful for observing events when scaling is based on the RMS value of a trace or traces.

Check here to apply a highcut (lowpass) filter -- is a check box that you will check when you want SeisNet to apply a lowpass filter before displaying the data. Note that the filtering operation does not affect the data in the data object. When this module filter the data, it is for plotting purposes only.

Highcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highcut filter. There are several predefined choices that you can select from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a lowpass filter.

Highcut slope (in dB/Octave) -- sets the roll-off rate of the lowpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a lowpass filter.

Highcut phase (Zero or Minimum) -- determines the phase response of the lowpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a lowpass filter.

Check here to apply a low-cut (highpass) filter -- is a check box that you will check when you want SeisNet to apply a highpass filter before displaying the data. Note that the filtering operation does not affect the data in the data object. When the data are filtered by this module, it is for plotting purposes only.

Lowcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the lowcut filter. There are several predefined choices that you can select from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut slope (in dB/Octave) -- sets the roll-off rate of the highpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut phase (Zero or Minimum) -- determines the phase response of the highpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a highpass filter.

Check here to apply a notch filter -- is a check box that you will check when you want SeisNet to apply a notch filter before displaying the data. Note that the filtering operation does not affect the data in the data object. When the data are filtered by this module, it is for plotting purposes only.

Notch frequency (in Hz) -- sets the notch filter frequency. You can choose either 60Hz or 50Hz from the predefined values, or you can type-in a different value. This parameter is only available when you choose to apply a notch filter.

Parameters on the "Scaling" Property Page

Check here to apply an AGC operator to each data trace -- is a check box that you check if you want to apply an AGC operator to your data. When this parameter is in the checked state, an edit box is displayed asking you to enter the operator length in seconds.

Enter the AGC operator length (in seconds) -- is displayed only when you request that an AGC operator be applied to the data. This is where you type-in the length of the AGC operator, expressed in seconds. Good values for the length of the AGC operator normally lie between 0.25 and 0.5 seconds.

Check here to scale on the RMS value of each individual trace -- is a check box that you check if you want to scale on the RMS value of each individual trace. When this box is in the checked state, each trace is divided by the RMS value of that trace before it is displayed.

Check here to scale on the RMS value of a particular trace -- is a check box that you mark if you want to scale all the traces by the RMS value of a particular trace. When this parameter is in the checked state, an edit box is displayed where you enter the sequential trace number of the trace you want to scale on.

Enter the sequential trace number to scale on -- is displayed only when you request that the data be scaled on a particular trace. You type-in the sequential trace number that you want to use for scaling. This can be used, for example, when you place an oscillator on say channel 1 and scale all the other traces by the RMS value of channel 1. This is a very convenient means for checking on such things as wind noise.

Check here to scale on the average RMS value of the entire dataset -- is a check box that you mark when you want to scale every data trace in the data object by the average RMS value of the entire dataset. The scaling factor is determined by averaging the RMS values of all the data traces in the data object.

Enter gain to apply to entire record -- is a number that multiplies every sample in every trace after all other scaling has been done. The default value of 1.0 is normally the best value for this parameter. This parameter serves the same purpose as the contrast and intensity button on your television.

Parameters on the "Info/Mute" Property Page

Check here and NO mute function will be applied to the data -- is a check box that you will check when you do not want to apply a mute function. When this parameter is in the checked state, no mute will be applied to the data.

Check here to apply an automatic mute to the data -- is a check box that you will check when you want to automatically mute the data. The automatic mute function works by calculating amplitude ratios and zeroing-out all the data until a threshold is met. The value of the threshold is determined by you, which you type-in.

Automatic mute threshold -- sets the automatic mute threshold. A value of 3.0 seems to work pretty good for most marine situations. You may have to experiment to get the best value for the data you are processing. There are some predefined values from which you can choose. If none of these values are to your liking, you can type-in a different value. This parameters is only available when you choose to apply an automatic mute.

Client -- is where you type-in the client's name, which gets printed on the side label of the plot.

Contractor -- is where you type-in the contractor's name, which gets printed on the side label of the plot.

Prospect -- is where you type-in the name of the prospect, which gets printed on the side label of the plot.

Area -- is where you type-in the area name, which gets printed on the side label of the plot.

Crew -- is where you type-in the crew name, which gets printed on the side label of the plot.

I.D. Info -- is where you type-in other identification information, which get printed on the side label of the plot.

Parameters on the "Attribute" Property Page

Check here to auto scale the attribute plot displayed at the bottom of the page -- is an option for automatically scaling the attribute plot located beneath the seismic data when you choose the option to plot an attribute with the seismic data. This parameter only has meaning when the type of plotter is NOT an HP LaserJet. No attributes can be displayed at when a plot is generated on an HP LaserJet. This parameter is simply ignored when the plotter type is "HP LaserJet".

Enter the minimum value to display for the attribute data -- is the minimum value that will be displayed for the attribute data displayed beneath the seismic data. This option is only valid when you choose to display and attribute and the option to automatically scale the attribute plot has been disabled. This parameter has no meaning when the plotter type is "HP LaserJet".

Enter the maximum value to display for the attribute data -- is the maximum value that will be displayed for the attribute data displayed beneath the seismic data. This option is valid only when you choose to display an attribute and the option to automatically scale the attribute plot has been disabled. This parameter has no meaning when the plotter type is "HP LaserJet".

Type of annotation at top of display -- determines the type of annotation at the top of the display. The bottom row numbers is always the sequential trace number. However, the top row of numbers is determined by the option you choose for this parameter. If you choose the "Channel Set # - Trace #" option, the channel set number and the trace number within the channel set will be displayed. But, if you choose the "Receiver Line # - Station #" option, the Receiver Line Number and the Receiver Station Number on the line will be displayed. You must be acquiring data from a recording system that has the line and station numbers in the headers to use the "Receiver Line # - Station #" option. Otherwise, the annotations will have no meaning.

Click Here to View Description of Module


Tape Output Chk EOD Then Verify Module

SeisNet Module: Tape Output Chk EOD Then Verify

The “Tape Output Chk EOD Then Verify” module is used to archive seismic data to magnetic tape. End-Of-Data, EOD, is always located before the record is written to tape. This insures that the module will not overwrite any previously recorded data. Furthermore, an option is available that will verify that the record was written to tape without errors.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Tape Output Chk EOD Then Verify

SeisNet Module: Tape Output Chk EOD Then Verify

Description

The “Tape Output Chk EOD Then Verify” module is used to archive seismic data to tape. This module insures that any previously recorded data will not be overwritten by searching for End-Of-Data, EOD, before the data is written to tape. In addition, an option exists that provides you with the capability to ensure that the data is correctly stored on tape. When the verify option is enabled, the record just written is read and compared with what was originally written to tape. Every byte that was stored on tape is compared in this manner. If an error is detected, the tape will be ejected and you will be asked to insert a new tape.

If there are multiple tape drives connected to the SeisNet system, you have the option of hot swapping when the End-Of-Tape, EOT, is reached. Hot swapping means that an unload command is issued to the current drive and the data is immediately written to the next available drive. When hot swapping is enabled, you do not have to wait for the current drive to rewind and unload before the data can be written to tape. SeisNet simply switches drives and continues on. Hot swapping is available only when there a multiple tape drives connected to the system. The SeisNet system will support up to four tape drives.

When data are written to tape, it can be stored in either the SEG-D 8048 or SEG-D 8058 format. If there is header information available from the recording system, it is used to construct the record and trace headers of the data written to tape.

Every time a record is stored on tape an entry is made in a log file. You must specify the name of the log file. If one is not specified, the logging information will be stored in a file called <tapelog.rec> in the current working directory, which is, the directory where the SeisNet executable is stored. When specifying the name of the log file, you can type-in a fully qualified file name or you can click on the “Browse” button to bring up the standard Windows file dialog box.

Click Here for an Explanation of the Parameters


Parameters for Tape Output Chk EOD Then Verify

SeisNet Module: Tape Output Chk EOD Then Verify

Parameters

The “Tape Output Chk EOD Then Verify” parameters are defined as follows:

Parameter names are shown in the color Green.

Initial Drive to user for Writing – lets you choose the first tape drive to use for writing data. You choose the initial tape drive by clicking on one of the radio buttons displayed. If only a single drive is connected to the system, only one radio button will be displayed. When there are multiple drives connected to the system, you will be permitted to select only one from the list of available drives. A particular drive is selected by clicking on the radio button next to the text describing the drive.

Output Data Format – determines the format of the data that is stored on tape. You can choose either “SEG-D 8048” or “SEG-D 8058”. Both are 32-bit formats, but the 8058 format is generally preferred, because it has better resolution and it is the standard I.E.E.E. floating point format used by most computers. You select the output format by clicking on the radio button next to the text describing the format.

Check here to enable hot swapping of drives when (EOT) is reached – enables the hot swapping of tape drives when End-Of-Tape is reached on the current drive. Obviously, there must be multiple drives connected to the system to enable hot swapping. If you only have a single drive connected an you request that hot swapping be enabled, the request will be ignored. Hot swapping means that when the current drives becomes full, SeisNet will issue a command to rewind and unload the current drive and immediately start writing to the next available drive. This is done without waiting for the current drive to unload. To enable hot swapping, simple place a check in the box next to the text asking you if you want to hot swap the drives.

Check here to verify record after it has been written to tape – is an option that lets you verify that the data has been correctly written to tape. Reading the record just written and comparing it with what was actually written is the procedure used to accomplish this task. Placing a check in the box next to the text asking if you want to verify the record written to tape will enable the verify option.

Enter name of the tape log file – allows you to specify the name of the log file. You can either type-in a fully qualified (path and file name) name or you can click on the “Browse” button. When you click on the “Browse” button, the standard Windows file dialog box is displayed, from which you can specify an existing file or create a new one.

Click Here to View Description of Module


Tape Output Syntron 4C Split Recording

SeisNet Module: Tape for Syntron 4C Split Recording.

The Tape for Syntron 4C Split Recording module provides the capability to create two component data from four component data recorded with the Syntrak recording system. You have options to hot swap tape drives when the current drive becomes full and to super block the data for increased performance.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Tape Output Syntron 4C Split Recording

SeisNet Module: Tape for Syntron 4C Split Recording

Description:

The Tape for Syntron 4C Split Recording gives you the capability to generate 2C data from 4C data recorded on the Syntrak recording system. However, you are not limited to just creating 2C datasets. You can, for example, create a tape that contains only vertical geophone data. The type of data archived to tape is selected by simply clicking on a button in the parameters dialog box. Any combination of data types that were recorded on the Syntrak can be archived to tape using this module.

Options for hot swapping tape drives and super blocking are supported. Hot swapping means that when the current drive becomes full, an unload command is issued to the current drive and data is immediately written to another drive. You do not have to wait for the current drive to unload before writing the next record to tape. Obviously, you must have more than one drive connected to SeisNet for hot swapping to be enabled. Super blocking allows you to write more than one trace to tape at a time. Both hot swapping and super blocking are employed to enhance performance.

For documentation purposes, we list the sensor codes used by Syntron to identify the different types data:

1 ==> Hydrophone,

2 ==> Vertical Geophone,

3 ==> Auxiliary,

4 ==> Inline Geophone

5 ==> Crossline Geophone.

SeisNet uses the same sensor codes as employed by Syntron to identify the different sensor types. The sensor type is found in byte 21 (one based) of the second block of the trace header on Syntron systems.

Click Here for an Explanation of the Parameters


Processing Tape with Verify Parms

SeisNet Module: Tape for Syntron 4C Split Recording

Parameters:

The Tape for Syntron 4C Split Recording parameters are defined as follows:

Parameter names are shown in the color Green.

Type of Sensor Data to Store on Tape -- lets you choose the type of sensor data that gets written to tape. Simply place a checkmark next to the type of sensor data you want to archive. For example, if you check only the Hydrophone sensor type, then only those traces that come from hydrophone sensors will be written to tape.

Primary Drive -- allows you to set the tape drive that will designate the primary drive. The first shot record written to tape will be written to the primary drive. If you have specified a secondary drive, data will be written to the secondary drive when the first drive becomes full.

Secondary Drive -- allows you to set the tape drive that will designate the secondary drive.

Superblocking -- lets you choose the type of super blocking to use when writing data to tape. Super blocking is where you write several traces to tape at a time. If you want to super block to greater than 64KB, you must make sure that the SCSI controller you are using can support blocks greater than 64KB.

Synchronize tape changes with the Syntrak -- is an option that will force a tape change whenever a tape change occurs on the Syntrak recording system. To detect a tape change, SeisNet looks at the reel number in the record header. If this reel number changes, then a tape change is performed on the SeisNet system.

Maximum number of shot records to store on a single tape -- tells SeisNet to force a tape change when the number you specify here is reached. Normally, you will want to make this a big number, say something like 500 or greater, so that tape changes are synchronized with those on the Syntrak.

Click Here to View Description of Module


Tape Output I/O 2 Split Recording Module

SeisNet Module: Tape for I/O 2 Split Recording.

The Tape for I/O 2 Split Recording module provides the capability to create two component, or other user selected sensor configuration, data tapes from four component sensor data recorded on the I/O 2 recording system. Provisions are also provided to correct station numbering and shear phone polarity for complex OBC cable layout configurations involving direction changes such as U shape layouts.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of Tape Output I/O 2 Split Recording

SeisNet Module: Tape for I/O 2 Split Recording.

Description:

The Tape for I/O 2 Split Recording module provides the capability to create two component, or other user selected sensor configuration, data tapes from four component sensor data recorded on the I/O 2 recording system. Provisions are also provided to correct station numbering and shear phone polarity for complex OBC cable layout configurations involving direction changes such as U shape layouts.

There is an option for enabling dual tape recording, which is the archival of two datasets to tape. For example, you can record the hydrophone and vertical geophone data to one tape and the inline and crossline data to another tape. In addition, it is possible to hot swap tape drives during data recording. Obviously, if you are doing dual recording and hot swapping tape drives, you will four tape drives connected to the SeisNet system. If you are not doing dual recording and you want to hot swap, you will need only two tape drives. Finally, if you are not doing dual recording and you are not hot swapping, then you will only need one tape drive.

When data is passed from this module to the next module in the flow, you can sort the traces in the SeisNet data object so that data from a particular sensor type are grouped together. This is very useful when you want to display the data after it has been recorded to tape. Displaying OBC data with the different sensor types inter-mixed generally yields a very poor looking display.

Tape changes can be synchronized with those on the I/O 2 system. SeisNet decodes the reel number found in the record header, and when it changes a tape change operation is started. If you disable the tape synchronization option, then the number of shots specified in the Records per tape parameter will be stored on tape before a tape change is made.

Click Here for an Explanation of the Parameters


Parameters for Tape Output I/O 2 Split Recording Module

SeisNet Module: Tape for I/O 2 Split Recording.

Parameters:

The Tape Output I/O 2 Split Recording parameters are defined as follows:

Parameter names are shown in the color Green.

Records per tape -- is the number of shot records required to be written to tape before switching tape drives. Note: If the Synchronize tape changes with the recording system option is enabled, synchronous tape switching with the I/O 2 recording system will occur irrespective of the Records per tape setting.

Dual tape recording -- allows for selected sensor configurations to be output to two different tape drives simultaneously. Sensor configurations are selected independently for each of the two datasets. Thus, allowing optimum flexibility in tape output. This option is enabled when the check box is checked.

Enable hot swapping of the tape drives -- enables auto-switching between tape drives when multiple tape drives are connected to the SeisNet system. This option is enabled when the check box is checked.

Manually select traces for this data set -- allows you to manually select the traces to be written to tape. The syntax for entering trace numbers is: sel-sel(inc), where sel is a trace number and inc is an increment. For example, if you enter 1,5,10-15,20-30(2), then traces 1, 5, 10, 11, 12, 13, 14, 15, 20, 22, 24, 26, 28 and 30 would be written to tape.

Select the tape drives to use for this data set -- allows you to select the tape drive or drives to use for archiving this data set. You must choose an item from the drop-down menu.

Select type of sensor data to be written for this data set -- allows you to select the type of sensor data that is written to tape for this data set. You must choose an item from the drop-down menu.

Cable configuration buttons -- provides the capability to configure up to eight cables, with up to four segments per cable. It is assumed that all the data from a single cable is configured into a single channel set.

Sort the traces in the SeisNet data object by sensor type -- sorts the data passed to the next module in the flow by sensor type. The option is enabled when the check box is checked.

Suppress the writing of data to tape -- disables the writing of data to tape. This option is intended for test purposes when initially setting parameters. Generally, a trace display module follows this module when setting up a flow. The option is enabled when the check box is checked.

Synchronize tape changes with the recording system -- is used to synchronize tape changes with those on the I/O 2 recording system. If this option is enabled a tape change is made every time the reel number in the record header changes. The option is enabled when the check box is checked.

Select the type of superblocking -- allows you to select if or how the data is super blocked when it is written to tape. You must choose either "Do NOT Superblock", "Set Blocksize to 32K", "Set Blocksize to 64K" or "Set Blocksize to 128K". Make sure the SCSI card you are using supports blocks greater than 64K if you a using a block size of 128K.

Cable Configuration Parameters

Note: Clicking on any of the eight cable configuration buttons in the parameters dialog box accesses the cable configuration parameters. You can define up to four sections for each cable in the Cable Configuration Parameters dialog box.

Activate Cable -- is a check box that must be checked to define a cable to SeisNet.

Line Segment Configurations

Up to four cable segments can be defined and activated depending on the complexity of the cable layout. The capability to define a line segment allows for the correction of station numbering and shear geophone polarity reversal for complex OBC cable layout configurations involving direction changes such as U shape layouts.

Channel Range -- defines the cable channels affected by the parameters settings within a cable segment.

Receiver Station Mapping -- is the multiplier and bias settings used for correction of the receiver station numbering.

Receiver Line Mapping -- is the multiplier and bias settings used for correction of the receiver line numbering.

Sensor Order -- allows selection of the sensor order in terms of trace sequential numbering for this cable segment. You must choose from the list displayed in the drop-down menu. Remember this is the order in which the data are written to tape by the recording system.

Activate Segment -- enables this line segment for this cable. Placing a check in the check box enables this parameter.

Kill Channels -- lets you select specific channels to kill for this line segment. Placing a check in the check box enables this parameter.

Swap Shear Polarity -- reverses the polarity on the inline and crossline geophones. Placing a check in the check box enables this parameter.

Click Here to View Description of Module


SEG-Y Data Written to Disk

SeisNet Module: SEG-Y Data Written to Disk

The SEG-Y Data Written to Disk module writes data to hard disk in the SEG-Y format. The SEG-Y format is a tape standard that places an interblock gap after each trace. There are no such gaps when the data are written to disk. In addition, each shot record is stored in a separate file, and each file has 3600 bytes of header information.

You may learn more about this module selecting one of the following:

Description

Parameters


Description of SEG-Y Data Written to Disk Module

SeisNet Module: SEG-Y Data Written to Disk

Description

The SEG-Y Data Written to Disk module lets you write data from the SeisNet system to hard disk in the SEG-Y format. Each shot record is written to a separate file, and each file has the standard SEG-Y 3600 byte record header. The first 3200 bytes consists of 40 card images written in EBCDIC, and the last 400 bytes is the binary coded block. There are no interblock gaps after the EBCDIC block and the coded block. You should refer to the publication "digital tape standards" from the SEG for a complete explanation of the SEG-Y standard. The data are stored on hard disk exactly as it would be stored on tape, except that there are no interblock gaps. Interblock gaps apply only when data are written to tape.

We have adopted a naming convention for files stored on disk. The files will be stored in a directory you specify in the parameters dialog box. If the directory, or folder, specified does not exist, it will created. The actual filename consists of the letter 'F' followed by the Field File Identification Number, FFID. This, in turn, is followed by the letter 'R' followed by the reel number you specify in the parameters dialog box. All SEG-Y file created by SeisNet will have an extension of ".SEGY". For example, assume that for a particular shot record that the FFID is 452 and the reel number is 98756, then the filename generated by SeisNet would be <F452R98756.SEGY>

Click Here for an Explanation of the Parameters


Parameters for SEG-Y Data Written to Disk Module

SeisNet Module: SEG-Y Data Written to Disk

Parameters

The SEG-Y Data Written to Disk parameters as defined as follows:

Parameter names are shown in the color Green.

Name of the folder (directory) where the SEG-Y data are to be stored -- specifies the directory where the SEG-Y disk data are stored. You can click on the Browse button for point-and-click operation.

Job identification number -- lets you associate this particular shot record with a job number. You must stop and restart the SeisNet flow to change the Job identification number.

Line number (one line per reel) -- lets you assign a line number for this shot record. The Line number cannot be changed while a flow is running.

Reel Number -- is used to generate the names of the files where the different shot records are stored. The Reel Number cannot be changed while a flow is running. If you want to change the Reel Number, you must stop the flow, change the Reel Number and restart the flow.

Click Here to View Description of Module


Tape Copy

SeisNet Module: GeoRes Tape Output

This module provides the capability to output GeoRes system generated files to tape in SEG-D Rev 2 8058 format.

To learn more about this module select one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: GeoRes Tape Output

Description

The GeoRes Tape Output module provides the ability to output GeoRes system generated files to tape in SEG D Rev.2 8058 format. It also creates a tape log file for each tape reel generated along with a tape label.

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: GeoRes Tape Output

Parameters

The parameters dialog box for the GeoRes Tape Output module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Output Tape Drive -- Select output tape drive. If the hot swapping option is selected, the drives will swap as follows:

Selecting MTO, Drive #1 or MT1, Drive #2 – will swap between drives MTO, Drive #1 and MT1, Drive #2

Selecting MT2, Drive #3 or MT3, Drive #4 – will swap between drives MT2, Drive #3 and MT3, Drive #4

Number of Records per Tape -- This parameter determines how many records will be stored on each tape before a double EOF and unload are initiated.

First Reel Number -- Sets the initial reel number.

Reel Number Increment -- Sets the reel number increment for succeeding reels.

Enable Hot Swapping – When multiple tape drives are connected to the system, this option provides the ability to automatically switch to the next available drive when a reel is completed and unload initiated. The hot swap scheme is dependent on the selection made for the Tape Drive, where the data are Archived parameter as detailed above.

Generate Tape Log File -- This option creates a REEL#.RPT file, for each reel written.

No Superblocking – This option provides single trace blocks to tape.

Superblock to 128K – This option provides multiple trace blocks to tape. The number of traces per block is calculated based on the number of bytes per trace divided into 128K. Due to this calculation, the last block of each channel set may contain less traces and therefore be shorter than the all the other blocks for that channel set.

Superblock to 512K – This option provides multiple trace blocks to tape. The number of traces per block is calculated based on the number of bytes per trace divided into 512K. Due to this calculation, the last block of each channel set may contain less traces and therefore be shorter than the all the other blocks for that channel set.

Number of Tape Labels – Enter number of tape labels to be printed for each tape reel written (Default value 1). Enter 0 to switch off tape label printing.

Tape Label Data – This section provides entry fields for the tape labels generated by the system. A maximum number 30 characters is allowed for each entry.

Click Here to View Description of Module


Tape Copy

SeisNet Module: SEG-D Tape Image to Disk

The SEG-D Tape Image to Disk module is used to archive data to hard disk. A tape image is created on the hard disk where shot records are stored in a single file. The image created is the same as would be on tape, except that there are no inter-block gaps or EOF marks. The data is stored in either SEG-D 8048 or SEG-D 8058 format, and byte-ordered as big endian.

To learn more about this module select one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: SEG-D Tape Image to Disk

Description

The SEG-D Tape Image to Disk module is used to archive seismic data to hard disk. A tape image is created on the hard disk where the shot records are stored in a single file. The image created is the same as would be recorded on tape, except that there are no inter-block gaps or EOF marks. The data can be stored in either SEG-D 8048 or SEG-D 8058 format with Big Endian byte ordering.

The module requires that you specify a directory and file name as a location of where to store the data. If you do not specify a directory and file name, the data will be stored in the default directory “D:\SEGD_DATA\” and default file “SEGD_SEISDATA.DATA”. It is possible to select the default directory and choose a specific file name. Selecting “Not Defined” for the “Enter the directory where the data will be stored” parameter will choose the default directory. Similarly, selecting “Not Defined” for the file name will choose the default file name. A browse button is provided to make it easier to navigate the Windows directory structure.

Another file is created that holds information on how the shot records are stored in the tape image file. That file has the same name as the tape image file, but with the characters “.tpf” (all lower case) appended. For example, if the fully qualified filename of the tape image file is “D:\Data\Test.DAT”, this file will be named “D:\Data\Test.DAT.tpf”. The tpf file is formatted as an ASCII file with two columns. The number of blocks in a memory segment is given in the left column and the number of bytes in a block is written in the right column. In addition, the number of bytes column holds the characters “FM” when an EOF mark is to appear on tape.

There are two choices for determining how the SEG-D headers are created. The first choice “Original SEG-D Headers” will use the SEG-D headers captured from the recording system, such as a Sercel 408 system. When the data is obtained from a recording system that writes SEG-D, SEG-D Rev1 or SEG-D Rev2 data, the “Original SEG-D Headers” should be chosen as the value for the “Source of SEG-D headers to use for formatting the Output Data” parameter. For all other systems, the choice should be “Internal Structure”.

An option is provided to generate a log of the shot records stored in the disk file. The option to generate a log is chosen by checking the “Check here to generate a log of the records written to disk” parameter. The FFID, time of acquisition and offset to the shot record is logged for each shot stored in the hard disk data file.

It is important to note that there is a limit as to the largest file that can be created with this module. That file size limit is 2GB, and it exists because a 32 bit integer was used to calculate the offsets needed to store the individual shot records.

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: SEG-D Tape Image to Disk

Parameters

The parameters dialog box for the SEG-D Tape Image to Disk module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Enter the directory where the data will be stored – Allows you to specify the name of the directory where the tape image file is stored. You can use the Browse button to display a list of existing directories. If you want to specify a subdirectory of an existing directory, use the Browse button to select an existing directory and append the name of the subdirectory to the root directory name. The new directory will be created when you execute the flow for the first time. For example, if you wanted to store the tape image file in a directory name D:\SeismicData\sub\, and the only the root directory D:\SeismicData\ existed, you could do the following: First, use the Browse button to select the D:\SeismicData\ directory. Second, append the characters “sub\” to the directory name displayed in the edit box. If you wanted to, you could just type-in the entire directory name. Note that if you select the default “Not Defined”, the tape image file will be stored in the directory D:\SEGD_DATA\.

Enter the name of the file where the data will be saved (e.g. R1234.DAT) – Lets you set the name of the tape image file. The filename you select here will be appended to the directory name to generate a fully qualified filename. When you accept the default “Not Defined” filename, the tape image file will be named “SEGD_SEISDATA.DATA”. Note that if you select the default “Not Defined” for both the directory and filename, the tape image data will be stored in a file with the fully qualified name D:\SEGD_DATA\SEGD_SEISDATA.DATA.

Format of the Output Data – Determines the format of the trace data. You can select either SEG-D 8048 or SEG-D 8058. Whichever one you choose, the data bytes will be ordered as Big Endian.

Source of SEG-D headers to use for formatting the Output Data – Specifies how the headers are calculated. You have two choices, “Original SEG-D Headers” and “Internal Structure”. Choosing “Original SEG-D Headers” tells the module to generate the headers using those read-in with the SEG-D shot record. If for example, the data came from a Syntrak system, you would probably choose this method because the Syntrak outputs SEG-D data. However, if you use as a recording systems that does not output SEG-D data, you would want to use “Internal Structure” option. A recording system that outputs SEG-2 files would require that you choose the “Internal Structure” option.

Check here to generate a log of the records written to disk – Logs information about the shot records that make-up the tape image to a disk file stored in ASCII format. The log file will be stored in the same directory where the tape image file is stored. It will have the same name as the tape image file, but with an extension of “.log”. For example, if the tape image file is named D:\SEGD_DATA\SEGD_SEISDATA.DATA, then the log file will be named D:\SEGD_DATA\SEGD_SEISDATA.LOG.

Click Here to View Description of Module


Filters Under SeisNet's Processing Menu

Lowpass | Butterworth IIR Lowpass Filter
Highpass | Butterworth IIR Highpass Filter
Notch | IIR Notch Filter
Correlation | Crosscorrelates Data Traces in the SeisNet Data Object


Processing Filters Lowpass command

SeisNet Module: Lowpass Filter

The Lowpass Filter module is used to remove high frequency components from the captured data. This filtered data is passed to the next module in the flow.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Filters Lowpass Description

SeisNet Module: Lowpass Filter

Description

The Lowpass Filter module in the SeisNet system is used to transmit all frequency components from DC to a specified cutoff frequency.

When the seismic traces are filtered with the Lowpass Filter module, the filtered traces replace the unfiltered traces in the data object that is passed to the next module in the processing flow. That is, the Lowpass Filter module modifies the data. The module next in the processing flow will receive filtered traces.

Click Here for an Explanation of the Parameters


Processing Filters Lowpass Parms

SeisNet Module: Lowpass Filter

Parameters

The parameters dialog box for the Lowpass Filter module is displayed when you click on the "P" in the icon representing the Lowpass Filter module.

Parameter names are shown in the color Green.

Cutoff frequency (hi-cut), in Hz -- is the frequency (in Hz) at which the amplitude response is down 3dB. You must type-in the cutoff frequency if you want a value other than the default value.

Filter's Slope in dB/Octave --is the rate, in dB/Octave, that the response goes through the transition band. It effect, this parameter determines the width of the transition band. You are presented with predefined choices of 12, 24, 36, 48, 60 and 72 dB/octave that can be selected by simply clicking the left mouse button. Values, other than the predefined values, must be typed-in.

Phase (zero or minimum) --is the filter's phase response. You must choose either minimum phase or zero phase.

Click Here to View Description of Module


Processing Filters Highpass command

SeisNet Module: Highpass Filter

The Highpass Filter module is used to remove low frequency components from the captured data. The filtered data is passed to the next module in the flow.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Filters Highpass Description

SeisNet Module: Highpass Filter

Description

The Highpass Filter module is used to transmit all the frequency components from the cutoff frequency to the folding frequency.

When the seismic traces are filtered with the Highpass Filter module, the filtered traces replace the unfiltered traces in the data object that is passed to the next module in the processing flow. That is the Highpass Filter module modifies the data. The next module in the processing flow will receive filtered traces.

Click Here for an Explanation of the Parameters


Processing Filters Highpass Parms

SeisNet Module: Highpass Filter

Parameters

The parameters dialog box for the Highpass Filter module is displayed when you click on the "P" of the icon representing the module.

Parameter names are shown in the color Green.

Cutoff frequency (low-cut) in Hz -- is the frequency (in Hz) at which the amplitude response is down 3dB. You must type-in the cutoff frequency if you want to change it from the default value.

Filter's Slope in dB/Octave -- is the rate, in dB/octave, that the response goes through the transition band. It effect, this parameter determines the width of the transition band. You are presented with predefined choices of 12, 24, 36, 48, 60 and 72 dB/octave that can be selected by left mouse clicking. If you do not like any of the predefined choices, you can type-in a different value. When you type-in a value different from a predefined choice, you should not type the "dB/Octave" text. It is only necessary to enter the number, For example, if you wanted a filter slope of 96 dB/octave, you would enter 96 and not "96 dB/Octave". The text "dB/Octave" is supplied so you can recognize the predefined choices.

Phase (zero or minimum) -- is the filter's phase response. You must choose either zero or minimum phase, which are the only choices you have for determining the filter's phase response.

Click Here to View Description of Module.


Processing Filters Notch command

SeisNet Module: Notch Filter

The Notch Filter module is used to remove frequency components in a very narrow frequency band from the captured data. The filtered data is passed to the next module in the flow.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Filters Notch Description

SeisNet Module: Notch Filter

Description

A notch filter is used to remove frequency components in a very narrow frequency band from the seismic data. Among other uses, a notch filter is used to remove the ever present 60Hz that comes from the electrical power distribution system. The power distribution frequency is 50Hz in England. The filtered data is passed to the next module in the flow.

Click Here for an Explanation of the Parameters


Processing Filters Notch Parms

SeisNet Module: Notch Filter

Parameters

The parameters dialog box for the Notch Filter module is displayed when you click on the "P" of the icon representing the module.

The Notch Filter parameters are defined as follows:

Parameter names are shown in the color Green.

Notch Frequency in Hz -- is the frequency you want to remove from the data's spectrum. You must type-in the notch frequency if you don't want the default value of 60Hz.

Click Here to View Description of Module


Correlation Module

SeisNet Module: Correlation

You may learn more about the Correlation module by selecting one of the following:

Description

Parameters


Processing Filters Correlation Description

SeisNet Module: Correlator

Description

"Correlator" is a SeisNet module that cross-correlates the pilot signal with the received Vibroseis signal. The length of a Vibroseis trace is the sum of the sweep time plus the listen time. Since the length of the trace is already known, it is only necessary for you to enter the listen time. The length of the output trace will be equal to the listen time.

There are three methods provided for choosing the pilot signal: Method #1 involves specifying the trace sequential number of the pilot trace. This is the simplest method, but it can have problems when then number of traces in a shot record varies from one shot to the next. The trace sequential number can be read from the trace annotations when a shot record is displayed. Method #2 involves specifying the aux trace number. For example, if you know that the pilot signal is wired into aux channel 3, then you could choose this method and specify a 3 for the aux trace number. The third and last method involves specifying the channel set and the trace number within the channel set. These numbers can be obtained from the trace annotations when a shot record is displayed.

Click Here for an Explanation of the Parameters


Processing Filters Correlation Parms

SeisNet Module: Correlator

Parameters

The Correlator parameters are defined as follows:

Parameter names are shown in the color Green.

Method to choose the pilot signal -- determines how to choose the pilot signal. The combo box lists three different choices. The first choice is "Sequential Trace Number" where the pilot signal is determined by looking-up the trace with the specified trace sequential number. The second choice is "Aux Trace Number" where the pilot signal is specified by entering the channel number of the aux trace holding the pilot signal. The third choice is "Channel Set/Trace Number" where the pilot signal is determined by looking-up the specified trace number within the channel set specified.

Enter sequential trace number for the pilot -- is displayed only when you choose "Sequential Trace Number" as the method for choosing the pilot. When displayed, type-in the sequential trace number of the pilot signal.

Enter the Aux trace number for the pilot -- is displayed only when you choose "Aux Trace Number" as the method for choosing the pilot. When displayed, type-in the channel number for the aux trace holding the pilot. For example, if the pilot signal is wired into channel number 3 of the recording system, you would type-in a 3 as the value of this parameters.

Enter the Channel Set Number that holds the pilot -- is displayed only when you choose "Channel Set/Trace Number" as the method for choosing the pilot. When displayed, type-in the number of the channel set holding the pilot signal.

Enter Trace Number within the channel set for the pilot -- is displayed only when you choose "Channel Set/Trace Number" as the method for choosing the pilot. When displayed, type-in the number of the trace within the channel set that holds the pilot.

Enter listen time (in seconds) -- is used to specify the listen time and consequently, the length of the output trace.

Click Here to View Description of Module


Display Under SeisNet's Processing Menu

Display Trace Data | Displays Seismic Data on the Computer Screen
Plot Seismic Traces | Plots Seismic Data on a V-80 Compatible Plotter
Display Single Trace Gather | Displays a Single Trace Gather on the Computer Screen
Plot Single Trace Gather (Real Time) | Real-Time Plot of Single Trace Gather on Plotter
Capture Screen to Printer | Automatically Captures Screen Image to Printer
Plot Traces on HP LaserJet | Plots Seismic Data on the HP LaserJet
Trace Highlight | Displays Traces in User Defined Colors


Processing Display Trace Data command

SeisNet Module: Display Trace Data

The Display Trace Data module displays seismic traces on the computer screen. The number of traces that can be displayed depends on the resolution of your monitor.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Display Trace Data Description

SeisNet Module: Display Trace Data

Description

This module provides the ability to interactively manipulate and display seismic trace data. All command and display options are mouse selectable. Error messages and status information is shown in the title bar of the display window, and the status bar at the bottom of the screen.

When the Display Seismic Traces module is inserted into a processing flow and executed, a window is displayed that has the following features:

A border consists of the lines that frame a window. Clicking on the border and dragging the mouse changes the size of the window.

The title bar is used to display messages about the status of the data object and the operation of the module. Normally, when a data object is processed, the FFID and the number of traces in the object are displayed in the title bar. Also, when the Display Traces Module looses control of the processing flow, and you attempt to interact with the display, a message will be displayed in the title bar telling you the module has lost control of the flow.

Use the maximize and minimize buttons to manipulate the Display Seismic Traces module. The box with the X in it is grayed, which says that it cannot be removed from the processing flow by killing the window. Scrollbars are used to position the screen image.

The menu bar lists commands that can be issued to the Display Seismic Traces module. You normally issue a command by pointing to it with the mouse and pressing the left mouse button. The menu bar also has three display areas for displaying the trace number, time, and value of the sample at the mouse location.

The actual trace display consists of the trace data displayed in either "wiggle trace" or "variable area" format. In addition to the trace data, there are labels for both time and trace numbers. The time (in seconds) label is to the left of the trace data, and the trace numbers are across the top of the plot. There are two rows of trace numbers; the bottom row is the trace sequential number, and the top row is the channel set number and trace number within the channel set.

Click Here for an Explanation of the Parameters


Processing Display Trace Data Parms

SeisNet Module: Display Trace Data

Parameters

The parameters dialog box for the Display Seismic Traces module is displayed when you click on the "P" of the icon representing the module.

Parameter names are shown in the color Green.

The parameters dialog box consists of five property pages, or "tab dialog boxes" because there are too many parameters to fit on a single page. The tabs are labeled as follows:

Important Note

Many of the parameters that you will be entering have predefined values. The executive normally displays some text immediately following a predefined value. For example, 15 is a predefined value for the number of timing lines and it is displayed as "15 Lines" and not simply 15. This is done so that you can easily identify predefined values. However, if you want to type in a value that has not been predefined, you should only type-in the number and not the associated text. For example, if you have 16 timing lines, you would type-in 16 , not 16 Lines.

Display -- is the property page that holds the parameters that relate to how the data are displayed on the screen. Such things as display times, traces that are displayed, and annotation increments are input via the "Display" property page.

Scaling -- is the property page that controls how the data are scaled for displaying. Such things as whether or not you want to AGC the data are input here.

Processing -- is the property page that controls how the data are processed for displaying. If you want to filter the data before it is displayed, you would input that in this property page.

Mute -- is the property page used to input a mute function.

Misc -- is the property page used to input various other functions. The main parameter that is input, is the number of bitmaps that you want to create for holding previously displayed records.

Parameters on the "Display" Property Page

Trace overlap factor -- controls the amount that one trace is permitted to overlap another before clipping occurs. There are several pre-defined values that you can choose by simply clicking the left mouse button. If you want a value different from those that are pre-defined, you will have to type-in the desired value.

Display method -- determines how the data are to be displayed. You only have two choices, which are "Wiggle Trace" and "Variable Area". If you type-in something, it must be "Wiggle Trace" or "Variable Area". It is much easier if you use the left mouse button to make your choice.

Number of timing lines -- sets the number of timing lines that will be generated when the data are displayed on the screen. You can choose from several pre-defined values simply by clicking the left mouse button. If you want a different value from those that are predefined, you will have to type-in the value.

Trace annotation increment -- determines how often the traces are annotated. There are several pre-defined values that you can choose from by simply clicking the left mouse button. If you want a value different from the one of the pre-defined values, you have to type-in that value.

Minimum time to display on the screen -- is the parameter that controls the minimum time that gets displayed. This parameter has units of seconds. You can choose one of the predefined values or you can type-in one.

Maximum time to display on the screen -- is the parameter that controls the maximum time that gets displayed. This parameter has units of seconds. You can choose one of the predefined values or you can type-in one.

Check here if you want to limit number of traces processed -- is a check box that sets an internal variable to TRUE when the box is checked. The internal variable is set to FALSE when the box is NOT checked. When the internal variable is TRUE, an edit box is displayed asking you to enter the trace numbers you want processed and displayed.

Enter the sequential trace numbers to be processed -- is displayed only when the above internal variable is set to TRUE and the above check box is checked. The edit box where you type-in the trace numbers expects a particular format. That format is:

trc# - trc# (increment)

For example:

1, 2, 3, 5-10, 12-20(2)

would tell the module to display traces 1, 2, 3, 5, 6, 7, 8, 9, 10, 12, 14, 16, 18, 20.

Parameters on the "Scaling" Property Page

Check here to apply an AGC operator to each trace in dataset -- is a check box that you check if you want to apply an AGC operator to your data. When this parameter is in the checked state, an edit box is displayed asking you to enter the operator length in seconds.

Check here to scale on the RMS value of each individual trace -- is a check box that you check if you want to scale on the RMS value of each individual trace. When this box is in the checked state, each trace is divided by the RMS value of that trace before it is displayed.

Check here to scale on the RMS value of a particular trace -- is a check box that you mark if you want to scale all the traces that are displayed by the RMS value of a particular trace. When this parameter is in the checked state, an edit box is displayed where you enter the number of the trace you want to scale on.

Check here to scale on the average RMS value of the entire dataset – is a check box that you select if you want to scale the data based on the RMS value of all the seismic traces (not aux traces) in the dataset. This scale factor is applied to both the aux and data traces. If you want to override the scaling of the aux traces, select the “Check here to apply a fixed gain to the aux traces” below.

Check here to apply a fixed gain to both the aux and data traces – is a check box that you select if you want to apply a fixed gain to all the traces in a dataset. If this option is selected, you will have to enter a gain value in the “Enter gain factor (in dB)” field below.

Check here to apply a fixed gain to the aux traces – is a check box that you select if you want to apply a fixed gain only to the aux traces. If this option is selected, the gain applied to the aux traces will be determined by the “Enter gain to apply to the aux traces (in dB)” parameter. It is noted that selecting this option overrides any other gain setting for the aux traces. In other words, you can AGC the seismic traces and apply a fixed gain to the aux traces using this option.

Enter the AGC operator length (in seconds) -- is displayed only when you request that an AGC operator be applied to the data. This is where you type-in the length of the AGC operator, and it has units of seconds. Good values for the AGC operator normally lie in the 0.25 to 5.0 seconds range.

Enter the sequential trace number to scale on -- is displayed only when you request that the data be scaled on a particular trace. You type-in the trace number that you want to use for scaling. This is used; for example, when you place an oscillator on say channel 1 and scale all the other traces by the RMS value of channel 1. This is an easy way to check on such things as wind noise.

Enter gain to apply to entire record -- is a number that multiplies every sample in every trace after all other scaling has been done. The default value of 1.0 is normally the best value for this parameter. This parameter serves the same purpose as the contrast and intensity buttons on your television.

Enter gain factor (in dB) – is the gain applied to the entire record, expressed in dB. This field is displayed when you check the “Check here to apply a fixed gain to both the aux and data traces”. The gain applied to the aux traces is determined by the “Check here to apply a fixed gain to the aux traces” is selected.

Enter gain to apply to the aux traces (in dB) – is the gain that is only applied to the aux traces when the “Check here to apply a fixed gain to the aux traces” is selected. If the “Check here to apply a fixed gain to the aux traces” is not selected, then the aux traces will be scaled according to whichever gain method is chosen. Applying a fixed gain to the aux traces lets you scale the aux traces separately from the data traces.

Parameters on the "Processing" Property Page

Polarity -- determines the polarity of the data for display purposes only. There are two choices for the polarity. They are "Normal" and "Reverse". Use your left mouse button to make the decision.

Interpolate -- is set to "Yes" if you want to interpolate values between samples. If you select "Yes" here, sample values will be calculated using a fourth order polynomial. Otherwise, the nearest sample value is chosen.

Apply T-ramp -- is a parameter that when set to "Yes" will tell the display module to multiply each trace by time. This is useful for observing events when scaling is based on the RMS value of a trace or traces

Check here to apply a highcut (lowpass) filter -- is a check box that you will check when you want the display module to apply a lowpass filter before displaying the data. Note that the filtering does not affect the data in the data object. When the display module filters the data, it is for display purposes only.

Highcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highcut filter. There are several predefined choices that you can select from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a lowpass filter.

Highcut slope (in dB/Octave) -- sets the roll-off rate of the lowpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a lowpass filter.

Highcut phase (Zero or Minimum) -- determines the phase response of the lowpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a lowpass filter.

Check here to apply a low-cut (highpass) filter -- is a check box that you will check when you want the display module to apply a highpass filter before displaying the data. Note that the filtering does not affect the data in the data object. When the display module filters the data, it is for display purposes only.

Lowcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the lowcut filter. There are several predefined choices that you can select from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut slop (in dB/Octave) -- sets the roll-off rate of the highpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut phase (Zero or Minimum) -- determines the phase response of the highpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a highpass filter.

Check here to apply a notch filter -- is a check box that you will check when you want the display module to apply a notch filter before displaying the data. Note that the filtering does not affect the data in the data object. When the display module filters the data, it is for display purposes only.

Notch frequency (in Hz) -- sets the notch filter frequency. You can choose either 60Hz or 50Hz from the predefined values, or you can type-in a different value. This parameter is only available when you choose to apply a notch filter.

Parameters on the "Mute" Property Page

Check here and NO mute function will be applied to the data -- is a check box that you will check when you do not want to apply a mute function. When this parameter is in the checked state, no mute will be applied to the data.

Check here to apply an automatic mute to the data -- is a check box that you will check when you want to automatically mute the data. The automatic mute function works by calculating amplitude ratios and zeroing-out all the data until a threshold is met. The value of the threshold is determined by you, which you type-in.

Automatic mute threshold -- sets the automatic mute threshold. A value of 3.0 seems to work pretty good for most marine situations. You may have to experiment to get the best value for the data you are processing. There are some predefined values that you can choose from. If none of the predefined values are to your liking, you can type-in a different value. This parameter is only available when you choose to apply an automatic mute.

Check here to apply a manual mute to the data -- is a check box that you will check when you want to apply a manual mute to the data. If you choose to apply a manual mute, you will have to type-in the trace number and time pairs.

Enter the trace number and time pairs -- is available only when you choose to apply a manual mute. When you type-in trace number and time pairs, they must be input in a particular format. The format consists of a trace number, dash, and time. Each trace number and time pair must be separated by commas. Linear interpolation is used to fill-in missing values. An example follows:

1-0.5, 50-1.0, 100-0.25,

which says that trace #1 should be muted to 0.5 seconds, trace #50 should be muted to 1.0 seconds, and that trace #100 should be muted to 0.25 seconds. Remember that the mute times will be linearly interpolated for any trace number not specified.

Parameters on the "Misc" Property Page

Number of previous images to keep -- tells the executive how many bitmaps to create for storing previously displayed records. These bitmaps are kept in the swap space; therefore, performance is not affected too much by keeping these bitmaps. However, don't get carried away and enter a big number like 1000, you might run out of swap space if you do. Ten records are a pretty good choice for this parameter. You have several predefined choices, if you do not like any of the predefined choices, you can type-in a different value.

Type of annotation at top of display -- determines the type of annotation at the top of the display. The bottom row on numbers is always the sequential trace number. However, the top row of numbers is determined by the option you choose for this parameter. If you choose the "Channel Set # - Trace #" option, the channel set number and the trace number within the channel set will be displayed. But, if you choose the "Receiver Line # - Station #" option, the Receiver Line Number and the Receiver Station Number on the line will be displayed. You must be acquiring data from a recording system that has line and station numbers in the headers to use the "Receiver Line # - Station #" option. Otherwise, the annotations in the top row of numbers will have no meaning.

Check here to display time picks from SeisNet's geometry module -- is a check box that you will check when you want tic marks displayed that relate to first break picking. When this parameter is in the checked state, tic marks will be displayed for the beginning and ending of the first break time window, the theoretical first break and the pick made by SeisNet. The beginning and ending tic marks are shown in Green. The theoretical pick is shown in Blue, and the pick made by SeisNet is shown in Red.

Shot increment to capture image files – enter number to reflect frequency of image captures to disk. E.g. “0” (default value) = no image captures, “1” = capture every shot, “2” = capture every 2nd shot etc.

Directory where to store Image Files – enter or browse to the appropriate destination path for the image capture files.

Default = D:\ImageData\ .

Display a Calibration Trace? – Check box to display calibration trace on the left side of the display.

Enter the amplitude of the calibration trace in (uB / uV) – Default value = 10

Enter the frequency of the calibration trace in (Hz) – Default value = 60

Parameters on the "Sequencing" Property Page

Check here if you want to sequence by channel set – enables the number of traces displayed to be defined in terms of channel sets per display, trace combing and channel set sequence.

Enter the number of channel set(s) per display – Default = 1

Enter trace combing factor – Default = 1. This value represents the number of sequential shots necessary to display all traces. E.g. “1” = all traces displayed every shot, “2” would display traces 1, 3, 5 etc. on first shot, then 2, 4, 6 etc. on second shot & repeat the sequence on subsequent shots, “3” would display traces 1, 4, 7 etc. on first shot, then 2, 5, 8 etc. on the second shot, then 3, 6, 9 on the third shot & repeat the sequence on subsequent shots.

Enter the channel set sequence to be processed – Entry format is:

Ch set# - Ch set#

For example:

1, 2, 3, 5-8

would tell the module to display ch sets 1, 2, 3, 5, 6, 7, 8, 9 in sequence (note channel set 4 represents aux channels in this example)

If you had selected to display 2 channel sets per display, the display sequence would be as follows:

1 & 2, 3 & 5, 6 & 7, 8 & 9 – then the sequence would repeat.

Click Here to View Description of Module


Processing Display Plot Seismic Traces command

SeisNet Module: Plot Seismic Traces

The Plot Seismic Traces module is used to plot traces on a V80 compatible plotter.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Display Plot Seismic Traces Description

SeisNet Module: Plot Seismic Traces

Description

The Plot Seismic Traces module plots seismic traces and an optional attribute on a V80 compatible plotter. At this time, there are four types of plotters supported. They are: Oyo model 612 at 200 dpi, Oyo model 622 at 200 dpi, Oyo model 624 at 200 dpi, and Oyo model 624 at 400 dpi.

In addition to plotting trace and attribute data, a side label is printed for every plot generated. The side label lists the parameters that were used to create the plot along with information entered in the 'Info/Mute' property page of the parameters dialog box. You enter client, contractor, prospect, area, crew names and identifying information in the 'Info/Mute" property page of the parameters dialog box.

The plot has either two or three rows of numbers displayed above the seismic data. There are three rows of numbers when the data object holds a single trace gather and you request that navigation markers be placed on the plot. Navigation fix numbers are printed in the top row when there are three rows of numbers. The bottom row represents trace sequential numbers and the middle row shows the channel set number and the trace number within the channel set. If the plot shows a single trace gather, the middle row of numbers are the FFID's.

You can select particular traces to be plotted by enabling the option to limit the number of traces plotted. When you choose to limit the number of traces plotted, you must type-in the sequential trace numbers of the traces to be plotted.

An option exists for displaying the traces in reverse order. If you are displaying 240 traces, for example, normally trace number one is plotted first. However, if you choose to reverse the order in which the traces are plotted, trace number 240 will be the first trace plotted.

When this module is being used to plot shot records, you may not want to plot every record. You can choose which shot records are plotted by enabling the option to limit the FFID's plotted. If, for example, you wanted to plot every 20th record, you would type-in something like this

1-9999(20),

which says to plot every 20th record, starting with the first shot record input to the flow.

There are several options for processing the data before it is plotted. The data can be scaled using either an AGC operator, the RMS value of each trace, the RMS value of a particular trace or the average RMS value of all the traces. The aux traces are always scaled on the peak value of each trace.

Options are available for applying lowpass, highpass and notch filters. When a particular filtering operation is requested, edit boxes are displayed for you to enter the filter parameters. For example, if you check the box to apply a highcut (or lowpass) filter, three boxes appear asking you to enter the cutoff frequency, the filter slope and the phase response of the filter.

An automatic or manual mute can be used to remove the noise at the beginning of the trace. To achieve optimum results when using the automatic mute, you may have to play around with the automatic mute threshold. Generally, the default value of 3.0 gives a pleasing appearance.

It is noted that any processing performed on the data is for display purposes only. The data in the data object is not affected by the plotting operation.

Click Here for an Explanation of the Parameters.


Processing Display Plot Seismic Traces Parms

SeisNet Module: Plot Seismic Traces

Parameters

The parameters dialog box for the Plot Seismic Traces module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

The parameters dialog box consists of five property pages, or "tabbed dialog boxes" because there are too many parameters to fit onto a single page. The tabs are labeled as follows:

Display - is the property page used to set the display parameters for plotting seismic traces including trace overlap factor, display method, number of timing lines, trace annotation increment, minimum and maximum time to display, and number of traces per inch.

Processing - is the property page that sets the parameters used to process the trace data before plotting. Here you choose such things as the polarity, whether or not to interpolate between samples, whether or not to apply a T-ramp and the type of filtering to apply.

Scaling - is the property page that sets the scaling parameters for plotting the trace data, including options to apply an AGC operator, scaling on the RMS value of each trace, a particular trace, or scaling on the average RMS value of the entire record.

Info/Mute - is the property that sets the mute function for plotting the trace data. You can have no mute function, an automatic mute, or a manual mute. This property page also has fields for entering information that gets printed on the side label.

Attribute - is the property page that determines whether or not you want to automatically scale attribute data displayed beneath the seismic data. This property page also gives you the option to print navigation fix number on the plot when a single trace gather is being plotted.

Parameters on the "Display"Property Page

Trace overlap factor -- controls the amount that one trace is permitted to overlap another clipping occurs. There are several pre-defined values that you can choose by simply clicking the left mouse button. If you want a value different from those that are pre-defined, you will have to type-in the desired value.

Display method -- determines how the data are to be displayed. You only have two choices, which are "Wiggle Trace" and "Variable Area". If you type-in something, it must be either "Wiggle Trace" or "Variable Area". It is much easier if you simply use the left mouse button to make your choice.

Number of timing lines -- sets the number of timing lines that will be generated when the data are displayed on the plotter paper. You can choose from several predefined values by simply clicking the left mouse button. If you want a value different for those that are predefined, you will have to type-in value.

Trace annotation increment -- determines how often the traces are annotated. There are several predefined values that you can choose from by simply clicking the left mouse button. If you want a value different from one of the predefined values, you will have to type-in the value.

Minimum time to display (in seconds) -- is the parameter that sets the minimum time that gets plotted. This parameter has units of seconds. You can choose form the list of predefined values or type-in one.

Maximum time to display (in seconds) -- is the parameter that sets the maximum time that gets plotted. This parameter has units of seconds. You can choose a value for the list of predefined values or you can type-in one.

Number of traces per inch to plot -- determines the spacing between the traces when they are plotted. You can choose from the predefined list or you can type-in a value.

Attribute to display at the bottom of the plot -- lets you select whether or not to plot an attribute at the bottom of the plot. You can plot either RMS or peak values from either the top or bottom time window. You can also choose not to plot and attribute at the bottom of the plot. You should make you selection using the left mouse button.

Plotter type -- tells SeisNet the type of plotter connected to the system. You should choose a type from the list of supported plotters, using the left mouse button.

Check here to reverse the order that the traces are plotted -- is the parameter that determines if the traces are plotted in reverse order. Normally, trace number one is plotted first. When this option is enabled the last trace is plotted first.

Check here if you want to limit the number of traces plotted -- is an option that lets you choose the traces that get plotted. If you enable this option and edit box appears asking you to enter the sequential trace numbers to be processed.

Enter sequential trace numbers to be procesed -- allows you to specify the traces to be plotted. This parameter is available only when the option to limit the number of traces plotted is enabled. The format for selecting the trace numbers is sel#-sel#(inc). For example, if you enter the string "3,5,20-25,30-40(2)", then the following traces will be plotted: 3, 5, 20, 21, 22, 23, 24, 25, 30, 32, 34, 36, 38, 40.

Check here if you want to limit the FFID's plotted -- is an option that lets you specify which shot records are plotted. If this option is enabled an edit box is displayed asking you to type-in the FFID's of the shot records you want plotted.

Enter the list of FFID's you want to plot -- allows you to specify the FFID's of the shot records you want to plot. For example, if you enter "3,5,100-110(2), then the FFID's 3,5,100, 102, 104, 106, 108, 110 will be plotted.

Parameters on the "Processing" Property Page

Polarity (normal or Reverse) -- determines the polarity of the data for plotting. There are two choices for the polarity. They are "Normal" and "Reverse". Use the left mouse button to make the choice.

Interpolate Data (Yes or No) -- is set to "Yes" if you want to interpolate values between samples. If you select "Yes", inter-sample values will be calculated using a fourth order polynomial. Otherwise, the nearest sample is chosen.

Apply T-ramp(Yes or No) -- is a parameter that when set to "Yes" will tell the module to multiply each trace by time before it is displayed. This feature is useful for observing events when scaling is based on the RMS value of a trace or traces.

Check here to apply a highcut (lowpass) filter -- is a check box that you will check when you want the display module to apply a lowpass filter before displaying the data. Note that the filtering does not affect the data in the data object. When this module filters the data, it is for plotting purposes only.

Highcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highcut filter. There are several predefined choices that you can select from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a lowpass filter.

Highcut slope (in dB/Octave) -- sets the roll-off rate of the lowpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a lowpass filter.

Highcut phase (Zero or Minimum) -- determines the phase response of the lowpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a lowpass filter.

Check here to apply a low-cut (highpass) filter -- is a check box that you will check when you want the display module to apply a highpass filter before displaying the data. Note that the filtering does not affect the data in the data object. When this module filters the data, it is for plotting purposes only.

Lowcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the lowcut filter. There are several predefined choices that you can select from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut slop (in dB/Octave) -- sets the roll-off rate of the highpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut phase (Zero or Minimum) -- determines the phase response of the highpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a highpass filter.

Check here to apply a notch filter -- is a check box that you will check when you want the display module to apply a notch filter before displaying the data. Note that the filtering does not affect the data in the data object. When this module filters the data, it is for plotting purposes only.

Notch frequency (in Hz) -- sets the notch filter frequency. You can choose either 60Hz or 50Hz from the predefined values, or you can type-in a different value. This parameter is only available when you choose to apply a notch filter.

Parameters on the "Scaling" Property Page

Check here to apply an AGC operator to each data trace -- is a check box that you check if you want to apply an AGC operator to your data. When this parameter is in the checked state, an edit box is displayed asking you to enter the operator length in seconds.

Check here to scale on the RMS value of each individual trace -- is a check box that you check if you want to scale on the RMS value of each individual trace. When this box is in the checked state, each trace is divided by the RMS value of that trace before it is displayed.

Check here to scale on the RMS value of a particular trace -- is a check box that you mark if you want to scale all the traces that are displayed by the RMS value of a particular trace. When this parameter is in the checked state, an edit box is displayed where you enter the number of the trace you want to scale on.

Check here to scale on the average RMS value of entire dataset – is a check box that you select if you want to scale the data based on the RMS value of all the seismic traces (not aux traces) in the dataset. This scale factor is applied to both the aux and data traces, unless you select the option “Check here to apply a fixed gain to the aux traces.” In that case the aux traces are gained according to the fixed gain parameter for the aux traces.

Check here to apply a fixed gain to both the aux and data traces – is a check box that you select if you want to apply a fixed gain to all the traces in the dataset. If this option is selected, you will have to enter a gain value for the “Enter gain to apply to entire record (in dB)” parameter. Note that the aux traces are gained separately when you select the “Check here to apply a fixed gain to the aux traces”. In that case the aux traces are gained according to the “Enter gain to apply to the aux traces (in dB)” parameter.

Check here to apply a fixed gain to the aux traces – is a check box that you select if you want to apply a fixed gain only to the aux traces. If this option is selected, the gain applied to the aux traces will be determined by the “Enter gain to apply to the aux traces (in dB)” parameter. It is noted that selecting this option overrides any other gain setting for the aux traces. In other words, you can AGC the seismic traces and apply a fixed gain to the aux traces using this option.

Enter the AGC operator length (in seconds) -- is displayed only when you request that an AGC operator be applied to the data. This is where you type-in the length of the AGC operator, and it has units of seconds. Good values for the AGC operator normally lie in the 0.25 to 0.5 second range.

Enter the sequential trace number to scale on -- is displayed only when you request that the data be scaled on a particular trace. You type-in the trace number that you want to use for scaling. This is used; for example, when you place an oscillator on say channel 1 and scale all the other traces by the RMS value of channel 1. This is an easy way to check on such things as wind noise.

Enter gain to apply to entire record -- is a number that multiplies every sample in every trace after all other scaling has been done. The default value of 1.0 is normally the best value for this parameter. This parameter serves the same purpose as the contrast and intensity buttons on your television.

Enter gain to apply to the aux traces (in dB) – is the gain that is only applied to the aux traces when the “Check here to apply a fixed gain to the aux traces” is selected. If the “Check here to apply a fixed gain to the aux traces” is not selected, then the aux traces will be scaled according to whichever gain method is chosen. Applying a fixed gain to only the aux traces lets you scale the aux traces separately from the data traces.

Parameters on the "Info/Mute" Property Page

Check here and NO mute function will be applied to the data -- is a check box that you will check when you do not want to apply a mute function. When this parameter is in the checked state, no mute will be applied to the data.

Check here to apply an automatic mute to the data -- is a check box that you will check when you want to automatically mute the data. The automatic mute function works by calculating amplitude ratios and zeroing-out all the data until a threshold is met. The value of the threshold is determined by you, which you type-in.

Automatic mute threshold -- sets the automatic mute threshold. A value of 3.0 seems to work pretty good for most marine situations. You may have to experiment to get the best value for the data you are processing. There are some predefined values that you can choose from. If none of the predefined values are to your liking, you can type-in a different value. This parameter is only available when you choose to apply an automatic mute.

Check here to apply a manual mute to the data -- is a check box that you will check when you want to apply a manual mute to the data. If you choose to apply a manual mute, you will have to type-in the trace number and time pairs.

Enter the trace number and time pairs -- is available only when you choose to apply a manual mute. When you type-in trace number and time pairs, they must be input in a particular format. The format consists of a trace number, dash, and time. Each trace number and time pair must be separated by commas. Linear interpolation is used to fill-in missing values. An example follows:

1-0.5, 50-1.0, 100-0.25,

which says that trace #1 should be muted to 0.5 seconds, trace #50 should be muted to 1.0 seconds, and that trace #100 should be muted to 0.25 seconds. Remember that the mute times will be linearly interpolated for any trace number not specified.

Client -- is where you type-in the client's name, which is printed on the side label.

Contractor -- is where you type-in the contractor's name, which is printed on the side label.

Prospect -- is where you type-in the name of the prospect, which is printed on the side label.

Area -- is where you type-in the area name, which is printed on the side label.

Crew -- is where you type-in the crew name, which is printed on the side label.

I.D. Info -- is where you type-in other identification information that is printed on the side label.

Parameters on the "Attribute" Property Page

Check here to auto scale the attribute plot displayed at bottom of page -- is an option for automatically scaling the attribute plot located beneath the seismic data when you choose the option to plot an attribute with the seismic data.

Enter the minimum value to display for the attribute data -- is the minimum value that will be displayed for the attribute data displayed beneath the seismic data. This option is valid only when you choose to display an attribute and the option to automatically scale the attribute plot has been disabled.

Enter the maximum value to display for the attribute data -- is the maximum value that will be displayed for the attributed data displayed beneath the seismic data. This option is valid only when you choose to display an attribute and the option to automatically scale the attribute plot has been disabled.

Check here to print navigation fix number on the plot -- is an option that will print an extra row numbers across the top of the plot. This extra row of numbers consists of navigation fix numbers pegged to the FFID. This option is only valid when the data object contains a single trace gather.

Starting navigation fix number -- is the first number of the navigation fix. This parameter is only valid when you choose to print navigation numbers on the plot.

Increment for navigation fix numbering -- is the increment for either increasing or decreasing the navigation fix numbers.

Increment or decrement fix numbers -- allows you to set whether the navigation fix numbers are either incremented or decremented. You must choose either Increment or Decrement for the combo box using the left mouse button.

FFID of the first navigation fix -- pegs the starting navigation fix number to the FFID you specify here.

Number of FFID's between navigation fixes -- is the number of FFID's between navigation fixes.

Type of annotation at top of display -- determines the type of annotation at the top of the display. The bottom row of numbers is always the sequential trace number. However, the top row of numbers, if there are no navigation fix marks, or the center row of numbers, if there are navigation fix marks, is determined by the option you choose for this parameter. If you choose the "Channel Set # - Trace #" option, the channel set number and the trace number within the channel set will be displayed. But, if you choose the "Receiver Line # - Station #" option, the Receiver Line Number and the Receiver Station Number on the line will be displayed. You must be acquiring data from a recording system that has the line and station numbers in the headers to use the "Receiver Line # - Station #" option. Otherwise, the annotations will have no meaning.

Click Here to View Description of Module


Processing Display Single Trace Gather command

SeisNet Module: Display Single Trace Gather

The Display Single Trace Gather module is used to display a single trace gather on the computer screen. That is, a single trace is taken from each shot record and displayed on the system monitor.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Display Single Trace Gather Description

SeisNet Module: Display Single Trace Gather

Description

The Display Single Trace Gather module takes a single trace from each shot record and inserts it into a single trace gather. As the gather is built, it is displayed on the computer's screen with the most recent trace being displayed at the left side of the display window. You have the option of saving the single trace gather to hard disk so that a hard copy can be generated after the acquisition of data is finished. If you want a hard copy of the single trace gather in real-time, you should insert the Plot Single Trace Gather module into your flow.

The Display Single Trace Gather module provides the ability to interactively manipulate and display the single trace gather. All command and display options are mouse selectable. Error messages and status information is shown in the title bar of the display window, and the status bar at the bottom of the screen.

When the Display Single Trace Gather module is inserted into a processing flow and executed, a window is displayed that has the following features:

A border consists of lines that frame a display window. Clicking on the border and dragging the mouse changes the size of the window. After you resize the display window, it will probably be necessary to click on the "Redraw" button to actually display the seismic data.

The title bar is used to display messages about the status of the data object, the single trace gather and the operation of the module. Normally, when a trace is selected from the data object for insertion into the single trace gather, the FFID and the trace number within the gather are displayed in the title bar. Other messages may also be displayed.

A menu bar has holding buttons that can be used for commands to the Single Trace Gather Display module. You normally issue a command by pointing to it with the mouse and pressing the left mouse button. The menu bar has a display where messages are displayed. If you move the mouse over the gather of displayed trace data, the trace number within the gather, FFID, time and the value of the trace at the mouse position are displayed.

Control of the processing flow is accomplished with the Automatic/Manual button. When the word "Automatic" is displayed on the Automatic/Manual button, the selected trace is copied from the data object to the single trace gather, and the data object is passed to the next module in the flow. The data object will NOT be passed to the next module in the flow when the word "Manual" is displayed on the Automatic/Manual button. Remember; the processing flow is halted when the word "Manual" is displayed on the Automatic/Manual button. The normal operating mode is "Automatic" and you should only use the "Manual" mode when operations are NOT time critical.

Use the maximize and minimize buttons on the title bar to manipulate the Display Single Trace Gather module. Note that the small box with the X in it is grayed, which says that it cannot be removed from the processing flow by killing the window. You cannot kill the display window by clicking on the X button found on the title bar. Use either the "Kill" or "Exit" command from the main menu bar to terminate a flow, which will also destroy the Display Single Trace Gather module's display window. The Scrollbars can be used to select a portion of the gather for display on the computer screen.

When you are interacting with the computer, the image on the screen is not automatically updated when the next trace is inserted into the gather. If you are playing with the horizontal scroll bar and the thumb tab is not at the left most position, the image on the screen will not be updated. The thumb tab on the horizontal scroll bar must be in the left most position for the image to be automatically updated. You can always click on the "Redraw" button to reset the display parameters, which will put the module in automatic update mode. That is, use the "Redraw" button after you have finished interacting with the display to enable the automatic updating of the screen image.

The actual trace display consists of the trace data displayed in either "wiggle trace" or "variable area" format. In addition to the trace data, there are labels for time, trace numbers, and FFID. The time (in seconds) label is to the left of the trace data, and the trace numbers are across the top of the plot. The FFID numbers are displayed in the row of numbers above the trace numbers.

Click Here for an Explanation of the Parameters.


Processing Display Single Trace Gather Parms

SeisNet Module: Display Single Trace Gather

Parameters

The parameters dialog box for the Display Single Trace Gather module is displayed when you click on the "P" of the icon representing the module.

Parameter names are shown in the color Green.

The parameters dialog box consists of four property pages, or "tab dialog boxes" because there are too many parameters to fit on a single page. The tabs are labeled as follows:

Display - This property page holds the parameters that relate to how the data are displayed on the screen. Such things as display times, the trace number of the trace that is inserted into the gather, and annotation increments are input via the "Display" property page.

Scaling - This property page controls how the data are scaled for displaying. Such things as whether or not you want to AGC the data are input here.

Filter - This property page controls whether or not filters are applied to the data before being displayed. The data are filtered for display purposes only. Data that is stored on the hard disk is not filtered.

Mute - This property page determines whether or not an automatic mute is applied to the data.

Parameters on the "Display" Property Page

Trace sequential number to insert into gather -- determines which trace is gathered from the data object holding a shot record. You probably will want to display a complete shot record, using the Display Trace Data module to help you determine the particular trace to select.

Trace overlap factor -- controls the amount that one trace is permitted to overlap another before clipping occurs. If you want a value different from the default value of 1.5, you will have to type-in the desired value.

Display method -- determines how the data are to be displayed. You only have two choices, which are "Wiggle Trace" and "Variable Area". If you type-in something, it must be either "Wiggle Trace" or "Variable Area". It is much easier if you use the left mouse button to make your choice.

Number of timing lines -- sets the number of timing lines that will be generated when the data are displayed on the screen.

Trace annotation increment -- determines how often the traces are annotated. If you enter 0 for the trace annotation increment, the system will attempt to make a reasonable choice.

Number of traces to display on the screen -- sets the number of traces that gets displayed on the screen. If you request more traces to be displayed than are in the single trace gather, the display window will be partially filled.

Minimum time to display on the screen -- is the parameter that controls the minimum time that gets displayed. This parameter has units of seconds.

Maximum time to display on the screen -- is the parameter that controls the maximum time that gets displayed. This parameter has units of seconds.

Check here to save single trace gather to file -- is a check box that when checked tells the Display Single Trace Gather module to save the gather to hard disk. The file is updated every time a trace is gathered from a shot record. If you do not erase this file, the data will be appended to the existing file the next time a flow is executed.

Enter name (include path) of the file where to store the single trace gather -- is a parameter that is only displayed when you choose to save the gather to hard disk. If you do not specify a filename here, the data will be saved in a file named "DefaultGather.stg" in the current working directory. Be sure to include the path name when you specify the filename. The file can be stored on both network and local drives.

Parameters on the "Scaling" Property Page

Enter gain to apply to entire record -- is a number that multiplies every sample in every trace after all other scaling has been done. The default value of 1.0 is normally the best value for this parameter. This parameter serves the same purpose as the contrast and intensity buttons on your television.

Polarity (normal or Reverse) -- determines the polarity of the data for display purposes only. There are two choices for the polarity, which are "Normal" and "Reverse". When you select "Reverse", a minus one multiplies every sample in the gather.

Interpolate data (Yes or No) -- is set to "Yes" if you want to interpolate values between sampling periods. If you select "Yes", inter-sample values will be calculated using a fourth order polynomial. Otherwise, the nearest sample value is chosen.

Apply T-ramp (Yes or No) -- is a parameter that when set to "Yes" tells the Display Single Trace Gather module to multiply each trace by time. This is useful for observing events when scaling is based on RMS values.

Check here to apply AGC operator to the data before displaying -- is a check box that you check if you want to apply an AGC operator to your data before displaying. When this parameter is in the checked state, an edit box is displayed asking you to enter the operator length in seconds. Normally, values between 0.25 and 0.5 seconds give satisfactory results.

Length of the AGC operator (in seconds) -- is displayed only when you request that an AGC operator be applied to the data. This is where you type-in the length of the AGC operator, which has units of seconds. Good values for the AGC operator are normally between 0.25 and 0.5 seconds.

Check here to scale on the RMS value of each trace -- is a check box that you check if you want to scale on the RMS value of each individual trace. When this box is in the checked state, each sample in a trace is divided by the RMS value of that trace before it is displayed.

Parameters on the "Filter" Property Page

Check here to apply a highcut (or lowpass) filter -- is a check box that you will check when you want the Display Single Trace Gather module to apply a lowpass filter before displaying the data. Note that the filtering operation does not affect the data stored on hard disk. The data are filtered for display purposes only.

Highcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highcut filter. Simply type-in the value you desire for the highcut frequency, expressed in Hz. This parameter is available only when you choose to apply a highcut or lowpass filter.

Highcut slope (in dB/Octave) -- sets the roll-off rate of the highcut, or lowpass, filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highcut, or lowpass, filter.

Highcut phase (Zero or Minimum) -- determines the phase response of the lowpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a lowpass filter.

Check here to apply a lowcut (or highpass) filter -- is a check box that you will check when you want the Display Single Trace Gather module to apply a lowcut, or highpass, filter before displaying the data. Note that the filtering operation does not affect the data in the actual gather. When the Display Single Trace Gather module filters the data, it is for display purposes only.

Lowcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the lowcut, or highpass, filter. You type-in the value you desire for the cutoff frequency. This parameter is only available when you choose to apply a lowcut, or highpass, filter.

Lowcut slope (in dB/Octave) -- sets the roll-off rate of the highpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut phase (Zero or Minimum) -- determines the phase response of the highpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a highpass filter.

Check here to apply a notch filter -- is a check box that you check when you want the Display Single Trace Gather module to apply a notch filter before displaying the data. Note that the filtering operation does not affect the data in the single trace gather. The filtering is for display purposes only.

Notch frequency (in Hz) -- sets the notch filter frequency. You type-in the value you want for the notch frequency. The default value is 60 Hz, which is the power-line frequency in the United States. If you desire a value other than 60 Hz, you must type-in your desired value. This parameter is only available when you choose to apply a notch filter.

Parameters on the "Mute" Property Page

Check here to apply automatic mute to the data -- is a check box that you will check when you want to automatically mute the data. The automatic mute function works by calculating amplitude ratios and zeroing-out all the data until a threshold is met. The value of the threshold is determined by you, which you type-in.

Mute threshold -- sets the automatic mute threshold. A value of 3.0 works good for most marine situations. You may have to experiment to get the best value for the data you are processing. This parameter is only available when you choose to apply an automatic mute.

Click Here to View Description of Module


Processing Plot Single Trace Gather (Real Time) command

SeisNet Module: Plot Single Trace Gather (Real Time)

This module plots a single trace from each shot record on the plotter in real time.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Plot Single Trace Gather (Real Time) Description

SeisNet Module: Plot Single Trace Gather (Real Time)

Description

The Plot Single Trace Gather module generates a real time single trace gather plot as data are being acquired by the SeisNet system. A single trace is taken from each shot and plotted on a V80 compatible plotter. Currently, four plotters are supported, which are the Oyo models 612 at 200 dpi, 622 at 200 dpi, 624 at 200 dpi, and 624 at 400 dpi.

In addition to displaying the trace data, a side label is generated when the first shot is acquired. The side label shows parameters that are used to generate the plot along with information entered in the 'Info/Mute' property page of the parameters dialog box. There are fields for entering the names of the contractor, client, prospect, area, crew and other identifying information in the 'Info/Mute' property page.

When the plot is created there are either two or three rows of numbers across the top of the plot. There are three rows of numbers when the option to display navigation fix numbers has been enabled. Otherwise, there are two rows of numbers. The bottom row numbers is a shot counter that always starts with 1. The middle row of numbers (top row if the option to display navigation fix numbers is disabled) is the field file identification number, FFID. The top row of numbers, when the option to display navigation numbers is enabled, are the navigation fix numbers.

A relationship exists between the navigation fix numbers and the field file numbers, which is explained below. Letting

s = Starting navigation fix number,

i = Increment for navigation fix numbering,

f = FFID of the first navigation fix,

n = number of FFID's between navigation fixes,

x = Navigation fix number, and

d = Current FFID.

When navigation fix numbers are increasing, their values are determined by the formula

x = s + (d-f) * (i/n),

and when the fix numbers are decreasing, their values are determined by the formula

x = s - (d-f)*(i/n);

Because the plot is generated in real time, the number of traces per inch that can be plotted is limited. As a practical limit, at least two traces per inch should be plotted. If you display a signal trace for every inch of paper, it is possible, depending on other parameters that have been set, that traces may appear to overlap. If this happens, it is because the buffer holding the trace data has been overrun. There should never be a problem with overrunning the buffer if the number of traces per inch parameter is always greater than or equal to two.

There are several options for processing the data before it is plotted. The data can be scaled using either an AGC operator or the RMS value of the trace. Lowpass, highpass and notch filters can either be applied or not, and an automatic mute can be used to remove noise at the beginning of the trace. It is noted that any processing performed on the data is for display purposes only. The data in the processing flow is not affected by placing the Plot Single Trace Gather module into the processing flow.

Click Here for an Explanation of the Parameters


Processing Plot Single Trace Gather (Real Time) Parms

SeisNet Module: Plot Single Trace Gather (Real Time)

Parameters

The parameters dialog box, consisting of five property pages, for the Plot Single Trace Gather module is displayed when you click on the "P" of the icon representing the module. There are five property pages in the dialog box because there are too many parameters to fit onto a single page.

Parameter names are shown in the color Green.

The tabs of the property pages are labeled as follows:

Display - This property page holds the parameters that relate to how the data are plotted on paper. Such things as display times, the trace number of the trace to be inserted into the gather, and the trace annotation increment are input via the "Display" property page.

Scaling - This property page controls how the data are scaled for displaying. Such things as whether or not you want to AGC the data are input here.

Filter - This property page controls whether or not filters are applied to the data before being plotted. When you choose a particular type of filter to apply, you will be asked to enter the parameters for that filter. For example, to apply a lowpass filter, you must enter the filter's highcut frequency, slope and phase response. Remember that data are filtered for display purposes only.

Info/Mute - This property page determines whether or not an automatic mute is applied to the data. Also, you enter information here that gets printed on the side label. The items you are asked to enter are the names of the client, contractor, prospect, area, crew and identification information.

Nav Marks - This property page sets the parameters needed to plot navigation marks across the top of the plot. If the option to print navigation fix numbers on the plot is disabled (not checked), then navigation marks will not be displayed on the plot.

Parameters on the "Display" Property Page

Trace sequential number to insert into gather -- determines which trace is gathered from the data object holding a shot record. You will probably want to display a complete shot record, using the Display Trace Data module to help you determine the particular trace to select.

Trace overlap factor -- controls the amount that one trace is permitted to overlap another before clipping occurs. If you want a value different from the default value of 1.5, you will have to type it in.

Display method -- determines how the data are to be displayed. You only have two choices, which are "Wiggle Trace" and "Variable Area". If you type-in something, it must be either "Wiggle Trace" or "Variable Area". It is much easier if you use the left mouse button to make your choice.

Number of timing lines -- sets the number of timing lines that will be generated when the data are plotted.

Trace annotation increment -- determines how often the traces are annotated.

Number of traces per inch -- sets the number of traces that are displayed per each inch of paper. The number of traces per inch should always be greater than or equal to two.

Minimum time to display (in seconds) -- is the parameter that controls the minimum time that gets displayed. This parameter has units of seconds.

Maximum time to display (in seconds) -- is the parameter that controls the maximum time that gets displayed. This parameter has units of seconds.

Plotter type -- selects the type of plotter being used. You must choose one from the list of supported plotters.

Parameters on the "Scaling" Property Page

Enter gain to apply to entire record -- is a number that multiplies every sample in every trace after all other scaling has been done. The default value of 1.0 is normally the best value for this parameter. This parameter serves the same purpose as the contrast and intensity buttons on your television.

Polarity (normal or Reverse) -- determines the polarity of the data for display purposes only. There are two choices for the polarity, which are "Normal" and "Reverse". When you select "Reverse", a minus one (-1) multiplies every sample in the gather.

Interpolate data (Yes or No) -- is set to "Yes" if you want to interpolate values between sampling periods. If you select "Yes", inter-sample values will be calculated using a fourth order polynomial. Otherwise, the nearest sample value is chosen.

Apply T-ramp (Yes or No) -- is a parameter that when set to "Yes" tells the Display Single Trace Gather module to multiply each trace by time. This is useful for observing deeper events when scaling is based on RMS values.

Check here to apply AGC operator to the data before displaying -- is a check box that you check if you want to apply an AGC operator to your data before displaying. When this parameter is in the checked state, an edit box is displayed asking you to enter the operator length in seconds. Normally, values between 0.25 and 0.5 seconds give satisfactory results.

Length of the AGC operator (in seconds) -- is displayed only when you request that an AGC operator be applied to the data. This is where you type-in the length of the AGC operator, which has units of seconds. Good values for the AGC operator are normally between 0.25 and 0.5 seconds.

Check here to scale on the RMS value of each trace -- is a check box that you check if you want to scale on the RMS value of each individual trace. When this box is in the checked state, each sample in a trace is divided by the RMS value of that trace before it is displayed.

Parameters on the "Filter" Property Page

Check here to apply a highcut (or lowpass) filter -- is a check box that you will check when you want the Plot Single Trace Gather module to apply a lowpass filter before displaying the data.

Highcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highcut filter. Simply type-in the value you desire for the highcut frequency, expressed in Hz. This parameter is available only when you choose to apply a highcut or lowpass filter.

Highcut slope (in dB/Octave) -- sets the roll-off rate of the highcut, or lowpass, filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highcut, or lowpass, filter.

Highcut phase (Zero or Minimum) -- determines the phase response of the lowpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a lowpass filter.

Check here to apply a lowcut (or highpass) filter -- is a check box that you will check when you want the Plot Single Trace Gather module to apply a lowcut or highpass, filter before displaying the data

Lowcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the lowcut, or highpass, filter. You type-in the value you desire for the cutoff frequency. This parameter is only available when you choose to apply a lowcut or highpass filter.

Lowcut slope (in dB/Octave) -- sets the roll-off rate of the highpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut phase (Zero or Minimum) -- determines the phase response of the highpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a highpass filter.

Check here to apply a notch filter -- is a check box that you check when you want the Display Single Trace Gather module to apply a notch filter before displaying the data.

Notch frequency (in Hz) -- sets the notch filter frequency. You type-in the value you want for the notch frequency. The default value is 60 Hz, which is the power-line frequency in the United States. If you desire a value other than 60 Hz, you must type-in your desired value. This parameter is only available when you choose to apply a notch filter.

Parameters on the "Info/Mute" Property Page

Check here to apply automatic mute to the data -- is a check box that you will check when you want to automatically mute the data. The automatic mute function works by calculating amplitude ratios and zeroing-out all the data until a threshold is met. The value of the threshold is determined by you, which you type-in.

Mute threshold -- sets the automatic mute threshold. A value of 3.0 seems to work pretty good for most marine situations. You may have to experiment to get the best value for the data you are processing. This parameter is only available when you choose to apply an automatic mute.

Client -- is an ASCII string that gets printed on the side label under the "Client" heading.

Contractor -- is an ASCII string that gets printed on the side label under the "Contractor" heading

Prospect -- is the name of the prospect that gets printed on the side label.

Area -- is the name of the area that gets printed on the side label

Crew -- is the name of the crew that gets printed on the side label.

I.D. Info -- is additional information that gets printed on the side label to help identify the particular data being plotted. You might enter a line or swath name here. This information is printed under the "Identifying Information" heading on the side label.

Parameters on the "Nav Marks" Property Page

Check here to print navigation fix numbers on the plot -- is an option that will print an extra row of numbers across the top of the plot. This extra row of numbers consists of navigation fix numbers pegged to the FFID. The relationship between the FFID and the navigation fix number is explained above.

Starting navigation fix number -- is the first number of the navigation fix. It is pegged to the FFID for the first navigation fix.

Increment for navigation fix numbering -- is the increment for either increasing or decreasing the navigation fix numbers.

Increment or decrement fix numbers -- determines whether the navigation fix numbers are either incremented or decremented. You must choose either "Increment" or "Decrement" from the combo box using the left mouse button.

FFID of the first navigation fix -- pegs the starting navigation fix number to the FFID specified here.

Number of FFID's between navigation fixes -- is the number of FFID's between navigation fixes.

Click Here to View Description of Module


Processing Display Capture Screen to Printer command

SeisNet Module: Capture Screen to Printer

The Capture Screen to Printer module is used to send an image of what is displayed on the computer screen to the printer. This is commonly known as a screen dump.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Display Capture Screen to Printer Description

SeisNet Module: Capture Screen to Printer

Description

The Screen Dump module captures the screen image and sends it to the printer. With this module you can specify which records you want to print. For example, if you choose to increment by 10, the 1st, 10th, 20th, etc. screen image corresponding to the 1st, 10th, 20th, etc. shot record acquired will be printed. If you don't specify anything, every shot record will be printed.

Click Here for an Explanation of the Parameters


Processing Display Capture Screen to Printer Parms

SeisNet Module: Capture Screen to Printer

Parameters

The parameters dialog box, for the Capture Screen to Printer module is displayed when you click on the "P" of the icon representing the module. There is only one parameter to input:

Parameter names are shown in the color Green.

Number of Shots between dumps -- is the increment at which a screen image is captured and sent to the printer. If you are displaying shot records on the screen, and you set this parameter to 10, then every 10th shot record will be sent to the printer.

Click Here to View Description of Module


Processing Display Plot Traces on HP LaserJet command

SeisNet Module: Plot Traces on HP LaserJet

The Plot Traces on HP LaserJet module is used to plot seismic traces on the HP LaserJet. The HP LaserJet can be used as very effective plotter when the number of traces in a record is small.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Display Plot Traces on HP LaserJet Description

SeisNet Module: Plot Traces on HP LaserJet

Description

The Plot Traces on HP LaserJet module plots the traces in a data object on the HP LaserJet. In order to plot seismic traces on the LaserJet, the legal paper tray must be installed in the printer. If it has not been installed, you will get a message displayed on the printer asking you to install the legal tray. The plot can span more than one page, which is accomplished by setting the number of pages in the horizontal and vertical directions to something other than one. For example, if you set the number of pages in the horizontal direction to 2 and the number of pages in the vertical direction to 3, then the plot will span 6 pages, with the page numbers being as follows:

1 of 6 4 of 6

2 of 6 5 of 6

3 of 6 6 of 6

In addition to the trace data, a side label is generated for every page printed, which is actually displayed at the top of each page. The side label shows parameters that are used to generate the plot along with information entered in the 'Info/Mute' property page of the parameters dialog box. There are fields for entering the names of the contractor, client, prospect, area, crew and other identifying information.

When the plot is created, there are two rows of number across the top of the plot. The top row displays the channel set number and the trace number within the channel set, and the bottom row displays a trace sequential number.

You can select the traces you want displayed on the plot. If you check the box asking if you want to limit the number of traces plotted, an edit box is displayed where you type-in the trace numbers to plot. It is not necessary to type-in the number of every trace to be plotted. You can enter a range and increment to save on the amount typing. Consider the following example of an input to select particular traces.

1, 3, 4, 5, 20-30(2), 50-55

This example tells the SeisNet system to plot traces that have sequential trace numbers: 1, 3, 4, 5, 20, 22, 24, 26, 28, 30, 50, 51, 52, 53, 54, 55.

There are several options for processing the data before it is plotted. The data can be scaled using either an AGC operator, the RMS value of each trace, the RMS value of a particular trace or the average of the RMS values of all the traces. The aux traces are scaled on the peak value of each trace.

Options are available for applying lowpass, highpass and notch filters. When a particular filtering operation is requested, edit boxes are displayed for you to enter the filter parameters. For example, if you check the box to apply a highcut (or lowpass) filter, three boxes appear asking you to enter the cutoff frequency, the filter slope and the phase type.

An automatic mute can be used to remove the noise at the beginning of the trace. To achieve optimum results, you may have to play around with the automatic mute threshold. Generally, the default value of three gives a pleasing appearance.

It is noted that any processing performed on the data is for display purposes only. The data in the data object is not affected by plotting data on a LaserJet.

Click Here for an Explanation of the Parameters


Processing Display Plot Traces on HP LaserJet Parms

SeisNet Module: Plot Traces on HP LaserJet

Parameters

The parameters dialog box, consisting of four property pages, for the Plot Traces on HP LaserJet module is displayed when you click on the "P" of the icon representing the module. There are four property pages in the dialog box because there are too many parameters to fit onto a single page.

Parameter names are shown in the color Green.

The tabs of the property pages are labeled as follows:

Display - This property page holds the parameters that relate to how the data are plotted on paper. Such things as display times, number of pages to plot for each record and the trace annotation increment are input via the "Display" property page.

Scaling - This property page controls how the data are scaled for displaying. Such things as whether or not you want to AGC the data are input here.

Filter - This property page controls whether or not filters are applied to the data before being plotted. When you choose a particular type of filter to apply, you will be asked to enter the parameters for that filter. For example, to apply a lowpass filter, you must enter the filter's highcut frequency, slope and phase response. Remember that data are filtered for display purposes only.

Info/Mute - This property page determines whether or not an automatic mute is applied to the data. Also, you enter information here that gets printed on the side label. The items you are asked to enter are the names of the client, contractor, prospect, area, crew and identification information.

Parameters on the "Display" Property Page

Trace overlap factor -- controls the amount that one trace is permitted to overlap another before clipping occurs. If you want a value different from the default value of 1.5, you will have to type it in.

Display method -- determines how the data are to be displayed. You only have two choices, which are "Wiggle Trace" and "Variable Area". If you type-in something, it must be either "Wiggle Trace" or "Variable Area". It is much easier if you use the left mouse button to make your choice.

Number of timing lines -- sets the number of timing lines that will be generated when the data are plotted.

Trace annotation increment -- determines how often the traces are annotated.

Minimum time to display (in seconds) -- is the parameter that controls the minimum time that gets displayed. This parameter has units of seconds.

Maximum time to display (in seconds) -- is the parameter that controls the maximum time that gets displayed. This parameter has units of seconds.

Number of pages horizontally -- determines the number of pages that make up the plot horizontally. For example, if there are 240 traces to be plotted, and you set the number of pages horizontally to 2, then 120 traces will be plotted on each page.

Number of pages vertically -- sets the number of pages that make up the plot in the vertically direction. For example, if the minimum time to plot is 0.0 seconds, and the maximum time to plot is 2.0 seconds and you set the number of pages vertically to 2, then the 0.0 to 1.0 seconds will be plotted on the first page and 1.0 to 2.0 seconds will be plotted on the second page.

Check here if you want to limit the number of traces plotted -- is a check box that when in the checked state displays an edit box where you type-in the trace numbers of the traces you select for plotting.

Enter the trace numbers to be plotted -- allows you to select the trace numbers of the traces that get plotted. For example, if you enter: 1,2,3,10-20(2), then traces with trace numbers of 1, 2, 3, 10, 12, 14, 16, 18, 20 will be plotted.

Parameters on the "Scaling" Property Page

Polarity (normal or Reverse) -- determines the polarity of the data for display purposes only. There are two choices for the polarity, which are "Normal" and "Reverse". When you select "Reverse", a minus one (-1) multiplies every sample in the gather.

Interpolate data (Yes or No) -- is set to "Yes" if you want to interpolate values between sampling periods. If you select "Yes", inter-sample values will be calculated using a fourth order polynomial. Otherwise, the nearest sample value is chosen.

Apply T-ramp (Yes or No) -- is a parameter that when set to "Yes" tells the Display Single Trace Gather module to multiply each trace by time. This is useful for observing deeper events when scaling is based on RMS values.

Check here to apply AGC operator to the data before displaying -- is a check box that you check if you want to apply an AGC operator to your data before displaying. When this parameter is in the checked state, an edit box is displayed asking you to enter the operator length in seconds. Normally, values between 0.25 and 0.5 seconds give satisfactory results.

Length of the AGC operator (in seconds) -- is displayed only when you request that an AGC operator be applied to the data. This is where you type-in the length of the AGC operator, which has units of seconds. Good values for the AGC operator are normally between 0.25 and 0.5 seconds.

Check here to scale on the RMS value of each trace -- is a check box that you check if you want to scale on the RMS value of each individual trace. When this box is in the checked state, each sample in a trace is divided by the RMS value of that trace before it is displayed.

Check here to scale on the RMS value of a particular trace -- is a check box that you check if you want to scale all the traces in the data object by the RMS value of a particular trace. If you check this box an edit box appears asking you to enter the trace number of the trace you want to scale on.

Enter the sequential trace number to scale on -- determines the trace that is used for scaling when you want to scale all the data in the data object based on the RMS value of a particular trace.

Enter gain to apply to entire record -- is a number that multiplies every sample in every trace after all other scaling has been done. The default value of 1.0 is normally the best value for this parameter. This parameter serves the same purpose as the contrast and intensity buttons on your television.

Parameters on the "Filter" Property Page

Check here to apply a highcut (or lowpass) filter -- is a check box that you will check when you want the Plot Traces on HP LaserJet module to apply a lowpass filter before displaying the data.

Highcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highcut filter. Simply type-in the value you desire for the highcut frequency, expressed in Hz. This parameter is available only when you choose to apply a highcut or lowpass filter.

Highcut slope (in dB/Octave) -- sets the roll-off rate of the highcut, or lowpass, filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highcut or lowpass filter.

Highcut phase (Zero or Minimum) -- determines the phase response of the lowpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a lowpass filter.

Check here to apply a lowcut (or highpass) filter -- is a check box that you will check when you want the Plot Traces on HP LaserJet module to apply a lowcut or highpass, filter before displaying the data

Lowcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the lowcut, or highpass, filter. You type-in the value you desire for the cutoff frequency. This parameter is only available when you choose to apply a lowcut or highpass filter.

Lowcut slope (in dB/Octave) -- sets the roll-off rate of the highpass filter. There are several predefined values that you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut phase (Zero or Minimum) -- determines the phase response of the highpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a highpass filter.

Check here to apply a notch filter -- is a check box that you check when you want the Plot Traces on HP LaserJet module to apply a notch filter before displaying the data.

Notch frequency (in Hz) -- sets the notch filter frequency. You type-in the value you want for the notch frequency. The default value is 60 Hz, which is the power-line frequency in the United States. If you desire a value other than 60 Hz, you must type-in the desired value. This parameter is only available when you choose to apply a notch filter.

Parameters on the "Info/Mute" Property Page

Check here to apply automatic mute to the data -- is a check box that you will check when you want to automatically mute the data. The automatic mute function works by calculating amplitude ratios and zeroing-out all the data until a threshold is met. The value of the threshold is determined by you, which you type-in.

Mute threshold -- sets the automatic mute threshold. A value of 3.0 seems to work pretty good for most marine situations. You may have to experiment to get the best value for the data you are processing. This parameter is only available when you choose to apply an automatic mute.

Client -- is an ASCII string that gets printed on the side label under the "Client" heading.

Contractor -- is an ASCII string that gets printed on the side label under the "Contractor" heading

Prospect -- is the name of the prospect that gets printed on the side label.

Area -- is the name of the area that gets printed on the side label

Crew -- is the name of the crew that gets printed on the side label.

I.D. Info -- is additional information that gets printed on the side label to help identify the particular data being plotted. You might enter a line or swath name here. This information is printed under the "Identifying Information" heading on the side label.

Click Here to View Description of Module


Tape Copy

SeisNet Module: Trace Highlight

The Trace Highlight module allows the user to highlight specified traces on screen displays with a selected color.

To learn more about this module select one of the following:

Description

Parameters


Description of Tape Copy Module

SeisNet Module: Trace Highlight

Description

This module provides the ability to highlight specified traces with a selected color on the screen display. Multiple modules may be used in a flow to provide multi-color highlights.

Click Here for Explanation of the Parameters


Parameters for Tape Copy Module

SeisNet Module: Trace Highlight

Parameters

The parameters dialog box for the Trace Highlight module is displayed when you click on the "P" of the icon representing the module.

Parameter names are shown in the color Green.

Trace Color – Select trace color from the available color palette.

Trace Selection – Select traces to be highlighted.

Enter trace numbers and/or trace number ranges with increments, separated by commas.

The trace specification format is:

trc# - trc# (increment)

For example:

1, 2, 3, 5-10, 12-20(2)

will display traces 1, 2, 3, 5, 6, 7, 8, 9, 10, 12, 14, 16, 18, 20.

Click Here to View Description of Module.


Scaling Under SeisNet's Processing Menu

Apply Scale Factor | Applies a Specific Scale Factor to the Data
Convert to Microbars | Converts the Data to have Units of Microbars


Processing Scaling Apply Scale Factor command

SeisNet Module: Apply Scale Factor

The Apply Scale Factor module multiplies every sample by a constant that you specify.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Display Trace Data Description

SeisNet Module: Apply Scale Factor

Description

The Apply Scale Factor module is used to multiply every sample in the data set by a constant that you specify. Aux traces are not affected by this module.

Click Here for an Explanation of the Parameters


Processing Scaling Apply Scale Factor Parms

SeisNet Module: Apply Scale Factor

Parameters

The parameters dialog box for the Apply Scale Factor module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Enter scale factor -- is the value that will be used to scale all the seismic traces. Each trace is multiplied by the value specified here. Aux traces are not scaled by this module.

Click Here to View Description of Module.


Processing Scaling Convert to Microbars command

SeisNet Module: Convert to Microbars

The Convert to Microbars module will scale the data so that all the seismic traces will have units of microbars. The aux traces are not affected by this module.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Scaling Convert to Microbars Description

SeisNet Module: Convert to Microbars

Description

This module scales all the seismic traces to have units of microbars. The scaling does not affect the aux traces.

You are required to type-in a conversion constant, which is normally the hydrophone sensitivity factor. The sensitivity factor should have units of Volts/Bar.

Click Here for an Explanation of the Parameters


Processing Scaling Convert to Microbars Parms

SeisNet Module: Convert to Microbars

Parameters

The parameters dialog box for the Convert to Microbars module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Enter the conversion constant -- is the scale factor that converts the seismic data to have units of microbars. The scale factor is normally the hydrophone sensitivity factor expressed in Volts/Bar.

Click Here to View Description of Module


Stacking and Geometry Under SeisNet's Processing Menu

Simple Marine Geometry | Adds Simple Marine Geometry to the SeisNet Data Object
Real-Time Brute Stack | Calculates, with Optional Semblance Analysis, a Brute Stack
SPS Geometry | Adds Geometry to Flow from SPS files.


Processing Stacking Simple Marine Geometry command

SeisNet Module: Simple Marine Geometry

The Simple Marine Geometry module is used to add geometry to the SeisNet object. This module assumes that there is a single source and a single receiver line.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Stacking Simple Marine Geometry Description

SeisNet Module: Simple Marine Geometry

Description

Geometry information must be provided to the SeisNet system before a brute stack can be generated. The "Simple Marine Geometry" module inserts information about the position of the sources and receivers into the trace headers. The position of the source and receiver determine the offset distance and the coordinates of the common reflecting point, CDP. For stacking operations, the data are reordered so that the traces that contribute to a given reflection point occur in sequence. To ease the implementation of the reordering and stacking processes, easting and northing, for both source and receiver, are assigned to each trace. CDP numbers are also assigned because they are needed for indexing by the "Real-Time Brute Stack" module.

The seismic data are assumed to be in shot-ordered format, namely, a particular source point with many receivers. Furthermore, the receivers are assumed to be in sequential order and laid-out in a single row. That is, a single streamer and a single set of air guns. The field file identification number, FFID, is used to distinguish between the different shots.

The "Simple Marine Geometry" module uses the Universal Transverse Mercator Coordinate System (UTM) for referencing source and receiver locations. You must supply the easting and northing for two different FFID's. The SeisNet system then uses linear interpolation and extrapolation to derive the source locations for all other FFID's. Receiver locations are determined using linear interpolation and extrapolation from your input of source to receiver distances for two different traces. Direction of the boat is determined by the order in which the parameters are entered. For example, if the easting and northing of the first point specified is (500000, 500000) and (600000, 600000) for the second point, then the boat will be traveling from the south west to the north east.

Click Here for an Explanation of the Parameters


Processing Stacking Simple Marine Geometry Parms

SeisNet Module: Simple Marine Geometry

Parameters

The parameters dialog box for the Simple Marine Geometry module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Unit of Measure -- determines whether distances are expressed in either meters or feet.

FFID to use to specify the first location -- pegs the location of the first source point.

FFID to use to specify the second location -- pegs the location of the second source point

Easting corresponding to the first source location -- is the easting for the first specified source point.

Northing corresponding to the first source location -- is the northing for the first specified source point.

Easting corresponding to the second source location -- is the easting for the second specified source point.

Northing corresponding to the second source location -- is the northing for the second specified source point.

Source to receiver distance for first trace specified -- normally specifies the distance from the source to receiver for the near trace.

Trace sequential number of the first trace to specify -- normally specifies the sequential trace number of the near trace.

Source to receiver distance for the second trace specified -- normally specifies the distance from the source to receiver for the far trace.

Trace sequential number of the second trace to specify -- normally specifies the sequential trace number of the far trace.

Click Here to View Description of Module


Processing Stacking Real-Time Brute Stack command

SeisNet Module: Real-Time Brute Stack

The Real-Time Brute Stack module calculates a real-time brute stack as the data are being acquired. An automatic semblance analysis is available to calculate the optimum stacking velocity.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Stacking Real-Time Brute Stack Description

SeisNet Module: Real-Time Brute Stack

Description

"Real-Time Brute Stack" is a SeisNet module that calculates a 2D common depth point, CDP, stacked section in real-time. Before a stack can be generated, geometry information must be inserted into the trace headers. The "Simple Marine Geometry" module can be used to supply that information when the shooting is in a straight line and there is a single set of air guns.

Stacking of seismic data collected at ever increasing separation of source and receiver about a common surface point has proven to be an extremely powerful processing procedure in improving the signal-to-noise ratio and is specially useful in suppressing coherent multiples. When the subsurface formations consist of horizontal layers, the common surface coincides with the projection of the CDP to the surface. In the case of dipping layers, the stacked data does not have a common depth point, but rather have reflections from a subsurface segment whose length increases with dip. In order to enhance primaries and suppress multiples, it is essential to stack the data along normal move-out curves appropriate for the primary reflection. In the normal case of increasing velocity with depth, the move-out at any fixed record time will be less for the primary reflection than any coherent multiple arriving at that time. The larger the differential normal move-out between primary and multiple reflections, the easier it is to differentially suppress the multiples. In the case of a velocity inversion with depth, it may be difficult to identify primaries and multiples, and may be impossible to separate them by stacking.

To generate a stack, all the traces with a common surface point are gathered together, and after normal move-out are summed together. Derivation of the normal move-out corrections to be applied prior to stacking is equivalent to determining the velocity structure of the prospect area. When the offsets are small, a general velocity function (here called a base velocity function) taken from a previous survey could suffice for generating a brute stack. However, as the range of offsets start to exceed approximately 2,500 feet, a better estimate of velocity is needed.

We employ a method to analyze a CDP gather to automatically find the 'best-fit' value of velocity, as follows. At a given two-way-travel-time, choice of a stacking velocity defines a hyperbolic time-offset relation across the gather. We calculate these hyperbolae for a wide range of velocities. Along each hyperbola, we then measure the semblance for each stacked trace using a 50ms time window. The best velocity for a specific two-way travel-time is then chosen by picking the velocity corresponding to the hyperbola yielding the maximum semblance. This process is implemented when you choose to perform an automatic semblance analysis.

Velocity estimation from seismic data is limited in accuracy and resolution for the following reasons:

  1. Offset,
  2. Stacking fold,
  3. Signal-to-noise ratio,
  4. Muting,
  5. Velocity sampling,
  6. Departures from hyperbolic move-out, and
  7. Bandwidth of the data.

Lack of large-offset information means lack of the significant move-out required for velocity discrimination. Although far-offset data are needed to better resolve the estimation of velocity, there is a stretching problem in the normal move-out process in the far-offset region. Therefore, velocity estimation based on only far-offset data suffers from the effects of muting at shallow times. We suggest that you limit the far-offset to something less than 3,000 feet for real time stacking. However, there are no limitations placed on offset by the SeisNet system. The more offsets that are included in the stack, the more computer time required to generate the stack.

Stacking fold helps determine the degree of resolution achieved in the estimate of velocity. In this module, fold is determined by your shooting geometry and the number of offsets you permit in the stack. You will probably want to include enough offsets so that you have at least 16-fold.

Noise in the seismic data directly effects the quality of the velocity estimate. You have the capability to apply lowpass, highpass, and notch filters before normal move-out and stacking. The frequency content, however, of the seismic section will be affected when you apply the filters.

Because of the normal move-out process, the waveform along the reflection hyperbola will be stretched. Stretching is more severe in the shallow part of the moved-out trace, and especially so when the offset is large. The stretched zone should be muted to prevent degradation of the stack. This module lets you choose from two different types of offset mutes. You can choose a linear offset mute to mute direct arrivals and shallow refraction events, or a hyperbolic mute to mute along some hyperbola. In both types of mutes, the shape is determined by the mute time of the zero-offset trace and the mute velocity.

The velocity spectrum is calculated along hyperbolas for several different velocity functions. The velocity range and the number of velocity functions should be chosen carefully. Trial velocity functions should be chosen that correspond to the primary reflections. The number of velocity functions should not be too small, because it can degrade the resolution of the section, especially for high-velocity events. Choosing a large number of velocity functions will increase the time required to compute the stack. It is recommended that you choose to use at least seven velocity functions and a percentage factor not greater than five percent. These minimum values produce a 30 percent velocity cone that is 15 percent on either side of the base velocity function. When performing an automatic semblance analysis to estimate velocity, you will want to enter the best base velocity function you can obtain and keep the velocity cone to something less than 30 percent. If you make the velocity cone too large, there is the possibility of stacking multiple events.

This module assumes that the move-out curves are hyperbolas. When the move-out curves cannot be approximated by hyperbolas, you will probably want to do further processing on a full-blown processing system.

Several options are available for constructing the velocity estimate. One is filtering, to remove noise outside the bandwidth of the data. You have the capability to apply lowpass, highpass, and notch filters to the data before processing. This will increase the signal-to-noise ratio, but it will also reduce the bandwidth.

Experience in a particular survey will always help when choosing the parameters for stacking and velocity estimation. The obvious goal is to choose the velocity function that will stack primary reflections and suppress multiple reflections.

Click Here for an Explanation of the Parameters


Processing Stacking Real-Time Brute Stack Parms

SeisNet Module: Real-Time Brute Stack

Parameters

The parameters dialog box for the Real-Time Brute Stack module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

The parameters dialog box consists of four property pages, or "tabbed dialog boxes" because there are too many parameters to fit onto a single page. The tabs are labeled as follows:

Display -- is the property page that holds the parameters that relate to how the data are displayed on the computer screen. Such things are display time, traces that are to be displayed, and annotation increments are input via the "Display" property page.

Stacking -- is the property page that holds the parameters needed for stacking.

Filter -- is the property page that sets the type of filtering that is applied to the data before stacking occurs.

Mute -- is the property page used to input a mute function.

Parameters on the "Display" Property Page

Trace overlap factor -- controls the amount that one trace is permitted to overlap another before clipping occurs. Generally the default value of 1.5 traces gives a pleasing display.

Number of timing lines -- sets the number of timing lines that will be generated when the data are displayed on the screen. You type-in the value you desire for the number of timing lines if you want a value different from the default value of 11 lines.

Trace annotation increment -- determines how often the traces are annotated. You can use the default value of 0 to let the SeisNet system determine the annotation increment.

Number of traces to display on the screen -- is the parameter that determines the number of traces that gets displayed on the computer screen. The default value of 240 traces is just about the maximum number of traces you will want to display, unless you have a 17" or greater monitor.

Minimum time to display (in seconds) -- sets the minimum time that gets displayed. This parameter can be modified with the interactive controls (toolbar buttons and vertical scroll bar) on the display. That is, when you do either a zoom-in or zoom-out, the minimum time to display can potentially be modified. However, when you click on the "Redraw" button, the minimum time to display will be set to the value specified here.

Maximum time to display (in seconds) -- sets the maximum time that gets displayed. This parameter can be modified with the interactive controls (toolbar buttons and vertical scroll bar) on the display. That is, when you do either a zoom-in or zoom-out, the maximum time to display can potentially be modified. However, when you click on the "Redraw" button, the maximum time to display will be set to the value specified here.

Gain to apply to entire record -- is a number that multiplies every sample in every trace after all other scaling has been done. The default value of 1.0 is normally the best value for this parameter. This parameter serves the same purpose as the contrast and intensity buttons on your television.

Polarity to use for display (Normal or Reverse) -- determines the polarity of the data for display purposes only. There are only two choices for the polarity. They are "Normal" and "Reverse". Use the left button on your mouse to make your decision.

Interpolate between samples (Yes or No) -- is set to "Yes" if you want to interpolate values between samples. If you select "Yes", sample values will be calculated using a fourth order polynomial. Otherwise, inter-sample values will be determined by choosing the value of the nearest sample.

Apply a T-Ramp before displaying data (Yes or No) -- is a parameter that when set to "Yes" will tell the software to multiply each trace by time. This feature is useful for observing deeper events when scaling is based on the RMS value of each trace. This value is ignored when an AGC operator is applied to the data.

Check here to apply AGC operator to the data before displaying -- is a check box that you check if you want to apply an AGC operator to the data. When this parameter is in the checked state, an edit box is displayed asking you to enter the operator length in seconds.

Length of the AGC operator (in seconds) -- is a parameter that you only have to enter when you want to apply an AGC operator to the data. You type-in the length of the AGC operator, which has units of seconds. Good values for the AGC operator normally lie in the range of 0.25 to 0.5 seconds.

Check here to scale on the RMS value of each trace -- is a check box that you check if you want to scale on the RMS value of each individual trace. When this box is in the checked state, each sample in a trace is divided by the RMS value of that trace before the trace is displayed.

Parameters on the "Stacking" Property Page

Minimum offset to place into stack -- is the minimum source to receiver distance for traces that will be placed in the stack. The units of measure are determined by the geometry that has been inserted into the trace and record headers. The source to receiver distance should be expressed in either meters or feet.

Maximum offset to place into stack -- is the maximum source to receiver distance for traces that will be placed in the stack. The units of measure are determined by the geometry that has been inserted into the trace and record headers. The source to receiver distance should be expressed in either meters or feet.

Enter the Base Velocity Function -- sets the base velocity function that will be used for the stacking process. If the option to perform an automatic semblance analysis is turned-off, then every CDP will be stacked with the velocity function specified here. That is, the entire seismic section will be generated using a single velocity function. If the option to perform an automatic semblance analysis is turned-on, then a different velocity function is calculated for every CDP. The automatic semblance algorithm uses the base velocity function as a starting point to build a velocity spectra, from which the best velocity function is determined for that CDP.

You enter the base velocity function as time-velocity pairs using the following format:

time-velocity, time-velocity, ........,

where time is entered in seconds and velocity is entered in either feet per second or meters per second. An example of how you enter a base velocity function is:

0.0-5000.0, 1.0-7500.0, 2.0-10000.0, 2.5-11000.0, 4.0-15000.0

Spaces are optional, however the dash '-' between time and velocity and the comma ',' between the time-velocity pairs are required.

Check here to save the stack to file -- is a check box that when checked tells the SeisNet system to save the seismic section to hard disk before exiting the program. You should note that the section is not saved until you click on either the 'Kill' or 'Exit' button on the main bar menu. When performing an automatic semblance analysis and you are saving the section to hard disk, the portion of the stack that has not been completed will have to be finished before the program can terminate. This can take several seconds to several minutes, depending on the range of offsets being placed into the stack. A popup dialog box is displayed giving you the status of the clean-up process. When the popup dialog goes away, then the seismic section will have been saved to hard disk.

Enter the name (include path) of where to store the stacked section -- lets you specify the name of the file where the stacked data (seismic section) is stored. You choose the filename using the common windows control for selecting a filename. You have the ability to create folders and new files with this common control. The name of the file should have an extension of '.SEIS' so that SeisNet knows that it is a "data object" file. The '.SEIS' extension will be appended to the filename automatically. So, all you have to do is simply type the name and not the extension.

Check here to perform an automatic semblance analysis -- is a check box that you check when you want the SeisNet system to generate a velocity function for every CDP that is stacked. The best velocity function is determined by choosing the velocity corresponding to the maximum semblance within a velocity cone.

Enter the number of velocity functions to generate -- tells the automatic semblance procedure the number of different velocity functions to generate when performing the semblance analysis. The velocity function used to generate a semblance trace is determined by multiplying the base velocity function by a percentage factor. For example, assume that the base velocity function is given by:

0.0-5000, 4.0-20000,

and the percentage parameter is 5 percent and the number of velocity functions to generate is 7. Then, seven semblance traces will be generated using the following velocity functions:

1st Semblance trace 0.0-4250, 4.0-17000

2nd Semblance trace 0.0-4500, 4.0-18000

3rd Semblance trace 0.0-4750, 4.0-19000

4th Semblance trace 0.0-5000, 4.0-20000

5th Semblance trace 0.0-5250, 4.0-21000

6th Semblance trace 0.0-5500, 4.0-22000

7th Semblance trace 0.0-5750, 4.0-23000

The velocity chosen at any particular time will be the velocity corresponding to the semblance trace with the maximum semblance. A smoothing operator, consisting of a median and moving average filter, is applied to the calculated velocity function to prevent aliasing.

Percentage parameter for generating velocity functions -- in conjunction with the number of velocity functions to generate determines the size and shape of the cone for the velocity spectra. To firm-up how the size and sample of the cone for the velocity spectra is determined, consider the example where the desired number of velocity functions is 7 and the percentage factor is 5 percent:

First velocity function: 0.85 times the base velocity function

Second velocity function: 0.90 times the base velocity function

Third velocity function: 0.95 times the base velocity function

Fourth velocity function: 1.00 times the base velocity function

Fifth velocity function: 1.05 times the base velocity function

Sixth velocity function: 1.10 times the base velocity function

Seventh velocity function: 1.15 times the base velocity function.

For this example, the cone for the velocity spectra is 30 percent of, and centered on, the base velocity function.

Parameters on the "Filter" Property Page

Check here to apply a highcut (or lowpass) filter -- is a check box that you will check when you want to apply a lowpass filter before doing the normal move-out. Because normal move-out is a highly nonlinear process, the filter is applied before the trace is moved-out.

Highcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highcut filter. Simply type-in the 3dB frequency you want your lowpass filter to have.

Highcut slope (in dB/Octave) -- sets the roll-off rate of the lowpass filter. There are several predefined values you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a lowpass filter.

Highcut phase (Zero or Minimum) -- determines the phase response of the lowpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a lowpass filter.

Check here to apply a lowcut (or highpass) filter -- is a check box that you will check when you want to apply a highpass filter before doing the normal move-out. Because normal move-out is a highly nonlinear process, the filter is applied before the trace is moved-out.

Lowcut frequency (in Hz) -- is the parameter that determines the cutoff frequency of the highpass filter. Simply type-in the 3dB frequency you want the highpass filter to have.

Lowcut slope (in dB/Octave) -- sets the roll-off rate of the lowpass filter. There are several predefined values you can choose from. If you don't like any of the predefined values, you can type-in a different value. This parameter is only available when you choose to apply a highpass filter.

Lowcut phase (Zero or Minimum) -- determines the phase response of the highpass filter. There are only two choices, which are "Zero Phase" and "Minimum Phase". This parameter is only available when you choose to apply a highpass filter.

Check here to apply a notch filter -- is a check box that you will check when you want to apply a notch filter before doing the normal move-out. Because normal move-out is a highly nonlinear process, the filter is applied before the trace is moved out.

Notch frequency (in Hz) -- sets the notch filter frequency. You type-in the value of the frequency you want to attenuate. Normally, this is either 60Hz or 50Hz. Don't type the characters 'Hz'. For example, type-in 60 and NOT 60Hz.

Parameters on the "Mute" Property Page

Check here to apply a linear offset mute to the data before stacking -- is a check box that you check if you want to apply a linear offset mute to the data before doing the normal moveout. For a linear offset mute the mute time is determined by the equation:

tm = v*x + t0,

where tm is the calculated mute time, v is the mute velocity, x is the offset, t0 is the mute time of the zero offset trace, and the character '*' stands for multiplication.

Check here to apply a hyperbolic offset mute to the data before stacking -- is a check box that you check if you want to apply a hyperbolic offset mute before doing the normal move-out. For a hyperbolic mute the mute time is determined by the equation:

tm = sqrt(t0 * t0 + (x * x)/(v * v)),

where tm is the calculated mute time, v is the mute velocity, x is the offset, t0 is the mute time of the zero offset trace, the character '*' stands for multiplication, and sqrt means square root of.

Check here and NO mute will be applied to the data before stack -- is a check box that you check when you do NOT want to apply a mute before doing the normal move-out.

Mute time (in seconds) of the zero-offset trace -- sets the mute time of the zero-offset trace. The zero-offset mute time can be determined by looking at the direct arrival of the near trace. This parameter is valid only when you decide to apply either a linear offset mute or a hyperbolic offset mute. If no mute is to be applied, then you do not have to enter this parameter.

Mute velocity -- is used to calculate the mute times based on the equations shown above.

Length of taper (in seconds) of the transition zone -- sets the width of the transition from no data to unaltered data. The default value of 50 milliseconds is normally a good choice for this parameter. A linear taper is applied to the data in a time window from the mute time to the sum of the mute time and the length of the transition zone.

Click Here to View Description of Module


Tape Copy

SeisNet Module: SPS Geometry

The SPS Geometry module is used to add geometry information to a SeisNet flow. Source and receiver position information is taken from the SPS dataset and inserted into the SeisNet data object.

To learn more about this module select one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: SPS Geometry

Description

The SPS Geometry module is used to provide geometry information to a SeisNet data flow. The module takes as input the name of the source file in the SPS dataset. The SPS dataset is assumed to have three files with extensions of “.r”, “.s” and “.x”. The file extensions have the following meaning: “.r” implies the receiver file, “.s” implies the source file and “.x” implies the cross-reference or relational file.

In SeisNet, the name of the source file is used to represent the SPS dataset. The source filename is split into its component parts and “.r” is appended to the filename to name the receiver file and “.x” is appended to represent the cross-reference file. For example, if “D:\Test\Data\test.s” is input as the source filename, then “D:\Test\Data\test.r” will be the name of the receiver file and “D:\Test\Data\test.x” will be the name of the cross-reference file.

It is important to note that for performance reasons the SPS dataset is read when the flow is first started. If your SPS dataset changes, you will have to restart your flow.

Documentation for the SPS format can be obtained from the SEG at:

http:/www.seg.org/publications/tech-stand/seg_sps_rev0.pdf

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: SPS Geometry

Parameters

The parameters dialog box for the SPS Geometry module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Enter the name of the SPS SOURCE File. Receiver and Relation files will have same name with extensions “.R” and “.X”. – specifies the name of the source file in the SPS dataset. The receiver and cross-reference files are assumed to have the same name as the source file but with extensions of “.R” and “.X” respectively. You can use the Browse button to help locate the required file. When you click on the Browse button, a standard windows dialog box appears any you simply point-and-click until you locate the SPS source file.

Click Here to View Description of Module


Attributes Under SeisNet's Processing Menu

Calculate Attributes | Calculates Trace Attributes in a SeisNet Data Object
Display RMS Values Top Window | Displays RMS Values from the Top Time Window
Display RMS Values Bottom Window | Displays RMS Values from the Bottom Time Window
Display Peak Values Top Window | Displays Peak Values from the Top Time Window.
Display Peak Values Bottom Window | Displays Peak Values from the Bottom Time Window.


Processing Attributes Calculate command

SeisNet Module: Calculate Attributes

The Calculate Attributes module is used to trace attributes from the seismic data. Such things as RMS and peak values are calculated in two different time windows.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: Calculate Attributes

Description

The Calculate Attributes module is used to calculate trace attributes on each seismic trace in a SeisNet data object. You have the option to save the calculated attributes to hard disk.

To calculate the attributes you must specify the beginning and ending times of two time windows. The first time window is called the top window and the second time window is called the bottom window. Normally, the top window would refer to a time window early in the trace and the bottom window would refer to a time window late in the trace. Hence, the names top and bottom. Within each time window the RMS and peak values are calculated. In addition, the time when the peak valued occurred is also determined. The calculated attributes are stored in the SeisNet data object, which is subsequently passed to the next module in the flow. Attributes must be calculated before any of the attribute display modules can be inserted into you flow.

When you elect to save the attribute data to hard disk, you must specify a name and path for the file that will hold attribute data. The filename you specify must be fully path qualified. An example of a fully qualified filename is shown below:

D:\AttributeData\SampleData.atr.

Here the data will be written to the "AttributeData" directory on the D: drive. The name of the file in that directory will be "SampleData.atr".

The attribute data is stored in the attributes file in a binary format. You can examine the source code in the file SampleCodeReadAttr.htm to see how to retrieve the attribute data from the attributes file.

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeitNet Module: Calculate Attributes

Parameters

The parameters dialog box for the Calculate Attributes module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Starting time of the first time window (in seconds) --is the starting time for the first time window. The first time window is normally the window that has the earliest starting time, and it is called the top window. You can choose from the list of pre-defined values, which are 0.0, 0.1, 0.2, 0.3, 0.4 or 0.5 seconds. The list of pre-defined values is obtained by clicking on the down arrow button on the right side of the of the parameter field. If you don't want to use one of the pre-defined values, simply type-in the desired value.

Ending time of the first time window (in seconds) --is the ending time for the first time window. The first time window is normally the window that has the earliest starting time, and it is called the top window. You can choose from the list of pre-defined values, which are 1.0, 1.5, 2.0 or 2.5 seconds. The list of pre-defined values is obtained by clicking on the down arrow button on the right side of the parameter field. If you don't want to use one of the pre-defined values, simply type-in the desired value.

Starting time of the second time window (in seconds) --is the starting time for the second time window. The second time window is normally the window that has the later starting time, and it is called the bottom window. You can choose from the list of pre-defined values, which are 3.5, 4.0, 4.5 or 5.0 seconds. The list of pre-defined values is obtained by clicking on the down arrow button on the right side of the parameter field. If you don't want to use one of the pre-defined values, simply type-in the desired value.

Ending time of the second time window (in seconds) --is the ending time for the second time window. The second time window is normally the window that has the later starting time, and it is called the bottom window. You can choose from the list of pre-defined values, which are 4.0, 4.5, 5.0, 5.5 or 6.0 seconds. The list of pre-defined values is obtained by clicking on the down arrow button on the right side of the parameter field. If you don't want to use one of the pre-defined values, simply type-in the desired value.

Check here if you want to save the attributes to hard disk -- is a check box that you check when you want to save the calculated attributes to hard disk. When you elect to save the attributes, another parameter is displayed asking you to enter the name of the file for storing the data.

Enter the name (including path) of where to store the attribute data -- is the parameter that gets displayed when you elect to save the attribute data to hard disk. The name enter must be fully path qualified. An example of a fully qualified file name is: <D:\AttributeData\SampleData.atr>. Here, the attribute data will be stored in file "SampleData.atr" in the "AttributeData" directory on the "D:" drive.

Click Here to View Description of Module


Processing Attributes Display RMS Values Top Window command

SeisNet Module: Display RMS Values Top Window

The Display RMS Values Top Window module displays the RMS values that were calculated by the Calculate Attributes module earlier in the flow.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Attributes Display RMS Values Top Description

SeisNet Module: Display RMS Values Top Window

Description

The Display RMS Values Top Window module displays the RMS values that were calculated by the Calculate Attributes module for the top time window. The Calculate Attributes module must be placed into your flow before this module. That is, the RMS values must be calculated before they can be displayed.

A conventional bar graph is used to display the RMS values, and there are several buttons displayed at the top of the plot so that you can interactively decide what you want to see. In addition, the concept of a Goodness Threshold is used to show the relative amplitudes between the traces. The color of the bar representing the RMS value for a particular trace is shown in one color if the value is less than the Goodness threshold. It is shown in a different color when the RMS value exceeds the Goodness threshold. You have complete control over setting of the value of the goodness threshold.

The buttons on the button bar are described below and the names of the buttons are shown in Green.

Manual/Automatic -- is a button that lets you pause the execution of the flow. If the word manual is displayed on the button, the flow is suspended and it will not continue until you click on the Manual button. When the word Automatic is displayed on the button, the display will be updated every time a new record is obtained by one of the input modules. You convert from the manual to the automatic mode by clicking on the Manual button, and from the automatic to manual mode by clicking on the Automatic button.

Redraw -- is used to update the display with the permanent set of parameters. This button is very useful for resetting the display with a known set of parameters when you have finished playing with the display parameters.

Reset Parms -- is used to bring up the parameters dialog box so that you can permanently change the display parameters. The display is automatically updated when you exit the parameters dialog box.

Max/Up -- is used to interactively increase the maximum RMS value that gets displayed. The maximum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the maximum RMS value that gets displayed. The maximum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Up -- is used to interactively increase the minimum RMS value that gets displayed. The minimum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the minimum RMS value that gets displayed. The minimum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Bar Color -- is used to set the color of the bars for values that are less than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Thes Color -- is used to set the color of the bars for values that are greater than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Scroll Bar -- is used to interactively set the value of the Goodness Threshold. Simply grab the slider control and move it up and down to change the value of the Goodness Threshold. The value of the Goodness Threshold is only temporary when it is set with the scroll bar.

When you move the mouse around the display area the trace number and the RMS value are shown in little windows on the button bar.

Click Here for an Explanation of the Parameters


Processing Attributes Display RMS Values Top Parms

SeisNet Module: Display RMS Values Top Window

Parameters

The parameters dialog box for the Display RMS Values Top Window module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Minimum RMS value to display -- is the smallest RMS value that will be displayed. This value can also be adjusted temporarily using the Min/Up and Min/Down buttons on the button bar.

Maximum RMS value to display -- is the largest RMS value that will be displayed. The value can also be adjusted temporarily using the Max/Up and Max/Down buttons on the button bar.

Goodness threshold -- is the RMS value that determines when a color change occurs for the color of a bar representing a RMS value. If the RMS value for a particular trace is greater than the Goodness threshold the bar color will be one value. If the RMS value for a particular trace is less than the Goodness Threshold the color of the bar will be different value. You determine the color of the bar using the Bar Color and Thres Color button on the button bar.

Number of traces to display on the screen -- determines the number of bars that will be displayed on the plot.

Trace annotation increment -- controls the frequency of annotation for the trace numbering across the top of the display.

No. of annotations for the RMS values displayed -- controls the number of annotation for the y-axis of the display. This is analogous to the number of timing lines on a seismic display.

Enter the list of trace numbers you wish to display -- is the edit box where you type-in the trace numbers of the traces you want to see displayed. The format for entering trace numbers is "trc# - trc#(increment)". For example, if you typed "1, 2, 3, 5-10, 12-20(2)", traces 1, 2, 3, 5, 6, 7, 8, 9, 10, 12, 14, 16, 18, and 20 would be displayed:

Click Here to View Description of Module


Processing Attributes Display RMS Values Top Window command

SeisNet Module: Display RMS Values Bottom Window

The Display RMS Values Bottom Window module displays the RMS values that were calculated by the Calculate Attributes module earlier in the flow.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Attributes Display RMS Values Top Description

SeisNet Module: Display RMS Values Bottom Window

Description

The Display RMS Values Bottom Window module displays the RMS values that were calculated by the Calculate Attributes module for the bottom time window. The Calculate Attributes module must be placed into your flow before this module. That is, the RMS values must be calculated before they can be displayed.

A conventional bar graph is used to display the RMS values, and there are several buttons displayed at the top of the plot so that you can interactively decide what you want to see. In addition, the concept of a Goodness Threshold is used to show the relative amplitudes between the traces. The color of the bar representing the RMS value for a particular trace is shown in one color if the value is less than the Goodness threshold. It is shown in a different color when the RMS value exceeds the Goodness threshold. You have complete control over setting of the value of the goodness threshold.

The buttons on the button bar are described below and the names of the buttons are shown in Green.

Manual/Automatic -- is a button that lets you pause the execution of the flow. If the word manual is displayed on the button, the flow is suspended and it will not continue until you click on the Manual button. When the word Automatic is displayed on the button, the display will be updated every time a new record is obtained by one of the input modules. You convert from the manual to the automatic mode by clicking on the Manual button, and from the automatic to manual mode by clicking on the Automatic button.

Redraw -- is used to update the display with the permanent set of parameters. This button is very useful for resetting the display with a known set of parameters when you have finished playing with the display parameters.

Reset Parms -- is used to bring up the parameters dialog box so that you can permanently change the display parameters. The display is automatically updated when you exit the parameters dialog box.

Max/Up -- is used to interactively increase the maximum RMS value that gets displayed. The maximum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the maximum RMS value that gets displayed. The maximum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Up -- is used to interactively increase the minimum RMS value that gets displayed. The minimum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the minimum RMS value that gets displayed. The minimum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Bar Color -- is used to set the color of the bars for values that are less than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Thes Color -- is used to set the color of the bars for values that are greater than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Scroll Bar -- is used to interactively set the value of the Goodness Threshold. Simply grab the slider control and move it up and down to change the value of the Goodness Threshold. The value of the Goodness Threshold is only temporary when it is set with the scroll bar.

When you move the mouse around the display area the trace number and the RMS value are shown in little windows on the button bar.

Click Here for an Explanation of the Parameters


Processing Attributes Display RMS Values Top Parms

SeisNet Module: Display RMS Values Bottom Window

Parameters

The parameters dialog box for the Display RMS Values Bottom Window module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Minimum RMS value to display -- is the smallest RMS value that will be displayed. This value can also be adjusted temporarily using the Min/Up and Min/Down buttons on the button bar.

Maximum RMS value to display -- is the largest RMS value that will be displayed. The value can also be adjusted temporarily using the Max/Up and Max/Down buttons on the button bar.

Goodness threshold -- is the RMS value that determines when a color change occurs for the color of a bar representing a RMS value. If the RMS value for a particular trace is greater than the Goodness threshold the bar color will be one value. If the RMS value for a particular trace is less than the Goodness Threshold the color of the bar will be different value. You determine the color of the bar using the Bar Color and Thres Color button on the button bar.

Number of traces to display on the screen -- determines the number of bars that will be displayed on the plot.

Trace annotation increment -- controls the frequency of annotation for the trace numbering across the top of the display.

No. of annotations for the RMS values displayed -- controls the number of annotation for the y-axis of the display. This is analogous to the number of timing lines on a seismic display.

Enter the list of trace numbers you wish to display -- is the edit box where you type-in the trace numbers of the traces you want to see displayed. The format for entering trace numbers is "trc# - trc#(increment)". For example, if you typed "1, 2, 3, 5-10, 12-20(2)", traces 1, 2, 3, 5, 6, 7, 8, 9, 10, 12, 14, 16, 18, and 20 would be displayed:

Click Here to View Description of Module


Processing Attributes Display RMS Values Top Window command

SeisNet Module: Display Peak Values Top Window

The Display Peak Values Top Window module displays the peak values that were calculated by the Calculate Attributes module earlier in the flow.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Attributes Display RMS Values Top Description

SeisNet Module: Display Peak Values Top Window

Description

The Display Peak Values Top Window module displays the peak values that were calculated by the Calculate Attributes module for the top time window. The Calculate Attributes module must be placed into your flow before this module. That is, the peak values must be calculated before they can be displayed.

A conventional bar graph is used to display the peak values, and there are several buttons displayed at the top of the plot so that you can interactively decide what you want to see. In addition, the concept of a Goodness Threshold is used to show the relative amplitudes between the traces. The color of the bar representing the peak value for a particular trace is shown in one color if the value is less than the Goodness threshold. It is shown in a different color when the peak value exceeds the Goodness threshold. You have complete control over setting of the value of the goodness threshold.

The buttons on the button bar are described below and the names of the buttons are shown in Green.

Manual/Automatic -- is a button that lets you pause the execution of the flow. If the word manual is displayed on the button, the flow is suspended and it will not continue until you click on the Manual button. When the word Automatic is displayed on the button, the display will be updated every time a new record is obtained by one of the input modules. You convert from the manual to the automatic mode by clicking on the Manual button, and from the automatic to manual mode by clicking on the Automatic button.

Redraw -- is used to update the display with the permanent set of parameters. This button is very useful for resetting the display with a known set of parameters when you have finished playing with the display parameters.

Reset Parms -- is used to bring up the parameters dialog box so that you can permanently change the display parameters. The display is automatically updated when you exit the parameters dialog box.

Max/Up -- is used to interactively increase the maximum peak value that gets displayed. The maximum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the maximum peak value that gets displayed. The maximum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Up -- is used to interactively increase the minimum peak value that gets displayed. The minimum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the minimum peak value that gets displayed. The minimum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Bar Color -- is used to set the color of the bars for values that are less than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Thes Color -- is used to set the color of the bars for values that are greater than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Scroll Bar -- is used to interactively set the value of the Goodness Threshold. Simply grab the slider control and move it up and down to change the value of the Goodness Threshold. The value of the Goodness Threshold is only temporary when it is set with the scroll bar.

When you move the mouse around the display area the trace number and the peak value are shown in little windows on the button bar.

Click Here for an Explanation of the Parameters


Processing Attributes Display RMS Values Top Parms

SeisNet Module: Display Peak Values Top Window

Parameters

The parameters dialog box for the Display Peak Values Top Window module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Minimum peak value to display -- is the smallest peak value that will be displayed. This value can also be adjusted temporarily using the Min/Up and Min/Down buttons on the button bar.

Maximum peak value to display -- is the largest peak value that will be displayed. The value can also be adjusted temporarily using the Max/Up and Max/Down buttons on the button bar.

Goodness threshold -- is the peak value that determines when a color change occurs for the color of a bar representing a peak value. If the peak value for a particular trace is greater than the Goodness threshold the bar color will be one value. If the peak value for a particular trace is less than the Goodness Threshold the color of the bar will be different value. You determine the color of the bar using the Bar Color and Thres Color button on the button bar.

Number of traces to display on the screen -- determines the number of bars that will be displayed on the plot.

Trace annotation increment -- controls the frequency of annotation for the trace numbering across the top of the display.

No. of annotations for the peak values displayed -- controls the number of annotation for the y-axis of the display. This is analogous to the number of timing lines on a seismic display.

Enter the list of trace numbers you wish to display -- is the edit box where you type-in the trace numbers of the traces you want to see displayed. The format for entering trace numbers is "trc# - trc#(increment)". For example, if you typed "1, 2, 3, 5-10, 12-20(2)", traces 1, 2, 3, 5, 6, 7, 8, 9, 10, 12, 14, 16, 18, and 20 would be displayed:

Click Here to View Description of Module


Processing Attributes Display RMS Values Top Window command

SeisNet Module: Display Peak Values Bottom Window

The Display Peak Values Bottom Window module displays the peak values that were calculated by the Calculate Attributes module earlier in the flow.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Attributes Display RMS Values Top Description

SeisNet Module: Display Peak Values Bottom Window

Description

The Display Peak Values Bottom Window module displays the peak values that were calculated by the Calculate Attributes module for the bottom time window. The Calculate Attributes module must be placed into your flow before this module. That is, the peak values must be calculated before they can be displayed.

A conventional bar graph is used to display the peak values, and there are several buttons displayed at the top of the plot so that you can interactively decide what you want to see. In addition, the concept of a Goodness Threshold is used to show the relative amplitudes between the traces. The color of the bar representing the peak value for a particular trace is shown in one color if the value is less than the Goodness threshold. It is shown in a different color when the peak value exceeds the Goodness threshold. You have complete control over setting of the value of the goodness threshold.

The buttons on the button bar are described below and the names of the buttons are shown in Green.

Manual/Automatic -- is a button that lets you pause the execution of the flow. If the word manual is displayed on the button, the flow is suspended and it will not continue until you click on the Manual button. When the word Automatic is displayed on the button, the display will be updated every time a new record is obtained by one of the input modules. You convert from the manual to the automatic mode by clicking on the Manual button, and from the automatic to manual mode by clicking on the Automatic button.

Redraw -- is used to update the display with the permanent set of parameters. This button is very useful for resetting the display with a known set of parameters when you have finished playing with the display parameters.

Reset Parms -- is used to bring up the parameters dialog box so that you can permanently change the display parameters. The display is automatically updated when you exit the parameters dialog box.

Max/Up -- is used to interactively increase the maximum peak value that gets displayed. The maximum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the maximum peak value that gets displayed. The maximum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Up -- is used to interactively increase the minimum peak value that gets displayed. The minimum value is increased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Min/Down -- is used to interactively decrease the minimum peak value that gets displayed. The minimum value is decreased approximately 25% every time you click on the button. Clicking on the redraw button resets the display using the permanently saved parameters.

Bar Color -- is used to set the color of the bars for values that are less than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Thes Color -- is used to set the color of the bars for values that are greater than the Goodness Threshold. A color dialog box is displayed when you click on the button. The bar color can only be changed when you are operating in the manual mode.

Scroll Bar -- is used to interactively set the value of the Goodness Threshold. Simply grab the slider control and move it up and down to change the value of the Goodness Threshold. The value of the Goodness Threshold is only temporary when it is set with the scroll bar.

When you move the mouse around the display area the trace number and the peak value are shown in little windows on the button bar.

Click Here for an Explanation of the Parameters


Processing Attributes Display RMS Values Top Parms

SeisNet Module: Display Peak Values Bottom Window

Parameters

The parameters dialog box for the Display Peak Values Bottom Window module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Minimum peak value to display -- is the smallest peak value that will be displayed. This value can also be adjusted temporarily using the Min/Up and Min/Down buttons on the button bar.

Maximum peak value to display -- is the largest peak value that will be displayed. The value can also be adjusted temporarily using the Max/Up and Max/Down buttons on the button bar.

Goodness threshold -- is the peak value that determines when a color change occurs for the color of a bar representing a peak value. If the peak value for a particular trace is greater than the Goodness threshold the bar color will be one value. If the peak value for a particular trace is less than the Goodness Threshold the color of the bar will be different value. You determine the color of the bar using the Bar Color and Thres Color button on the button bar.

Number of traces to display on the screen -- determines the number of bars that will be displayed on the plot.

Trace annotation increment -- controls the frequency of annotation for the trace numbering across the top of the display.

No. of annotations for the peak values displayed -- controls the number of annotation for the y-axis of the display. This is analogous to the number of timing lines on a seismic display.

Enter the list of trace numbers you wish to display -- is the edit box where you type-in the trace numbers of the traces you want to see displayed. The format for entering trace numbers is "trc# - trc#(increment)". For example, if you typed "1, 2, 3, 5-10, 12-20(2)", traces 1, 2, 3, 5, 6, 7, 8, 9, 10, 12, 14, 16, 18, and 20 would be displayed:

Click Here to View Description of Module


Utilities Under SeisNet's Processing Menu

Detect Dead Traces | Detects Dead Traces and Sets Flag in Header
Remove Dead Trace Flags | Removes Dead Trace Flags from the Trace Headers
Telseis Trace Selection | Selects Traces for Processing from the Telseis System
Q.C. Link | Handles Gun Controller Data Stored in Header
Pick First Breaks | Module to Pick First Breaks
Vertical Stacking | Module for Vertical Stacking
Spectrum Attributes | Calculates Spectrum Attributes for Selected Traces
Power Spectrum of Single Trace | Calculates the Amplitude Spectrum of a Single Trace
MarineQC | Calculates Attributes and Stores them in a Database
Save First Break Picks | Saves First Break Picks to Hard Disk.
Vib Pro Index File | Generates Cross-Reference File for Vib Pro/SEG-D
Marine Source Logging | Logs Information about the Marine Source


Processing Utilities Detect Bad Traces command

SeisNet Module: Detect Dead Traces

The Detect Dead Traces module is used to identify and flag dead traces.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Utilities Detect Bad Traces Description

SeisNet Module: Detect Dead Traces

Description

The Detect Dead Traces module is an automated method for determining and flagging dead traces. When a dead trace is detected, a flag is set in the trace header indicating a dead trace. Traces that have the dead trace flag set in the trace header are colored red when displayed on the computer screen using the Display Seismic Traces module.

A dead trace is determined by comparing it’s calculated trace energy with the median trace energy calculated for the entire spread. When a trace’s energy is less than or greater than the median value by the dB value specified as the “Dead Trace Threshold” parameter, the dead trace flag is set in the trace header. A second parameter setting “Far Trace Offset Time” is used to optimize the accuracy of the average energy value by eliminating the near trace energy from the calculation.

It should be noted that the seismic data are not modified. A flag is set in the trace header when a dead trace is detected. In addition, an aux trace is never flagged as dead.

Click Here for an Explanation of the Parameters


Processing Utilities Detect Bad Traces Parms

SeisNet Module: Detect Dead Traces

Parameters

The parameters dialog box for the Detect Dead Traces module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Far Trace Offset Time (in seconds) – This parameter is set to reflect the time of the first arrivals on the traces farthest from the source, as determined by viewing the data using the Display Seismic Traces module. The purpose of this parameter is to restrict the data values used to calculate the average trace energy, by eliminating the near trace energy from the calculation and thus improving the accuracy of the calculated results. The default value is set to 2.0 seconds.

Dead Trace Threshold (in dB) – This parameter specifies the minimum deviation (in dB) of individual trace energy values, compared to the calculated average trace energy value, to determine a dead trace. The default value is 48dB.

Click Here to View Description of Module


Processing Utilities Remove Bad Trace Flags command

SeisNet Module: Remove Dead Trace Flags

The Remove Dead Trace Flags module is used to clear the dead trace flags in the SeisNet trace headers.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Utilities Remove Bad Trace Flags Description

SeisNet Module: Remove Dead Trace Flags

Description

The Remove Dead Trace Flags module clears all the dead trace flags that have been set in the trace headers.

When a SeisNet data object is saved to disk and the dead trace flags have been set, the dead trace flags also get saved. The purpose of this module is to clear all the dead trace flags so that traces are not colored red when they are displayed.

Click Here for an Explanation of the Parameters


Processing Utilities Remove Bad Trace Flags Parms

SeisNet Module: Remove Dead Trace Flags

Parameters

The Remove Dead Trace Flags module does not have parameters.

Click Here to View Description of Module


Processing Utilities Select Traces from Telseis command

SeisNet Module: Select Traces from Telseis System

The Select Traces from Telseis System module is used to choose particular traces for further processing when recording with the Telseis system.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Utilities Select Traces from Telseis Description

SeisNet Module: Select Traces from Telseis System

Description

The Telseis Trace Selection module is a utility that lets you select the traces to be processed. The traces selected for processing are determined from your input and shot numbers and receiver numbers decoded from the trace header. You specify the number of receiver locations, centered on the shot number, that you want to process. If the receiver number falls in this range, the trace is selected for processing. Otherwise, the trace is deleted from the data object.

It is noted that this module is useful only for data recorded with the Telseis system. The Telseis system encodes the shot and receiver numbers in bytes 17 through 20 of the trace header. Since this placement of the shot and receiver numbers in the trace header is not part of the SEG-D standard, this module will not work with data recorded from other types of recording systems.

Click Here for an Explanation of the Parameters


Processing Utilities Select Traces from Telseis Parms

SeisNet Module: Select Traces from Telseis System

Parameters

The parameters dialog box for the Select Traces from Telseis System module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Number of Receiver Stations Centered on Shot Location -- specifies the number of receiver stations that are to be considered for selecting traces for processing. The number you specify here is first divided by two. The result of this operation is added and then subtracted from the shot location number to give the range of receiver numbers for trace selection. For example, if the shot location number is 1500 and you enter 100 for the number of receiver stations, then all traces with receiver numbers between 1450 and 1550 will be selected for processing.

Click Here to View Description of Module


Processing Utilities Q.C. Link command

SeisNet Module: Q.C. Link

The Q.C. Link module is used to get gun controller information from the recording system's record header.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Utilities Q.C. Link Description

SeisNet Module: Q.C. Link

Description

The Q.C. Link module takes information from the gun controller, which was stored in the SEG-D record header, and creates a Microsoft Access Database. There are two tables created to make-up the Access database. The first table, called the "Shot" table, is used to store information about a particular shot, and the second table, called the "Gun" table is used to store information about individual guns. There is a single entry (row) in the "Shot" table for each shot captured by SeisNet. However, there can be several entries in the "Gun" table for each shot. For example, if there are twenty guns in the gun array, then there will be twenty entries (rows) in the "Gun" table for each shot. That is, every gun gets an entry in the "Gun" table for every shot.

At present the Q.C. Link module supports two types of gun controllers. They are the GCS90 from Syntron and GUNDA from Geco Prakla. Below, you will find an explanation of the fields in each table and how the information is obtained for the different gun controllers.

The "Shot" table has fourteen columns:

FFID is taken from the recording system for all controllers.

Line # is taken from the GCS90 header block for the GCS90 controller. The line number is taken from the third block of the SEG-D general header for the GUNDA controller.

Date is taken from the recording system for all controllers

Shot Point is taken from the GCS90 header block for the GCS90 controller. The shot point number is taken from the third block of the SEG-D general header for the GUNDA controller.

Manifold is taken from the GCS90 header block for the GCS90 controller and is taken form the GUNDA header block GUNDA controller.

# Subarrays is taken from the GCS90 header block for the GCS90 controller and is calculated from the information in the GUNDA header block for the GUNDA controller.

# Guns is taken from the GCS90 header block for the GCS90 controller and from the GUNDA header block for the GUNDA controller.

# Active is taken from the GCS90 header block for the GCS90 controller and is set to 0 for the GUNDA controller.

#Delta is taken from the GCS90 header block for the GCS90 controller and is set to 0 for the GUNDA controller.

# Autofires is taken from the GCS90 header block for the GCS90 controller and is set to 0 for the GUNDA controller.

#Missfires is taken from the GCS90 header block for the GCS90 controller and is calculated from the GUNDA header block for the GUNDA controller.

Delta Spread is taken from the GCS90 header block for the GCS90 controller and is set to 0 for the GUNDA controller.

Volume Fired is taken from the GCS90 header block for the GCS90 controller and is calculated by summing the volume fired from each gun for the GUNDA controller.

Deep Tow is taken from the GCS90 header block for the GCS90 controller. The value of "Deep Tow" is used to signify the source array when the GUNDA controller is employed. When using the GUNDA controller, a value of '1' means that the port array was fired, and a value of '0' means that the starboard array was fired.

The "Gun" table has eleven columns:

FFID is taken from the recording system for all controllers

Line # is taken from the GCS90 header block for the GCS90 controller. The line number is taken from the third block of the SEG-D general header for the GUNDA controller.

Date is taken from the recording system for all controllers.

Shot Point is taken from the GCS90 header block for the GCS90 controller. The shot point number is taken from the third block of the SEG-D general header for the GUNDA controller.

Gun # is taken from the GCS90 header block for the GCS90 controller and is taken from the GUNDA header block for the GUNDA controller.

Fire-Time is taken from the GCS90 header block for the GCS90 controller and is taken from the 'Error' field of the GUNDA header block for the GUNDA controller.

Delay is taken from the GCS90 header block for the GCS90 controller and is taken from the 'Delay' field of the GUNDA header block for the GUNDA controller.

Offset is taken from the GCS90 header block for the GCS90 controller and is taken from the 'Offset' field of the GUNDA header block for the GUNDA controller.

Delta is taken from the GCS90 header block for the GCS90 controller and is taken from the 'Tilt' field of the GUNDA header block for the GUNDA controller.

Depth is taken from the GCS90 header block for the GCS90 controller and is taken from the 'Gun Volume' field of the GUNDA header block for the GUNDA controller. Note that this field is the depth of the gun below the ocean's surface for the GCS90 controller and it is the gun volume in cubic inches for the GUNDA controller.

Seq # is taken from the GCS90 header block for the GCS90 controller and is calculated by SeisNet for the GUNDA controller.

Click Here for an Explanation of the Parameters


Processing Utilities Q.C. Link Parms

SeisNet Module: Q.C. Link

Parameters

The parameters dialog box for the Q.C. Link module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Enter name of the MS Access Database. Use the Browse Button for Point-and-Click operation. -- Here, you enter the name of your Access database. You can click on the Browse button to enable the standard Windows interface for locating and naming files.

Choose the type of Gun Controller. -- This is the parameter you use to tell SeisNet about the type of gun controller being employed by the recording system. At present there are only two types of controllers supported. They are the GCS90 and GUNDA. You must select one of these.

Click Here to View Description of Module


Processing Utilities Detect Bad Traces command

SeisNet Module: Pick First Breaks

The Pick First Breaks module in conjunction with the SPS Geometry module, utilizes the SPS geometry information to pick the first breaks and output the results to a disk file for receiver position determination by the navigation system.

You may learn more about this module by selecting one of the following:

Description

Parameters


Processing Utilities Detect Bad Traces Description

SeisNet Module: Pick First Breaks

Description

The Pick First Breaks module in conjunction with the SPS Geometry module, provides the ability to output a first break pick file for use in determination of receiver positions.

SeisNet uses the source position information and the receiver drop coordinates from the provided SPS files, to calculate the source to receiver distance, or offset. The offset, in conjunction with a user-supplied velocity, is used to calculate a theoretical first break pick. A first break time window is then defined centered on the theoretical first break pick. The width of the first break time window is a parameter entered in SeisNet's parameter dialog box. The actual first break pick made by SeisNet is forced to fall within this first break time window.

When you enable the display of first break pick information in SeisNet's trace display module, tic marks are super-imposed on the trace display to show you the first break time window and the theoretical and SeisNet picks. Referring to the figure below, it can be seen that the first break time window is bounded by Green tic marks. The theoretical first break pick is shown with a Blue tic mark, and the SeisNet first break pick is shown with a Red tic mark.

Displaying the first break pick information is accomplished by placing a check mark next to the parameter Check here to display time picks from SeisNet's geometry module in the Display Trace Data parameters dialog box.

SeisNet's first break picking procedure consists of first calculating the envelope of the trace in the first break time window. Next a threshold value is determined by calculating the peak signal amplitude within the first break time window and multiplying by the user entered Trip Value Percentage parameter (Default value 10%). Starting at the top of the first break time window, the envelope is searched until a value exceeding the threshold is found. Finally, the pick is refined by determining the preceding zero crossing and advancing to the point at which the trace amplitude exceeds a calculated peak noise value.

The first break pick data along with source line number, shot point number, receiver line number, ground station number and calculated source to receiver offsets are then written to a disk file as specified by the user in the parameters dialog box. This file is an ASCII format file.

Click Here for an Explanation of the Parameters


Processing Utilities Detect Bad Traces Parms

SeisNet Module: Pick First Breaks

Parameters

The parameters dialog box for the Pick First Breaks module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Minimum offset to use when picking the first breaks (feet or meters) -- is the smallest offset that will be allowed when picking the first breaks. The offset for a particular trace must be greater than the minimum offset and less than the maximum offset for a pick to be made on that trace. Traces with offsets outside this range are ignored. The units of measure (feet or meters) are determined by whatever units are used to express the source and receiver positions.

Maximum offset to use when picking the first breaks (feet or meters) -- is the largest offset that will be allowed when picking the first breaks. The offset for a particular trace must be greater than the minimum offset and less than the maximum offset for a pick to be made on that trace. Traces with offset outside this range are ignored. The units of measure (feet or meters) are determined by whatever units are used to express the source and receiver positions.

Width (in seconds) of the first break time window --specifies the width of the first break time window. The first break time window is centered on the theoretical first break, which is the offset divided by the velocity.

Velocity (feet/sec or meters/sec) --is used to determine the theoretical pick time. The theoretical pick time is the offset divided by this velocity.

Trip value expressed as a percentage of the peak value -- determines the trip threshold value. The threshold is determined by taking the peak amplitude within the first break window and multiplying it by the trip value percentage.

Enter name and path of file to hold First Break Picks – Specifies the name and location of the First Break Pick file to contain the first break picks and associated geometry data.

Click Here to View Description of Module


Processing Utilities Detect Bad Traces command

SeisNet Module: Vertical Stacking

The 'Vertical Stacking' module combines together several records for which the source and geophone locations remain the same. You have the option of doing either a straight vertical stack or a diversity stack. In a straight vertical stack all the traces in the stack are given equal weight. In a diversity stack each trace in the stack is scaled by the inverse of the power in the trace prior to stacking.

In addition to stacking, there is the ability to apply a noise reduction procedure. The three options for noise reduction are: 1) Zero the noisy parts of a trace, 2) Clip the noisy parts of a trace or 3) Remove the trace from the stack.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of the Vertical Stacking Module

SeisNet Module: Vertical Stacking

Description:

Vertical stacking involves combining together several records for which both the source and geophone locations remain the same. It is used extensively with the Vibroseis method of exploration. In actual practice the surface source is moved a small amount (3-10 meters) between successive recordings. Up to twenty or more records may be vertically stacked.

An option is provided for stacking data from two different sets of vibrators. Placing a check mark next to either Configuration A or Configurations B in the VERTICAL STACKING MODULE control panel determines the vibrator set that is shaking. The VERTICAL STACKING MODULE control panel is displayed during the stacking operation to provide status information about the stack.

The vertical stacking module in SeisNet can perform either provides a straight vertical stack or a diversity stack. In a straight vertical stack, all traces are given the same weight in the stack. In a diversity stack, each trace is scaled either by the inverse of the average power or the inverse of the RMS power in the trace before stacking. Renormalization is carried-out by dividing by the composite gain used during the stacking process.

If you are doing a diversity stack, you must choose to scale either by the average or RMS power before starting a SeisNet flow. It is recommended that you use the default scaling of RMS power unless you are in an area with a lots of low-level burst noise.

The effect of vertical stacking is essentially the same as using multiple shots or multiple source units simultaneously. Trace data can be input to a SeisNet flow from either a hard disk or DCT card.

When data are acquired used the DCT card, it can be stored on hard disk before being stacked. This way you can use SeisNet to stack and correlate the data with different parameters to get an optimum result. After you have determined the best parameters for stacking and written the data to tape, you can always remove the data from the hard disk. This procedure makes stacking an offline process. It is much cheaper to rerun a SeisNet flow than it is to backup the vibrators and reshoot the source point or points.

An example is presented below showing the results from both straight vertical stacking and diversity stacking. It is noted that this example shows the best result using straight vertical stacking because the traces being stacked are very noisy. Diversity stacking works best when the noise is low-level burst noise.

First Shot Record in Stack: Note the noise on trace number 51, which is the third trace from the left.

Second Shot Record in Stack: The noise has gotten larger on trace number 51.

Third Shot Record in Stack: The noise is not as large as in the first and second records above, but it is still larger than the adjacent traces.

Fourth Shot Record in Stack: There is very little noise on trace number 51.

Conventional Vertical Stack: The noise on trace number 51 has been greatly reduced on trace number 51 using a straight vertical stack.

Diversity Stack using RMS Power: The noise has been reduced on trace number 51 using a diversity stack when scaling is based on the RMS power. The noise reduction is not as great as the straight vertical stack because diversity stacking is the most effective on low level burst noise.

Diversity Stack using Average Power: The noise level is quite large when diversity stacking is scaled using average power. This is because three traces with large noise values are summed into a stack of four.

Data can be input to a SeisNet flow either from the hard disk or the DCT card. After the data are put into a SeisNet flow it can then be passed to “Vertical Stacking” module. It is a good idea to place the “Vertical Stacking” module immediately following the acquisition module. Two SeisNet flows are shown below where “Vertical Stacking” module immediately follows the acquisition module.

Two processing flows. The flow (A) reads data from the hard disk and the (B) flow reads data from the DCT Card.

In addition to vertical stacking, the “Vertical Stacking” module provides the capability to do noise editing. The “Vertical Stacking” module supports three types of noise editing:

1. “Zero the noisy parts of a trace” uses a threshold determined by calculating the average power in time windows. The time windows are the same length as those used in diversity stacking. The procedure works using a user defined threshold and a noise tracking editor. When a burst of noise is detected, the tracking editor determines the location of the noise and looks for zero-crossings on either side of the noise burst. The trace is then zeroed for the duration of the noise burst.

2. “Clip the noisy parts of a trace” works by clipping any trace value whose absolute amplitude exceeds a predefined user specified threshold.

3. “Remove trace from stack” is used to remove a bad trace from the stack. For example if you had a stack of four and one trace is bad, then you would end-up with a stack of three.

Click Here for an Explanation of the Parameters


Parameters for the Vertical Stacking Module

SeisNet Module: Vertical Stacking

Parameters:

There are two sets of parameters for the 'Vertical Stacking' module. The first set of parameters is called real-time and consists of parameters that can be changed during the execution of the flow. Real-time parameters for vertical stacking are input in the control panel for vertical stacking which is displayed whenever a flow is executed containing a 'Vertical Stacking' module. The vertical stacking control panel, shown below, is initially displayed in the lower right-hand corner of the screen. You can move it by placing the mouse on the title bar and dragging it to a new location.

The real-time parameters for vertical stacking are described below, where the parameter names are shown in the color Green.

Reset Sweep Counter -- is a push button that you click on to reset the internal counter that keeps track of the number of sweeps inserted into the stack. When you click on this button you will be asked if you really want to reset the sweep counter. If you answer 'Yes' any data that has been acquired for this VP will be discarded.

Status -- is a small window in the control panel that displays information about the progress of the stack and any error messages.

Check Here for Configuration A – is chosen when you want to create a stack with the number of sweeps specified in Configuration A. The number of sweeps in Configuration A is specified in the “Vertical Stacking” module’s parameters dialog box. This is a real-time parameter and it should be chosen before the start of the stacking process. Once a stack is started, the parameters for Configuration A will be used to complete the stack. In other words, the number of sweeps in a stack must be specified before the stack is started.

Check Here for Configuration B – is chosen when you want to create a stack with the number of sweeps specified in Configuration B. The number of sweeps in Configuration B is specified in the “Vertical Stacking” modules’s parameters dialog box. This is a real-time parameter and it should be chosen before the start of the stacking process. Once a stack is started, the parameters for Configuration B will be used to complete the stack. In other words, the number of sweeps in a stack must be specified before the stack is started.

Since the control panel for vertical stacking is not displayed until you execute the flow, you must set the initial values for the real time parameters. This is accomplished by clicking on the 'Parms' option on SeisNet's Main Menu Bar and selecting 'Initial Parameters for Vertical Stacking' from the drop-down menu. The dialog box that is displayed is shown below:

You set the initial parameters using the same procedures described above for the control panel. It is important to note that the “Initial Parameters for Vertical Stacking” only has meaning when SeisNet is controlling the vibrators. For example, issuing the vibrator start command using the RS232 port on the SeisNet computer. This set of parameters is legacy code needed to support vertical stacking using the DC20 card. When using the DCT card, this set of parameters is not used. However, you can set the number of sweeps in a VP to override the default setting of four (4).

The initial parameters that are set under “Parms” on the main menu bar are:

Check here to automatically acquire the next sweep in a VP – This parameter should always be set (checked) when operating with the DCT card. The best thing to do is to accept the default setting of “checked”.

Number of sweeps in a VP – determines the number of sweeps that are in a VP. This parameter can also be set in the “Vertical Stacking Parameters” dialog box, before you execute a flow with a Vertical Stacking module. This parameter is only used when data is acquired using the older DC20 card. When using the DCT acquisition card, the initial parameters as obtained form the “Vertical Stacking Parameters” dialog box.

Time between sweeps (in seconds) – only has meaning when using a DC20 data capture card. This parameter is NOT needed when data comes either from disk or DCT capture card.

The 'Vertical Stacking' module employs a second set of parameters. Clicking on the 'P' in the icon representing the module displays the dialog box shown below:

The second set of parameters are defined as follows:

Noise Reduction Method -- is a group of four radio buttons that lets you choose the type of noise editing to perform. You are permitted only a single choice. If you select, for example, 'Zero the noisy parts of a trace' all other choices are automatically deselected. The following options are available.

Zero the noisy parts of a trace -- is chosen when you want the noisy parts of a trace to be zeroed. An amplitude value for a trace is determined by calculating the median value of the peak value in 100 sample time windows. Next the trace is scanned to see if any values in the trace exceed the sum of the amplitude value and the threshold. When a large value is found, the sample and 15 samples on either side are zeroed. A 10 sample cosine taper is applied to reduce the Gibb's effect.

Clip the noisy parts of a trace -- clips all the samples whose amplitude exceeds the trace amplitude plus the threshold. The trace amplitude is determined as explained above.

Remove trace from stack -- will not include the trace in the vertical stack if any of the sample values are greater than the trace amplitude plus the threshold. The trace amplitude is determined as explained above.

Disable noise Editing -- prevents SeisNet from performing any type of noise editing.

Noise Threshold (in dB) -- sets the threshold used for the noise editing. A sample is considered to be noisy when its amplitude exceeds the trace amplitude plus the threshold. The trace amplitude is determined as explained above.

Enter the beginning FFID -- sets the value of the FFID for the first stacked record. SeisNet increments the FFID by one every time a stacked record is processed. Remember that SeisNet determines the FFID of the stacked record and not the recording system.

Enter the window length in seconds (e.g. 0.512) – is used in the diversity stacking procedure to set the length of the time gate in seconds. In diversity stacking each trace is divided into time windows (or time gates). This parameter sets the length of each time gate in seconds.

Check here to generate a log of the acquired data --is a check box that when checked tells SeisNet to generate a log of the processed data. The log information is written to the file <VStackLog.Log> in the same directory where the SeisNet executable is located..

Check here to base scaling on RMS power – determines the type of scaling. When this parameter is selected (checked) scaling will be based on the RMS power of each window in a trace. When it is deselected (unchecked) scaling will be based on the average power of each window in a trace.

Noise edit zeroing length (in seconds) – is a parameter used only when you are performing noise editing and zeroing the noisy parts of the trace. The procedure for noise editing when using the “Zero the noisy parts of a trace” option is to look backward in time to the last zero crossing. The data are then zeroed from the zero-crossing time to the zero-crossing time plus the value of this parameter. If another noise burst is detected during this time interval, the zero-crossing time is reset.

Number of Sweeps in a VP for Configuration A: – specifies the number of sweeps in a stack for Configuration A.

Number of Sweeps in a VP for Configuration B: – specifies the number of sweeps in a stack for Configuration B.

Check here to start stacking with Configuration B. – forces the number of sweeps in a VP, for the first stack executed, to be what is specified in the “Number of Sweeps in a VP for Configuration B:” parameter above. Note that this parameter is only used when the flow is first executed. If this parameter is unchecked, then number of sweeps in a VP will be what is specified in “Number of Sweeps in a VP for Configuration A”.

Check here to perform Diversity Stacking – determines whether a normal vertical stack or a diversity stack is produced. When this parameter is checked, a diversity stack is calculated; otherwise, a normal vertical stack is generated.

Click Here to View Description of Module


Tape Copy

SeisNet Module: Spectrum Attributes

The Spectrum Attributes module calculates spectrum attributes for each trace and identifies any traces that exceed user specified percentage deviations.

To learn more about this module select one of the following:

Description

Parameters


Description of Tape Copy Module

SeisNet Module: Spectrum Attributes

Description

This module provides the ability to identify traces in which spectrum attributes deviate beyond a specified percentage in terms of Low Cut frequency, Highcut frequency, Bandwidth and Peak Amplitude frequency. Results are placed in an Access database file. An option is also provided to flag bad traces on the Display Seismic Traces module to be highlighted in red.

Click Here for Explanation of the Parameters


Parameters for Tape Copy Module

SeisNet Module: Spectrum Attributes

Parameters

The parameters dialog box for the Trace Highlight module is displayed when you click on the "P" of the icon representing the module.

Parameter names are shown in the color Green.

Percentage deviation for low cut frequency – Specify maximum percentage deviation for low cut frequency.

Percentage deviation for high cut frequency – Specify maximum percentage deviation for high cut frequency.

Percentage deviation for bandwidth – Specify maximum percentage deviation for bandwidth.

Percentage deviation for peak frequency – Specify maximum percentage deviation for peak amplitude frequency.

Bad Trace Flag – Check box to set flag in trace headers of traces exceeding the specified percentage deviations. This flag will cause the traces to be presented in red by the Display Seismic Traces module.

Name Access Database File – Specify the file name and location for the access database file created by this module.

Click Here to View Description of Module.


Processing Utilities Detect Bad Traces command

SeisNet Module: Power Spectrum of Single Trace

The 'Power Spectrum of Single Trace' module calculates and displays the amplitude spectrum of a trace that you specify in the data object.

You may learn more about this module by selecting one of the following:

Description

Parameters


Description of the Vertical Stacking Module

SeisNet Module: Power Spectrum of Single Trace

Description:

The ‘Power Spectrum of Single Trace’ module calculates and displays the amplitude spectrum (square root of the power spectrum) of a trace that you specify in the data object. The trace is specified using the trace sequential number. You can use the ‘Display Trace Data’ module to locate the trace you want to analyze. You have the option of specifying a time window within the trace that is tapered on both ends to minimize the Gibb’s phenomenon. For example, if you chose a time window of one to three seconds and a taper length of 0.25 seconds. The trace would be zeroed from zero to one second and from three seconds to the end of the trace. In addition, a cosine taper would be applied to the data at the beginning of the time window (1.0 to 1.25 second) and at the end of the time window (2.75 to 3.0 seconds).

This display created by this module is a real-time display that does not provide you with the capability to interact with the data. If the data area displayed with improper parameters you will have to kill the flow, reset the parameters and execute the flow again. However, you do have the capability to resize and move the display window at will.

There are two options for scaling. The default option is where the spectrum is searched for the largest value, which in turn is used to represent 0dB. The second option is where you enter a value to represent 0dB. The second option is useful when you want to monitor such things a wind noise from shot to shot, or you want to compare the spectra of a near trace with that of a far trace.

Click Here for an Explanation of the Parameters


Parameters for the Vertical Stacking Module

SeisNet Module: Power Spectrum of Single Trace

Parameters:

The parameters dialog box for the ‘Power Spectrum of Single Trace’ module is displayed when you click on the “P” in the icon representing the module.

Parameter names are shown in the color Green.

Sequential trace number of the trace to be analyzed – is used to specify the trace in the data object that will be analyzed. You can identify the particular trace by examining the data in the data object using the ‘Display Trace Data’ module. The trace sequential number is shown on the trace data display immediately above the seismic traces.

Minimum dB value to display – sets the smallest dB value that will be displayed. Remember that the data is formatted to display the amplitude of the spectrum as so many dB down from a reference value. So, for example, a minimum value could be –72dB and a maximum value could be 0dB. If the data are automatically scaled then the reference value, that represents 0dB, is the largest value in the spectrum.

Maximum dB value to display – sets the largest dB value that will be displayed. Remember that the data is formatted to display the amplitude of the spectrum as so many dB down from a reference value. So, for example, a minimum value could be –72dB and a maximum value could be 0dB. If the data are automatically scaled then the reference value, that represents 0dB, is the largest value in the spectrum.

Minimum frequency (in Hz) to display – is used to specify the smallest frequency component displayed.

Maximum frequency (in Hz) to display – is used to specify the largest frequency component displayed.

Minimum value (in seconds) of time window – specifies the beginning of the time window.

Maximum value (in seconds) of time window – specified the end of the time window.

Length (in seconds) of end taper for time window – is a parameter that you can use to minimize the Gibb’s phenomenon (ringing in the data) by tapering into and out of the time window. A cosine taper is used for this operation. The length of the taper is specified here. The default value of 0.25 seconds normally does an adequate job.

Check here to Automatically Scale the data for display -- is a check box that when checked tells SeisNet to automatically scale the data for displaying. When this parameter is enabled (checked state) the amplitude spectrum is searched for the its largest value. The data is scaled so that this largest value represents 0dB. When this parameter is unchecked you will be asked to enter a value that will represent 0dB. For most recording systems, the default value of 100 will normally display something on the screen. You may have to iterate changing the reference value and displaying the data to come up with an acceptable value.

Reference value to represent 0dB – is a parameter that you are asked to enter when the ‘Check here to Automatically Scale the data for display’ parameter is unchecked. This value is used to represent 0dB.

Click Here to View Description of Module


Tape Copy

SeisNet Module: Marine QC

This module calculate RMS attributes related to the seismic traces associated with each marine streamer for each line and stores these values, along with configuration data , into an Access database file representing the attributes for a complete line.

To learn more about this module select one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: Marine QC

Description

The Marine QC module calculates RMS attributes related to the seismic traces associated with each marine streamer for each line and stores these values, along with configuration data, into an Access database file representing the attributes for a complete prospect.

To calculate the attributes, two time windows must be specified, a signal window and a noise window. The signal window can be automatically set by the system based on a waterbottom pick algorithm or may be set manually if the auto pick option is not selected. The noise window can be automatically set by the system to the last 100 mS of the trace or may be set manually if the auto pick option is not selected. Within each time window the RMS signal values are calculated and are stored in an Access database file. The user must specify the database file name and path. A single database file will contain attribute data for a complete line. Line databases can be merged to produce a complete prospect database by utilizing the QC_DB_MERGE.exe application provided with SeisNet.

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: Marine QC

Parameters

The parameters dialog box for the Marine QC module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Auto Pick Signal Window -- This option allows the system to automatically specify the signal window based on a waterbottom pick algorithm.

Starting Time of Signal Window (in Seconds) -- This parameter only appears if the Auto Pick Signal Window option is not selected. It allows the user to specify the beginning of the signal window. Enter a time in seconds just prior to the apparent waterbottom first breaks on the near traces as seen on a shot record display.

Ending Time of Signal Window (in Seconds) -- This parameter only appears if the Auto Pick Signal Window option is not selected. It allows the user to specify the ending of the signal window. Enter a time in seconds just after to the apparent waterbottom first breaks on the far traces, as seen on a shot record display.

Auto Pick Noise Window -- This option allows the system to automatically set the noise window to the last 100 mS of the trace.

Starting time of Noise Window (in Seconds) -- This parameter only appears if the Auto Pick Noise Window option is not selected. Enter the starting time for the noise window.

Ending Time of Noise Window (in Seconds) -- This parameter only appears if the Auto Pick Signal Window option is not selected. Enter the ending time for the noise window.

Path to where data stored -- Enter the destination path for the Access database file to be created. The database file name is automatically created from the line name read from the data header.

Project Name – Enter a project name to create a subdirectory to contain the database file.

Shot Offset (Meters) -- Enter the distance from the source to the near trace streamer sensor.

Group Interval (Meters) -- Enter the distance between streamer sensors.

Water Velocity (Meters/Second) -- Enter the water velocity (default 1500 m/sec).

Upper Value to Subtract from Water Bottom Time (Seconds) -- Enter signal window upper offset (default 0.05 seconds).

Lower Value to Add to Water Bottom Time (Seconds) -- Enter signal window lower offset (default 0.1 seconds).

Water Delay (Seconds) – Enter recorder start delay time for deep water applications.

Multiple Source Vessel Operation – Check to support multiple source operations. When this parameter is checked the Vessel ID is obtained from the Navigation Section in the record header and stored in the Marine QC database. The Vessel ID is placed in the Sequence column in the “Source” and “System QC – Trace RMS” tables.

Click Here to View Description of Module


Processing Utilities Detect Bad Traces command

SeisNet Module: Save First Break Picks

The Save First Break Picks module is used to save first break times that have been stored in the SeisNet data object.

You may learn more about this module by selecting one of the following:

Description

Parameters


Processing Utilities Detect Bad Traces Description

SeisNet Module: Save First Break Picks

Description

The Save First Break Picks module is used to save first break pick times that have been stored in the SeisNet data object to hard disk. This module is normally inserted into the flow just after a Display Trace Data module. To see first break time picks you should select the Check here to display time picks from SeisNet's geometry module option in the Display Trace Data parameters dialog box. The first break pick times are normally calculated automatically in the Pick First Breaks module. A Display Trace Data module follows the Pick First Breaks module so that the first break picks can be edited by a human. The Save First Break Picks module follows the Display Trace Data module to save the edited picks to hard disk.

The first break pick data along with source line number, shot point number, receiver line number, ground station number and calculated source to receiver offsets are written to a disk file as specified by the user in the parameters dialog box. This file is an ASCII format file.

Click Here for an Explanation of the Parameters


Processing Utilities Detect Bad Traces Parms

SeisNet Module: Save First Break Picks

Parameters

The parameters dialog box for the Save First Break Picks module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Enter name of the File to Store the First Break Picks stored in the SeisNet Data Object – Specifies the name and location of the First Break Pick file to contain the first break picks and associated geometry data.

Click Here to View Description of Module


Processing Utilities Detect Bad Traces command

SeisNet Module: Vib Pro Index File

The Vib Pro Index File module creates an index file that cross-references Vib Pro data with the corresponding shot record.

You may learn more about this module by selecting one of the following:

Description

Parameters


Processing Utilities Detect Bad Traces Description

SeisNet Module: Vib Pro Index File

Description

The Vib Pro Index File module generates a cross-reference file between the Vib Pro data and the corresponding shot record. Vib Pro data is collected in each vibrator during shooting and must be transcribed at day’s end. To properly correlate the data, the Vib Pro data must be matched to the seismic data. The cross-reference file generated by the “Vib Pro Index File” module performs that task.

You insert the “Vib Pro Index File” module into the SeisNet flow just like any other SeisNet module. The module automatically creates and index file for the day’s shooting and stores it in a sub directory, called VibPro, beneath SeisNet root directory. For example, if the SeisNet root directory is “C:\SeisNet\”, the cross-reference will be stored in the directory “C:\SeisNet\VibPro”. Furthermore, the cross-reference filename has a special format. The first two letters are “BK”, followed by a time stamp, followed by a “.TXT” extension. For example, if the data were acquired on Oct 12, 2005, the cross-reference filename would be “BK101205.TXT”. A new file is created for each day’s shooting.

In order to generate the cross-reference file using the “Vib Pro Index File” module, the Vib Pro “Encoder PSS Message #0” must be stored in the SEG-D external header by the recording system. The “Vib Pro Index File” module examines the “Encoder PSS Message #0” packet and extracts the Sweep ID and Sweep Number. These two values it stores, along with the FFID from the recording system, in an ASCII file. The ASCII file is formatted as a Pelton Co. Advance 3 Encoder PSS Index Log file.

Click Here for an Explanation of the Parameters


Processing Utilities Detect Bad Traces Parms

SeisNet Module: Vib Pro Index File

Parameters

The Vib Pro Index File module does not have parameters.

Click Here to View Description of Module


Tape Copy

SeisNet Module: Marine Source Logging

This module calculates the near field bubble period and creates a marine source status log file.

To learn more about this module select one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: Marine Source Logging

Description

The “Marine Source Logging” module gathers information from the navigation and GCS90 sections in the record header and stores it in a user specified log file. In addition, the near field bubble period is calculated and also stored in the log file.

This module is intended for use during source testing and requires that only one gun be fired at a time.

The following values are recorded in the log file.

1. FFID - Field File Identification Number

2. TRCNUM - Trace Sequential Number

3. AUXTRC - Aux Trace Number

4. GUNID - Gun Identifier

5. GUNPRES - Gun Manifold Pressure

6. GUNTIME - Gun Timing - Delta Error (expressed in milliseconds)

7. GUNDEPTH - Gun Depth - Average per sub-array (expressed in meters)

8. BUBBLE – Calculated Bubble Period (expressed in milliseconds).

As shown in the figure below, the bubble period is the time from when the airgun is fired to the time of the bubble collapse. The bubble period is measured by calculating the time of the first peak generated when the gun is fired to the time of the first peak when the bubble collapses.

The log file that is created by this module is comma delineated, to facilitate import into Microsoft’s Excel or Access.

Gun ID mapping to corresponding auxiliary traces must be specified by the user.

Because not all of the airguns have depth sensors, the gun depth is determined by averaging only the valid depth sensor readings in a specific sub-array.

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: Marine Source Logging

Parameters

The parameters dialog box for the Marine Source Logging module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

Fully Qualified Name of the Logging File – is the parameter determines where the logging file will be created and how it will be named. Note that the file created will be a comma delineated “.txt” file.

Enter Mapping from Gun ID’s to Aux Trace Numbers – sets the mapping from Gun ID’s to auxiliary trace numbers. The edit box where you type-in the mappings requires a particular format. That format is:

Gun ID – Gun ID = Aux Trace Number, or

Gun ID = Aux Trace Number.

For example, if you type the following:

1 – 5 = 1, 6 – 9 = 2, 33 – 37 = 7, 38 – 41 = 8, 44 = 9, 45 = 10

the mapping would be

Guns 1, 2, 3, 4 and 5 would map to aux trace 1, Guns 6, 7, 8, 9 would map to aux trace 2, Guns 33, 34, 35, 36, 37 would map to aux trace 7, Gun 44 would map to aux trace 9, and Gun 45 would map to aux trace 10.

Click Here to View Description of Module


Tape Copy

SeisNet Module: Select Traces Based on Sensor Type

No Help Available at this time.

To learn more about this module select one of the following:

Description

Parameters


Processing Atrributes Calculate Description

SeisNet Module: Select Traces Based on Sensor Type

Description

No Help Available at this Time.

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: Select Traces Based on Sensor Type

Parameters

No Help at this Time.

Parameter names are shown in the color Green.

Auto Pick Signal Window -- This option

Click Here to View Description of Module


Processing Atrributes Calculate Description

SeisNet Module: SPS QC

Description

The SPS QC module is used to compare the information contained in the SPS dataset with the information contained in the actual seismic record. Source position, receiver position and relation information is taken from the SPS dataset to make this comparison.

Source point coordinates are retrieved from the SPS dataset using the source point line name and the source point number from the seismic record headers. Receiver point coordinates are retrieved from the SPS dataset using the receiver line names and receiver station numbers from the seismic record headers. A theoretical first break time is calculated for each data trace in the seismic record. The theoretical first break time is the distance between source and receiver divided by the velocity. The velocity used is a user entered parameter. If a display module is connected to the output of the SPS QC module the theoretical first break times will be display in green.

The relation file of the SPS dataset is used to calculate a second set of theoretical first break times. The relation record for the shot point is decoded and a model of the shot point is built. The relation record describes what receiver line names and receiver station numbers should be included in the shot point. Theoretical first break times are calculated for each receiver in the model. If a display module is connected to the output of the SPS QC module the second set of theoretical first break times will be displayed in red.

The SPS QC module will detect and log (if logging is enabled) any of the following problems:

1. Shot point coordinates not found in the SPS dataset. If the shot point coordinates cannot be found, the first break times are not calculated and an error is generated.

2. Receiver coordinates not found in the SPS dataset. First break times are not calculated for these receivers and errors are generated.

3. The content of the seismic record and the content of the shot point model are compared and errors if any are generated.

The SPS QC module will also allow you to generate an output relation file based on the actual seismic record.

Documentation for the SPS Standard Rev. 0 format can be obtained from the SEG at:

http:/www.seg.org/publications/tech-stand/seg_sps_rev0.pdf

Click Here for an Explanation of the Parameters


Processing Attributes Calculate

SeisNet Module: SPS QC

Parameters

The parameters dialog box for the SPS QC module is displayed when you click on the "P" in the icon representing the module.

Parameter names are shown in the color Green.

SPS File Type – specifies the file format of the SPS dataset. The SPS QC module currently supports two file formats (Standard SPS Rev 0 and Combo SPS Type 0).

Enter the name of the SPS SOURCE File (i.e. “.S” or “.SPS” file extension) – specifies the name of the source file in the SPS dataset.

Enter the name of the SPS RECEIVER File (i.e. “.R” or “.RPS” file extension – specifies the name of the receiver file in the SPS dataset.

Enter the name of the SPS RELATION File (i.e. “.X” or “.XPS” file extension – specifies the name of the relation file in the SPS dataset.

Enter the velocity (feet/sec or meters/sec) used to calculate first breaks – is used to determine the first break times generated by the SPS QC module. The first break times are the offset (distance between source and receiver) divided by this velocity.

Enter the name of the SPS QC LOG File – specifies the name of the log file generated by the SPS QC module. Entering “Not Defined” will disable SPS QC logging.

Enter the name of the SPS QC created RELATION File – specifies the name of the relation file generated by the SPS QC module. Entering “Not Defined” will disable the SPS QC relation file creation process.

Click Here to View Description of Module


Processing Split Flow command

SeisNet Module: Split Flow

The Split Flow module is used to split the processing from one to two branches.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Split Flow Description

SeisNet Module: Split Flow

Description

This module allows the user to split a flow in order to perform parallel tasks. It is important to note that this module relies on the Windows NT page file system to store data object clones on hard disk until they are processed in the event that parallel tasks have significantly different execute times.

Click Here for an Explanation of the Parameters


Processing Split Flow Parms

SeisNet Module: Split Flow

Parameters

The Split Flow Module does not have parameters.

Click Here to View Description of Module


Processing End Module command

SeisNet Module: End Module

The End Module is used to terminate a branch in a SeisNet flow. For normal operations the use of this module is optional, since it is used mainly for debugging purposes.

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing End Module Description

SeisNet Module: End Module

Description

This module allows the user to terminate a flow that does not have a valid termination module in the case of a test flow design. It would not be required in a normal operation flow design.

Click Here for an Explanation of the Parameters


Processing End Module Parms

SeisNet Module: End Module

Parameters

The parameters dialog box for the End Module is displayed when you click on the "P" in the icon representing the module.

The end module does not have parameters. It is used to provide correct thread termination when a data object would otherwise not be destroyed. For example, if you simply have an input module as the only thing in a flow, it will not run. However, a flow consisting of an input module followed by an END module will run. Since this module is mainly for debugging purposes, you normally don't have to worry about placing it at the end of the branches of your processing flow.

Click Here to View Description of Module.


Tape Menu Commands

The following commands are available under the 'Tape' selection on SeisNet's Main Menu Bar:

Select Active Tape Drive | Selects tape drive to be active.
Rewind Active Drive | Rewinds active drive to beginning of tape.
Unload Active Drive | Rewinds and unloads active tape drive.
Skip Forward by Filemarks | Skips forward specified number of filemarks.
Skip Backward by Filemarks | Skips backward specified number of filemarks.
Skip to End of Data on Tape | Positions the head between filemarks at end of data on tape.
Display Status | Displays the status of selected tape drive.


Tape Select Active Tape Drive command

Select Active Tape Drive command Under SeisNet's Tape Menu

This command is used to set the active tape drive. To select the active tape drive, simply click on the 'Tape' option on SeisNet's Main Menu Bar. Then, select the 'Select Active Tape Drive' command from the drop-down menu.

After selecting the 'Select Active Tape Drive' command, the following dialog box appears. Here you select the drive you want to be active by placing a check mark next to the desired drive. Right clicking the mouse on the desired check box accomplishes placing a check mark. Only one drive can be the active at a time.

The following message box is displayed if you try to select a tape drive to be active and no drives are installed on your system. When this message box is observed and there are tape drives connected to your system, you probably have the wrong device driver for the type of drives you are using. You can contact the factory or consult with your system administrator to obtain the correct device driver for your particular type of tape drive.

It should be noted that you cannot select the active tape drive when a flow is running. If you want to change the drive that is active, you will first have to kill the flow that is executing, select the active drive and restart the flow.

Most SeisNet modules that read or write data to or from tape have the capability to over-ride the active drive. That is, you select the drive used for reading or writing data from within the chosen module. If a "Hot Swapping" option is enabled, then SeisNet will make the decision as to which drive is used for the reading and writing of data.


Tape Rewind Active Drive command

Rewind Active Drive command Under SeisNet's Tape Menu

This command rewinds the active tape drive to beginning of tape. To rewind the tape in the active drive to the beginning of tape, simply click on the 'Tape' option on SeisNet's Main Menu Bar. Then, select the 'Rewind Active Drive' command from the drop-down menu. As the tape is being rewound a message is displayed in the status bar telling you that the SeisNet program pauses until the rewind operation completes.

If no tape drives have been installed on your system the following message box is displayed when you execute the rewind command.


Tape Unload Active Drive command

Unload Active Drive command Under SeisNet's Tape Menu

This command is used to rewind and unload the active tape drive. To unload the active tape drive, simply click on the 'Tape' option on SeisNet's Main Menu Bar. Then, select the 'Unload Active Drive' command from the drop-down menu. As the drive is being unloaded, a message is displayed on the status bar informing you that the SeisNet program pauses until the unload operation is completed.

The following message box is displayed when you execute the 'Unload Active Drive' command and there are no tape drives connected to your system.


Tape Skip Forward by Filemarks command

Skip Forward by Filemarks command Under SeisNet's Tape Menu

This command is used to advance the tape by a specified number of filemarks. The tape will not be advanced beyond the logical end of tape. To advance the tape, based on filemarks, simply click on the 'Tape' option on SeisNet's Main Menu Bar. Then select the 'Skip Forward by Filemarks' command from the drop-down menu, as shown below.

After selecting the 'Skip Forward by Filemarks' command, the following dialog box appears. Here you enter the number of filemarks that you want to advance the tape. If you enter a number that would advance the tape beyond the logical end of tape, the tape head will be positioned at the logical end of tape.

The following message box is displayed when you try to execute a 'Tape' command and no drives are connected to your system. If this message box is observed and there are tape drives connected to your system, you probably have the wrong device driver for the type of drives you are using. You can contact the factory or consult with your system administrator to obtain the correct device driver for your particular type of tape drive.

You cannot perform a 'Tape' command when a flow is running. If you want to change the head position, you will have to kill the flow that is executing, reposition the head, and then restart the flow.


Tape Skip Backward by Filemarks command

Skip Backward by Filemarks command Under SeisNet's Tape Menu

This command is used to rewind the tape by a specified number of filemarks. The tape cannot be rewound past the beginning of tape. If you enter a number that is too large, the head will be positioned at the beginning of tape. To rewind the tape, based on filemarks, simply click on the 'Tape' option on SeisNet's Main Menu Bar. Then, select the 'Skip Backward by Filemarks' command from the drop-down menu, as show below.

After selecting the 'Skip Backward by Filemarks' command, the following dialog box is displayed. Here you enter the number of filemarks that you want to rewind the tape by. If you enter a number that would position the head beyond the beginning of tape, the head will be positioned at the beginning of tape.

The following message box is displayed when you try to execute a 'Tape' command and no drives are installed on your system. If this message box is observed and there are drives connected to your computer, you probably have the wrong device driver for the type of tape drives you are using. You can contact the factory or consult with your system administrator to obtain the correct device driver.

You cannot issue a 'Tape' command when a flow is running. If you want to change the head position, you will have to kill the flow that is running, reposition the head, and then restart the flow.


Tape Skip to End of Data on Tape command

Skip to End of Data on Tape command Under SeisNet's Tape Menu

This command is used to position the tape head at the end data on tape. To advance the tape to the logical end of tape, simply click on the 'Tape' option on SeisNet's Main Menu Bar. Then, select the 'Skip to End of Data on Tape' command from the drop-down menu, as shown below.

If no tape drives are connected to your computer, the following message box will be displayed when you try to execute a 'Tape' command.


Tape Display Status command

Display Status command Under SeisNet's Tape Menu

This command displays the status of the currently active tape drive. To display the status of the currently active drive, simply click on the 'Tape' option on SeisNet's Main Menu Bar. Then, select the 'Display Status' command from the drop-down menu, as shown below.

After selecting the 'Display Status' command, a report is displayed supplying information about the currently selected tape drive. An example of such a report is shown below.

If you try to execute the 'Display Status' command and no tape drives are connected to your computer, the following message box is displayed.


Parms Menu Commands

The following commands are available under the 'Parms' selection on SeisNet's Main Menu Bar:

Warning Level | Sets the error warning level.
Message Level | Sets the level of information displayed in the Log file.
Input Data Path | Sets the data path for reading data from hard disk.
Output Data Path | Sets the output data path for data written to hard disk.
Max Samples Per Trace | Sets the maximum number of samples in a trace.
Enable Debugging | Debugging is enabled when checked.
No. Shots to Store on Stack | Sets the number of shot records to store on a secondary thread's stack.
Initial Parameters for Vertical Stacking | Sets the initial real time parameters for vertical stacking.


Parms Warning Level command

Warning Level command Under SeisNet's Parms Menu

Use this command to set the level at which you are notified about warnings and errors. To set the warning level, simply click on the 'Pams' option on SeisNet's Main Menu Bar. Then, select 'Warning Level' from the drop-down menu, as show below.

After selecting the 'Warning Level' command, the following dialog box is displayed. You must choose a type from those that are displayed in the list box.

It is suggested that "Critical Errors Only" be used for production work. You may also select Disable All, Errors Only, or Warnings and Errors.


Parms Message Level command

Message Level command Under SeisNet's Parms Menu

Use this command to set the level at which messages get written to the log file. To set the message level, simply click on the 'Parms' option on SeisNet's Main Menu Bar. Then, select 'Message Level' from the drop-down menu, as show below.

After selecting the 'Message Level' command, the following dialog box is displayed. You must choose a type from those that are displayed in the list box.

For production work, it is recommended that you choose the option, "All But Parameters". You may also choose "Debugging Messages", "Everything", or "Warnings and Errors".


Parms Input Data Path command

Input Data Path command Under SeisNet's Parms Menu

Use this command to specify the default data path for reading data from hard disk. To set the default input data path, simply click on the 'Parms' option on SeisNet's Main Menu Bar. Then, select 'Input Data Path' from the drop-down menu, as shown below.

After selecting the 'Input Data Path' command, the following dialog box is displayed. You can either type-in the pathname or click on the Browse button to display a directory dialog box. You can use the directory dialog box to point to an existing drive and directory and add a subdirectory by appending to the pathname after you close the directory dialog box. If the specified directory does not exist, it will be created.

If you click on the Browse button a directory dialog box is displayed that will let you choose an existing directory using point-and-click operations. An example of that dialog box is shown below.


Parms Output Data Path command

Output Data Path command Under SeisNet's Parms Menu

Use this command to specify the default data path for writing data to hard disk. To set the default output data path, simply click on the 'Parms' option on SeisNet's Main Menu Bar. Then, select 'Output Data Path' from the drop-down menu, as shown below.

After selecting the 'Output Data Path' command, the following dialog box is displayed. You can either type-in the pathname or click on the Browse button to display a directory dialog box. You can use the directory dialog box to point to an existing drive and directory and add a subdirectory by appending to the pathname after you close the directory dialog box. If the specified directory does not exist, it will be created.

If you click on the Browse button a directory dialog box is displayed that will let you choose an existing directory using point-and-click operations. An example of that dialog box is shown below.


Parms Max Samples Per Trace command

Max Samples Per Trace command Under SeisNet's Parms Menu

It is sometimes necessary for SeisNet to read a trace before the length of the trace is known. It that case, memory must be temporarily allocated to hold the trace header and data. The number you enter here specifies the amount of memory that will be allocated to hold that trace. Memory that is allocated to hold a trace of unknown length is immediately released when it is no longer needed.

After selecting the 'Max Samples Per Trace' command, the following dialog box is displayed. You type in the number of samples that would correspond to the maximum trace length. The default value of 16,384 samples is generally large enough to handle most situations. In the example below, we show a value 66000 having been entered.

Remember that you enter the number of samples in a trace and not the number of bytes.


Parms Enable Debugging command

Enable Debugging command Under SeisNet's Parms Menu

Use this command to enable the writing of a captured shot record to hard disk when an acquisition error occurs. The feature is useful for determining the source of the error by performing a hex dump on the captured record. To enable debugging, simply click on the 'Parms' option on SeisNet's Main Menu Bar. Then, select 'Enable Debugging' from the drop-down menu, as shown below.

When an acquisition error occurs and you have 'Enable Debugging' set, a file is created in the directory where the SeisNet executable is stored. The name of the file holding the bad record is <Shotxxxx.DBG>, where 'xxxx' is a place holder for the current date and time. The place holder data and time is represented as the number of seconds from Jan 1, 1970. You must delete these files from your hard disk when you no longer needed them.

A check mark appears to the left of the 'Enable Debugging' command when it is set, or enabled. To disable debugging, simply click on the 'Enable Debugging' command again and the check mark will disappear. The 'Enable Debugging' command is always disabled when you start the SeisNet program. You must enable debugging after SeisNet starts, in order to capture any bad shot records.


Parms Max Samples Per Trace command

No. Shots to Store on Stack command Under SeisNet's Parms Menu

Whenever a 'Split Flow' module is inserted into a SeisNet flow, a secondary thread is created. Because a thread can execute independently from other threads, it is necessary to temporarily store captured shot records on a stack to insure thread synchronization. This comes into play when you have a plotting module in a secondary thread and data is being captured at a rate where the plotter cannot keep up. If there were no limit on the number of shot records that are buffered, the computer would eventually run out of virtual disk space and the SeisNet program would hang. To prevent this from happening, we place a limit on the number of shot records that will stored for future processing. If the number of shot records stored exceeds the number specified here, the executing thread will discard the record. Other threads will not be affected by this discarding operation. The net result is that not all shots will be plotted when the computer's resources have been depleted.

When you click on the 'No. of Shots to Store on Stack' option the following dialog box is displayed. You simply type in the number of shot records you want to store on a secondary thread's stack. You are permitted to enter numbers between 1 and 256. Normally, the default value of 4 is adequate for almost all SeisNet operations.

Remember that SeisNet determines which modules are put in primary and secondary threads by the order in which they are placed on the desktop and on the order in which they are wired together. For example assume that you have set up the following flow:

To have the 'Data Input From DC20 Card' and 'Display Seismic Traces' modules in the primary thread and the 'Plot Seismic Traces' module in a secondary thread you would do the following:

  1. Drop the 'Data Input From DC20 Card' module onto the desktop.
  2. Drop the 'Split Flow' module onto the desktop.
  3. Drop the 'Display Seismic Traces' module onto the desktop.
  4. Wire the 'Data Input From DC20 Card' to the 'Split Flow' module.
  5. Wire the 'Split Flow' module (left connection point) to the 'Display Seismic Traces' module.
  6. Drop the 'Plot Seismic Traces' onto the desktop.
  7. Wire the 'Split Flow' module (right connection point) to the 'Plot Seismic Traces' module.


Initial Parameters for Vertical Stacking

Initial Parameters for Vertical Stacking command Under SeisNet's Parms Menu

When a 'Vertical Stacking' module is placed in your SeisNet processing flow, it is necessary to tell the SeisNet executive about the initial values of the real time vertical stacking parameters. By real time parameters we mean those parameters that can be changed as the data are being acquired. For example, if you wanted to increase the number of sweeps in a VP you would simply enter a new value for the 'Number of sweep in a VP' parameter in the vertical stacking control panel, which is discussed below. The vertical stacking control panel is displayed in the lower right-hand corner of the screen whenever you execute a processing flow that has included a 'Vertical Stacking' module.

To set the initial values of the real time parameters for vertical stacking, simply click on the 'Parms' option on SeisNet's Main Menu Bar. Then, select 'Initial Parameters for Vertical Stacking' as shown below:

When you select the 'Initial Parameters for Vertical Stacking' command, the following dialog box appears:

If you want SeisNet to automatically acquire the next sweep in a VP, a check should appear in the check box next to the text "Check here to automatically acquire the next sweep in a VP". To set the initial value for the number of sweeps in a VP, type-in the desired value in the edit box just to the right of the text "Number of sweeps in a VP. The time between sweeps is controlled by the value you enter in the edit box just to the right of the text "Time between sweeps (in seconds)".

In the example above, there will be eight sweeps in a VP and the time between sweeps is set to 20 seconds. Furthermore, SeisNet will automatically acquire all eight sweeps once you have given the command to acquire data from the control panel shown below: Clicking on the 'Start Acquisition' button begins the acquisition process.

The vertical stacking control panel is used to control the vertical stacking process. If a check mark appears in the check box next to the text "Check here to automatically the next sweep in a VP", then all the sweeps in a VP will automatically be acquired by SeisNet. The acquisition process is started when you click on the 'Start Acquisition' button. If the parameter 'Check here to automatically acquire the next sweep in a VP' is NOT checked, then you will have to manually tell SeisNet to acquire the next sweep by clicking on the 'Start Acquisition' button. SeisNet will not automatically begin data acquisition for the next VP. Clicking on the 'Start Acquisition' button starts a VP.

If you want to pause operations momentarily, simply click on the 'Pause Operations' button. When you click on the 'Pause Operations' button, the text displayed on the button will change to 'Resume Operations'. To resume operations you will have to click on the 'Resume Operations' button. In other words, the 'Pause Operations button' is a toggle switch. Click on it once to pause operations, click on it again to resume operations.

It is possible to restart the entire VP by clicking on the 'Reset Sweep Counter' button. When you click on the 'Reset Sweep Counter' button you will be asked if you really want to throw away the data you have already acquired for the VP and begin anew. If you answer 'Yes' a new VP will be started and any previous data acquired for that VP is discarded.

You can change the number of sweeps in a VP by entering a new value in the edit box just to the right of the text "Number of sweeps in a VP". Likewise, you can change the time between sweeps by entering a different value in the edit box just to the right of the text "Time between sweep (in seconds)".

The control panel for vertical stacking also has a status window that keeps you informed about the status of the stack. Such things as the number sweeps that have been acquired and operations errors are reported in the status window. The time remaining before the next sweep is acquired is shown on the SeisNet status bar found in the lower left corner of the screen.


View Menu Commands

The following commands are available under the 'View' selection on SeisNet's Main Menu Bar:

Toolbar | Shows or hides the toolbar.
Status Bar | Shows or hides the status bar.
Grid | Shows or hides the grid.
View Log File | Shows or hides the log file.


View Toolbar command

Toolbar command Under SeisNet's View Menu

Use this command to display or hide SeisNet's toolbar. SeisNet's toolbar includes buttons for some the most common commands used in the SeisNet system. Commands such as 'File Open' and Display Grid are available as shortcuts on SeisNet's toolbar. To show or hide SeisNet's toolbar, simply click on the 'View' option on SeisNet's Main Menu Bar. Then, select 'Toolbar' from the drop-down menu, as shown below.

A check mark appears next to the 'Toolbar' command when the SeisNet toolbar is visible. There is no check mark when the SeisNet toolbar is hidden.

See Toolbar for help on using the toolbar.


View Status Bar Command

Status Bar command Under SeisNet's View Menu

Use this command to display and hide the status bar, which describes the action to be executed by the selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to the menu item when the status bar is displayed. To display or hide the status bar, simply click on the 'View' option on SeisNet's Main Menu Bar. Then, select 'Status Bar' from the drop-down menu, as shown below.

See Status Bar for help on using the status bar.


View Grid command

Grid command Under SeisNet's View Menu

Use this command to display and hide the grid that aids in the construction of your flows. When the grid is displayed, the icon representing a SeisNet module is aligned with the grid. That is, each SeisNet module is snapped-to a grid index when the grid is displayed. To show the grid, simply click on the 'View' option on SeisNet's Main Menu Bar. Then, select 'Grid' from the drop-down menu, as shown below.

A check mark appears to the left of the 'Grid' command when the grid is displayed. The check mark disappears if a grid is not displayed. The 'Grid' command is a toggle switch. Click it once and the grid appears; click it again and it disappears.

You can also display or hide the grid by clicking on the 'Grid' button in SeisNet's toolbar. The 'Grid' button found in SeisNet's toolbar is shown below:


View Log File command

View Log File command Under SeisNet's View Menu

Use this command to display SeisNet's log file. SeisNet's log file contains all the runtime parameters for all the modules in your flow. Additional information can be logged, depending on the setting of your Message Level

A check mark appears next to the 'View Log File' command when the log file is displayed. There in no check mark when the log file is not displayed. This makes it easy to tell if the log file is displayed beneath another window.

It is important to note that a new log is created every time you execute a flow. It is equally important to remember that the old log file is erased when a new log file is created. Therefore, if you want to save the contents of the current log file you will want to issue the 'Save As' command, which is found under the 'File' selection on the log file's menu bar, before you give the command to execute a flow. The best way to save the current log file is to first 'Kill' the flow, then issue the 'Save As' command.

The name of the current log file consists of three parts. The first part is the character string "logfile". Appended to this string is the number of seconds from January 1, 1970 to the time when the log file is created. Finally the log file has an extension of ".log'. A valid log file name would look something like <logfile922385836.log>. If you look in the directory where the SeisNet executable is stored you should see a file or files with names similar to this. When more than one log file exists, it means that there could have been more than instance of SeisNet running or the SeisNet program terminated improperly. You might want to check this directory from time-to-time and remove any log files that have been orphaned. The current log file is erased when a flow is executed, not when the SeisNet program terminates.

The log file is displayed in its own window running in a separate thread, so as to have minimal impact on SeisNet operations. The log file has three selections on its menu bar, as shown below.

An existing log file that was saved previously, using the 'Save As' command can be displayed using the 'Open' command under the 'File' selection on the log file's menu bar. This command will bring-up the standard Windows File Open dialog box so you can easily find the log file of interest. An example of a file open dialog box can be found under the help topic Open command Under SeisNet's File Menu

To save the current log file to a file with a permanent name, you should issue the 'Save As' command found under the 'File' selection on the log file's menu bar. The best time to save a log file is immediately after you issue the 'Kill' command to stop the execution of a flow. A 'Kill' command will stop the execution of a flow, but it will not terminate the SeisNet program. When you issue the 'Save As' command, a standard Windows 'Save As' dialog box will appear. An example of a save as dialog box can be found under the help topic Save As command Under SeisNet's File Menu

To make a hard copy of the log file, issue the 'Print' command found under the 'File' selection of the log file's menu bar. When the 'Print' command is issued, the standard Windows print dialog box appears.

You can examine the log file at any time, even while a flow is executing. If you do examine the log file when a flow is executing, you will want to issue an 'Update' command from time-to-time so that you always have the most current information. The 'Update' command is issued by selecting 'Update' on the log file's menu bar, as shown below.

When you are finished examining the log file, issue the 'Exit' command, which will hide the log file from view. The 'Exit' command is issued by selecting 'Exit' on the log file's menu bar, as shown below.

You can also display the log file by clicking on the 'Log' button in SeisNet's toolbar. The 'Log' button found in SeisNet's toolbar is shown below.


Window Menu Commands

The following commands are available under the 'Window' selection on SeisNet's Main Menu Bar. These commands enable you to arrange multiple views of flows in the application window.

New Window | Creates a window that will hold a new flow.
Cascade | Arranges windows in an overlapped fashion.
Tile | Arranges windows in non-overlapped tiles.
Arrange Icons | Arranges the icons of minimized windows.
Window 1, 2, ... | Let's you select a specific window or flow.


Window New command

New Window command Under SeisNet's Window Menu

Use this command to open a new window with the same contents as the active window. You can open multiple document windows to display different parts or views of a document at the same time. If you change the contents in one window, all other windows containing the same document reflect those changes. When you open a new window, it becomes the active window and is displayed on top of all other open windows.

Do not use this command when you want to create a new flow.. A new flow should be created using the New command Under SeisNet's File Menu .

This command is included for those very rare occasions when you have very large flows and you want to view them in separate windows. In general, you should avoid using this command.


Window Cascade command

Cascade command Under SeisNet's Window Menu

Use this command to arrange multiple opened windows in an overlapped fashion. To display opened windows in a cascade fashion, simply click on the 'Window' option on SeisNet's Main Menu Bar. Then, select 'Cascade' from the drop-down menu, as shown below.


Window Tile command

Tile command Under SeisNet's Window Menu

Use this command to arrange multiple opened windows in a non-overlapped fashion. To display all opened windows in a tile fashion, simply click on the 'Window' option on SeisNet's Main Menu Bar. Then, select 'Tile' from the drop-down menu, as shown below.


Window Arrange Icons command

Arrange Icons command Under SeisNet's Window Menu

Use this command to move the icons representing minimized flow windows to the bottom of the application window. To issue this command, simply click on the 'Window' option on SeisNet's Main Menu Bar. Then, select 'Arrange Icons' from the drop-down menu, as shown below.

This command is useful when you have a lot of open flows and you want to examine only one at a time. It helps to keep your desktop clean and uncluttered.


Window 1, 2,… command

Window 1,2,… command Under SeisNet's Window Menu

The SeisNet system displays a list of currently open flows or windows at the bottom of the drop-down menu under SeisNet's Window Menu. A check mark appears to the left of the name of the flow that is active. You can choose any flow from this list to be the active flow simply by clicking on that flow's name. An example of a list of open flows is shown below.

Here we have chosen the flow named <DataOut.FLW> to be the active flow. All flows in SeisNet have a file extension of ".FLW".


Help Menu Commands

The following commands are available under the 'Help' selection on SeisNet's Main Menu Bar. The 'Help' commands provide you with assistance on how to use the SeisNet program and how to use this online help system.

SeisNet Online Help | Offers you an index to topics on which you can get online help.
Using SeisNet Help | Provides general instructions on using help.
About SeisNet | Displays the program information including version number and copyright of this application.


Help Index command

SeisNet Online Help command Under SeisNet's Help Menu

Use this command to display the opening screen of SeisNet's online help system.. From the opening screen, you can jump to any help topic using the Three-Pane HTML Help Window. To display the online help system, simply click on the 'Help' option on SeisNet's Main Menu Bar. Then, select 'SeisNet Online Help' from the drop-down menu, as shown below.


Help Using Help command

Using SeisNet Help command Under SeisNet's Help Menu

Use this command to get instructions on how to use the SeisNet help system. To display the instructions, simply click on the 'Help' option on SeisNet's Main Menu Bar. Then, select 'Using SeisNet Help' from the drop-down menu, as shown below.

The SeisNet online help system uses the framework from Microsoft's HTML help system. A compiled help file is created which gets displayed in a Three-Pane HTML help window. An example of that Three-Pane help window is shown below. The three panes are called the Button Pane, the Navigation Pane, and the Content Pane.

An example of a help topic displayed in the Three-Pane HTML help window. The Hide button in the left corner of the Button pane is a toggle switch. Clicking on it hides the navigation pane and displays a Show button in its place. Clicking on the Show button redisplays the navigation pane.

In the example above, the navigation pane shows the Contents tab open to the current topic displayed in the content pane, which in this case is the introduction to SeisNet An important point about the table of contents in the HTML help display is that it is synchronized with what is displayed in the Content Pane.

Both keyword and full-text search capabilities are available in the SeisNet help system. You access the keyword search by clicking on the Index tab. Simply click on the keyword of interest to display help topic that contains that keyword. To access the full-test search function, click on the Search tab. You type in the text to search for and then click on the Display button.

Inside of the SeisNet program, you can get help on a topic by placing the mouse over the object of interest and then pressing the F1 key. You can get help on individual SeisNet modules by click on the 'H' in the icon that represents the module.


Help About command

About SeisNet command Under SeisNet's Help Menu

Use this command to display the copyright notice and version number of your copy of the SeisNet software program. To display the information, simply click on the 'Help' option on SeisNet's Main Menu Bar. Then, select 'About SeisNet' from the drop-down menu, as shown below.

The information presented when you click on 'About SeisNet' is useful when you call the factory for technical support. The Software Sciences engineer will need to know the version number of the software you are using.


Execute menu command

Execute command on SeisNet's Main Menu Bar

Use this command to start the execution of a SeisNet flow. To start the execution of a flow, simply click on the 'Execute' option on SeisNet's Main Menu Bar, as shown below.

Only a single SeisNet flow can be executing at a time. If flow is running and you try to execute another one, the following dialog box is displayed. All threads in the SeisNet program are suspended until you click on the OK button.

However, you are not limited by the number of instances of the SeisNet program that can be executing at any one time. Therefore, if you want to execute multiple flows, simply start up another instance of the SeisNet program. For example, you could have one instance of the SeisNet program capturing data and writing it to hard disk, and another instance reading the data from hard disk and plotting it on an Oyo plotter.


Pause menu command

Pause command on SeisNet's Main Menu Bar

The Pause menu command allows you to suspend the operation of all the threads in the SeisNet program. To pause the execution of the SeisNet program, simply click on the 'Pause' option on SeisNet's Main Menu Bar, as shown below.

When you issue the 'Pause' command, the following message box is displayed. All threads in the SeisNet program are suspended until you click on the OK button.


Kill menu command

Kill command on SeisNet's Main Menu Bar

The Kill menu command allows you to kill a flow that is currently running. To stop the execution of a running flow, simply click on the 'Kill' option on SeisNet's Main Menu Bar, as shown below.

When you select the 'Kill' option, the following dialog box is displayed. If you choose 'Yes' the flow will be stopped. If you choose 'No' the execution of the flow will be resumed.

It is important to note that when you 'Kill' a running flow, only the execution of the flow is stopped. The SeisNet program continues to run after the flow has been stopped. You can execute the flow you just killed, or you can start the execution of another flow. The SeisNet program is terminated by selection the 'Exit' option on SeisNet's Main Menu Bar.


Toolbar

SeisNet's Toolbar

The SeisNet toolbar is displayed across the top of the main application window and below the Main Menu Bar. The toolbar provides quick mouse access, or shortcuts, to commands that are available on the Main Menu Bar. SeisNet's toolbar is shown below.

To hide or display the toolbar, choose the 'Toolbar' command from under the 'View' option on SeisNet's Main Menu Bar.

Buttons on SeisNet's toolbar have the following meanings:

Opens a new flow.

Opens an existing flow. When you click on this button, SeisNet displays the file Open dialog box, in which you can locate and open the desired flow.

Saves the active flow with the currently specified name. If you have not named the flow, SeisNet will display the Save As dialog box.

Performs a screen dump to the printer. Use this to make hard copies of the flows you have generated. You can also use this command to display trace data on the printer. Simply click on this button anytime you want to save what is displayed on the screen to the printer.

Displays information about the SeisNet program. Such things as the version number and copyright notice are displayed.

Displays context sensitive help. First click on this button, then move the cursor to an area, button or command of interest and click the left mouse button again. The area can be a button, a menu item, or other windows item.

Displays the log file. The contents of the log file are displayed when you click on this button. This is a toggle button. Press it once to see the log file. Press it again and the log file will be closed.

Displays a grid to help you align the modules in your flow. This is a toggle button. Click on it once to display the grid lines. Click on it again and the grid lines will disappear. To give you flows a more structured appearance, align the icons, representing the modules in your flow, with the grid turned on; then, after you have completed building your flow, turn the grid off. When the grid is turned on, icons representing SeisNet modules will 'snap to' the nearest grid coordinate.


Status bar

SeisNet Status Bar

SeisNet's status bar is displayed at the bottom of the main application window. To display or hide the status bar, use the 'Status Bar' command under the 'View' option on SeisNet's Main Menu Bar.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate through menus. This area similarly shows messages that describe the actions of toolbar buttons as you depress them, before releasing them. If after viewing the description of the toolbar button command you wish not to execute the command, release the mouse button while the pointer is off the toolbar button.

During the execution of a flow, SeisNet uses the different areas of the status bar to keep you informed about what is going-on inside the SeisNet program.


Processing Utilities Detect Bad Traces command

SeisNet

Gator/SeisNet Communications Link

If the security key you have has been programmed to enable communications between the Gator System and SeisNet and you do not want the link enabled, you can do the following to disable it.

To disable the link between Gator and SeisNet, the SeisNet program should be started with the command line argument "NoNav" set to TRUE. For example, if the SeisNet executable has been stored in the directory <C:\SeisNet>, then the command line to start the SeisNet program with the link to Gator disabled would be:

C:\SeisNet\SeisNet.exe NoNav=TRUE.

There should be no spaces around the "=" sign. Also, the NoNav command line argument is case insensitive. That is, NoNav and NONAV are both valid names. The entire command line is converted to upper case before any parsing is done.

When the link between Gator and SeisNet is enabled (the default condition), there are three modes of operation for the SeisNet system. The SeisNet mode of operation is controlled by the Gator system. Each of these modes is descriped below:

Mode 0 is when SeisNet is off-line. In this mode SeisNet acquires no data, and it will wait until it receives a command from Gator telling it to either go on-line or that there is no navigation data available.

Mode 1 is the on-line mode. When SeisNet is on-line it will receive navigation data from Gator and seismic data from the recording system. A shot record will be processed when the navigation and seismic data can be merged. The basis used for merging is the source line number and the source station number. A shot record will not be processed if a match cannot be found. SeisNet will buffer up to four shot records before giving up looking for a match between the navigation a seismic data. When a match cannot be found, after SeisNet has buffered four shot records the oldest shot record is simply thrown away. If the first break picking module is in the SeisNet processing flow, the picks will be sent to the Gator system for further processing.

Mode 2 is the no navigation data mode. In this mode of operation, the SeisNet system will process all the shot records obtained from the recording system. No first break data will be sent to the Gator system in this mode of operation, because geometry information from Gator is needed to pick the first breaks.

When displaying the first break picks using SeisNet's trace display module, the following color scheme is adopted. Green defines the first break time window. Blue is the theoretical first break pick, and Red is the pick made by SeisNet.


Service & Support

Seismic Support Technology is committed to providing responsive product service and support.

If you require assistance with any of our products, please contact us at:

Phone: | (713) 266-5075
Email: | info@seismicsupport.com


Technical Specifications

Hardware

The following hardware options are available for use with the SeisNet system:

DC20 Capture Card

20 Mbytes/Second capture rate

128 MB on board seismic RAM

PCI Bus - 70 Mbytes/Second unload

16 Bit or 8 Bit SCSI data bus capture programmable

Differential or single ended interface modules

DCT Tape Emulator Card

40 Mbytes/Second capture rate

128 MB on board seismic RAM

PCI Bus – 70 Mbytes/Second unload

16 Bit or 8 Bit SCSI data bus compatible

Differential or single ended interface

3490/3590 Tape Drive Emulation

Read After Write Option

A Read After Write interface is available to enable data capture from the Fujitsu 3490 Read After Write port.

MDS 18 Tape Simulator Option

An MDS 18 interface is available which simulates a 3480 tape drive and enables the SeisNet to write Y2K compatible tapes to any SeisNet supported tape drive.

Software

The SeisNet software runs under the Windows NT (version 4.0 + Service Pack 6.0 + Internet Explorer 5+) and Windows 2000 operating system and provides the following capabilities:

Processing Modules

Click here for a description of SeisNet's processing modules.

In keeping with our philosophy of increasing product value, Software Sciences will continue to develop new processing modules to meet customer requirements as they are identified.

Plotting

V80 compatible plotting option available, including OYO 612/622/624 and DFM 480 capability.

Tape I/O

3480/3490/3590, DLT, 4mm and 8mm. Tape Copy and Dual Write capability.

Network Link

UNIX, Windows NT/2000 and Windows 98 compatible. ProMAX and Focus links are available.

Host Computer Configuration

Host computer configuration requirements are as follows:

Minimum Recommended Configuration

The following represents the current minimum recommended host computer configuration:

Pentium 4 - 3.0 GHz Processor

200 GByte Hard Drive

1.0 GByte RAM

Gigabit Network Link

19" Monitor - 1280 x 1024 Resolution

Performance Upgrades

Upgrades such as multiple processors, increased RAM, increased hard drive capacity and application of RAID technology will improve system performance if required for a specific application.

Software Sciences reserves the right to change any of the above specifications without notice in order to provide the best possible products and service.


Troubleshooting

Introduction

The SeisNet system creates flow.log files to assist in troubleshooting problems which may occur when running specific flows. In addition, the Windows Performance Monitor is also a useful tool for determining the cause of hardware resource related problems.

Flow.log Files

Created in the c:\seisnet directory each time a flow is executed, these files contains flow parameter settings + any errors detected within the flow.

The file name will be “flow name”.log

e.g. TapeCopy.flw will create TapeCopy.log

Note: This file is overwritten if the flow is killed then re-executed.

You may view the flow.log file by selecting the Log File icon in the Menu Bar while the flow is running or use explorer to select the file in the c:\seisnet directory.

Performance Monitor

Accessed via the task manager, this Windows feature provides resource utilization status. In particular, CPU and Memory usage monitoring may help to identify potential hardware resource related problems. Watch for excess memory usage leading to virtual memory utilization which will seriously impact disk access.


SeisNet Installation

Introduction

The SeisNet system is comprised of a data capture card and software residing on a host computer. This section provides details of the host computer configuration requirements and the hardware/software installation procedure.

Host Computer Requirements

Recommended Configuration

The recommended host computer configuration is as follows:

Pentium 4 - 3 GHz

250 GByte Hard Drive - SATA

1 GBytes RAM

1.44 MB diskette drive

Microsoft compatible mouse

20” Monitor – 1600 x 1200 Resolution

Windows 2000/XP Operating System.

Upgrades such as multiple processors, increased RAM, increased hard drive capacity and hard drive striping will improve system performance if required for a specific application.

Hardware Installation

DC20 – Differential Passive Capture Card

Ensure that the program jumpers are set correctly as follows:

Jumpers 1 | Set to Internal or External Termination +5V Power. (Factory setting = Internal)
Jumpers 2 – 10 | Set to 8 or 16 bit position to match 8 or 16 bit SCSI data bus.

Install the DC20 card in full length PCI slot location.

DCT – Tape Emulator Card

Refer to the SeisDrive Installation.pdf file on the SeisNet CD in the Docs directory for instructions on DCT Tape Emulator Card installation and setup.

SCSI Termination

SCSI termination is provided on the DC20 and DCT cards. All other terminators must be removed to avoid bus problems. Caution: Factory DC20 jumper settings provides SCSI terminator power from the SeisNet host computer which means that the SeisNet computer must remain powered to maintain correct SCSI bus termination.

Software Installation

Install Windows 2000/XP + Latest Service Pack

Place SeisNet CD in the host computer’s CD ROM drive and execute the setup.exe and follow the install instructions using the default install directory c:\seisnet.

You should reboot your computer after the installation is complete to enable all the SeisNet device drivers.

Two types of software key are available, Parallel or USB. If using a Parallel Key it may be necessary to activate the software. You do this by running the "keysetup" program. The "keysetup.exe" program is found on the SeisNet CD in the ProgramFiles directory. The "keysetup" program can be run by going to the Start Menu and selecting RUN. Type-in “x”:\ProgramFiles\keysetup /U /D, where “x” is the CD drive letter.


Scroll bars

SeisNet: Scroll bars

Displayed at the right and bottom edges of the window. The scroll boxes inside the scroll bars indicate your vertical and horizontal location in the window. You can use the mouse to scroll to other parts of the window. Clicking on the scroll box and dragging it toward one end of the scroll bar makes the screen scroll left or right, up or down.


Control Switch to command

Switch to command (application Control menu)

Use this command to display a list of all open applications. Use this "Task List" to switch to or close an application on the list.

Shortcut

Keys: CTRL+ESC

Dialog Box Options

When you choose the Switch To command, you will be presented with a dialog box with the following options:

Task List

Select the application you want to switch to or close.

Switch To

Makes the selected application active.

End Task

Closes the selected application.

Cancel

Closes the Task List box.

Cascade

Arranges open applications so they overlap and you can see each title bar. This option does not affect applications reduced to icons.

Tile

Arranges open applications into windows that do not overlap. This option does not affect applications reduced to icons.

Arrange Icons

Arranges the icons of all minimized applications across the bottom of the screen.


System Minimize command

SeisNet: Minimize Command

Use this command to reduce the SeisNet application window to an icon. This button is found in the upper right-hand corner of the screen. It reduces the window to a small icon at the bottom of the computer screen.

Shortcut

Mouse: Click the minimize icon on the title bar.

Keys: ALT+F9


Contents

Index for Help on the SeisNet System

Introduction

System Architecture

User Interface

Data Objects

Creating Process Flows

Main Menu Bar

Toolbar

Status Bar

User’s Notes

Service & Support

Technical Specifications


Title bar

SeisNet: General Information

Windows NT includes a feature called the Performance Monitor which is accessed under Programs – Administrative Tools. This feature allows the user to monitor the status of various system components. When setting up a split flow design it is recommended that you use this feature to monitor the Paging File % Usage to ensure that it does not continue to increase after the program has been running for several minutes.

A title bar is located along the top of the main application window. It contains the name of the flow and the version number. An example of the title bar for the main application window is shown below.

To move the window, drag its title bar. Note: You can also move dialog boxes by dragging their title bars.

A title bar may contain the following elements:

Application Control-menu button

Document Control-menu button

Maximize button

Minimize button

Name of the application

Name of the document

Restore button


Control Restore command

SeisNet: Restore command

Use this command to return the active window to its size and position before you chose the Maximize or Minimize command.


Control Previous Window command

Previous Window command (document Control menu)

Use this command to switch to the previous open document window. The SeisNet application window determines which window is previous according to the order in which you opened the windows.

Shortcut

Keys: SHIFT+CTRL+F6


System Maximize command

SeisNet: Maximize Command

Use this command to enlarge the active window to fill the available space. This button is found in the upper right-hand corner. It makes the window expand to fill the whole screen.

Shortcut

Mouse: Click the maximize icon on the title bar; or double-click the title bar.

Keys: CTRL+F10 enlarges a document window.


System Size command

SeisNet: Size command

Use this command to display a two-headed arrow so you can size the active window with the mouse or arrow keys.

After the pointer changes to the two-headed arrow:

1. Move the cursor with the mouse to the border you want to change. Hold the left mouse button down and move the mouse or click the arrow keys in the direction of the change you want to make. For example, move left or right to widen or shrink the window.

2. Release the left mouse button when the window is to your satisfaction.


User's Notes

Click below if you want to run the Microsoft WordPad word processing program.

NotePad Program


Control Next Window command

Next Window command (document Control menu)

Use this command to switch to the next open document window. The SeisNet system determines which window is next according to the order in which you opened the windows.

Shortcut

Keys: CTRL+F6


Control Move command

SeisNet: Move command

Use this arrow to move an active window or dialog box. Position the arrow inside the window or dialog box title bar area, and while holding down the left mouse button, drag the item to the new location.

Note: This command is unavailable if you maximize the window.

Shortcut

Keys: CTRL+F7


Service & Support

Software Sciences is committed to providing responsive product service and support.

If you require assistance with any of our products, please contact us at:

Phone: | (720) 540-0846
Fax: | (720) 540-0851
Email: | ssiserver@aol.com


Processing menu commands

SeisNet--Attribute Modules

The following modules can be used to calculate and display attributes in the SeisNet system:

Attributes Module | Specifies the attributes calculated and displayed:
Calculate Attributes | Calculates Trace Attributes in a SeisNet Data Object
Display RMS Values Top Window | Displays RMS Values from the Top Time Window
Display RMS Values Bottom Window | Displays RMS Values from the Bottom Time Window
Display Peak Values Top Window | Displays Peak Values from the Top Time Window.
Display Peak Values Bottom Window | Displays Peak Values from the Bottom Time Window


Processing Tape for Syntron’s Split Recording

Tape for Syntron’s Split Recording command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing Tape for Syntron’s Split Recording Parms

Parameters

Tape Output Syntron Split Recording command (Processing menu)

Parameters for the Tape Output Syntron Split Recording include:

Records Per Tape

Enter the number of shot records required to be written to tape before switching tape drives. Note: If the Synchronize tape changes with the recording system option is enabled, synchronous tape switching will occur irrespective of the Records Per Tape setting.

Dual Tape Recording
Allows user selected sensor configurations to be output to 2 tape drives simultaneously. Sensor configurations are selected independently for each of the 2 tape drives allowing optimum flexibility in outputs.
Enable hot swapping of the tape drives
This option enables auto-switching between tape drives when multiple tape drives are connected to the SeisNet system.

Manually select traces for this data set

This option allows the user to specify the traces to be written to tape.

Select the tape drives to use for this data set

Allows selection from list of tape drive(s) to be used.

Select type of Sensor Data to be written for this Data Set

Allows selection from list of sensor configurations to be written to tape.

Cable configuration buttons

Provide ability to configure up to 8 cables (channel sets).

Sort the traces in the SeisNet data object by sensor type

This option sorts the data passed on to the next module in the flow by sensor type.

Suppress the writing of data to tape

Option disables writing data to tape. Intended for test purposes when checking data output without writing to tape.

Synchronize tape changes with the recording system

Option detects recording system tape changes and synchronizes SeisNet tape changes to match.

Select type of superblocking

Option allows selection of superblocking to tape.

Cable Configuration Parameters

Accessed by clicking on any of the 8 cable configuration buttons in the Split Component Parameter dialog box, the user can define up to 4 sections for each cable

Activate Cable
This check box must be checked to enable the entered parameters to be applied for the cable selected.

Line Segment Configurations

Up to four cable segments can be defined and activated depending on the complexity of the cable layout. This capability allows for the correction of station numbering and shear phone polarity for complex OBC cable layout configurations involving direction changes such as U shape layouts.

Each segment defines the following:

Channel Range

Defines the cable channels affected by the parameters settings within the cable segment.

Receiver Station Mapping

Multiplier & Bias settings allow for correction of receiver station numbering.

Receiver Line Mapping

Multiplier & Bias settings allow for correction of receiver line numbering.

Sensor Order

Allows selection of sensor order in terms of trace sequence to tape for the cable segment.

Activate Segment

Enables the entered parameters to be applied for the cable segment.

Kill Channels

Eliminates channels within cable segment from tape output.

Swap Shear Polarity

Reverses polarity of channels within cable segment


Processing Tape for Syntron’s Split Recording Description

Description

Tape for Syntron’s Split Recording command (Processing menu)

This module provides the ability to create 2 component or other user selected sensor configuration data tapes from 4 component sensor data recorded on the Syntron Syntrak recording system. Provisions are also provided to correct station numbering and shear phone polarity for complex OBC cable layout configurations involving direction changes such as U shape layouts.


Processing menu commands

SeisNet--Data Input Modules

The following modules can be used to input data into the SeisNet system:

Data Input | Specifies the source of input:
DC10XX | DC10XX Data Acquisition Card
Tape | SCSI Tape Drive
Disk | Hard Disk
DC20 Card | DC20 Data Acquisition Card
Raw Data In/Out | Raw Data from the DC20 Card is Stored on Disk
Raw Data From Disk | Reads Raw Data Stored on Hard Disk
SEG-2 Files from OYO DAS | Reads OYO DAS SEG-2 Files from Hard Disk
SEG-Y Tape Input | Reads SEG-Y Tapes
SEG-Y Disk Input | Reads SEG-Y Files


Processing menu commands

SeisNet--Data Output Modules

The following modules can be used to output data from the SeisNet system:

Data Output | Specifies where and how Data is Written:
Disk | Hard Disk in SeisNet's Data Object Format
Tape | Tape in SEG-D 8048 or 8058 Format
MicroMax Dataset | Hard Disk in MicroMax Format
Tape with Verify | Tape in SEG-D Format with Verify Option
Tape for Syntron 4C Split Recording | Tape for 4C Syntron Recording System
Tape for I/O 2 Split Recording | Tape for 4C I/O 2 Recording System
Disk Output in SEG-Y Format | Hard Disk in SEG-Y Format


Processing menu commands

SeisNet--Display Modules

The following modules can be used to display or plot data on the SeisNet system:

Display Function | Specifies where the data are displayed:
Display Trace Data | Displays Seismic Data on the Monitor
Plot Seismic Traces | Plots Seismic Data on a V-80 Compatible Plotter
Display Single Trace Gather | Displays Single Trace Gather on the Monitor
Plot Single Trace Gather (Real Time) | Plots Single Trace Gather on Plotter in Real Time
Capture Screen to Printer | Automatically Captures Screen Image to Printer
Plot Traces on HP LaserJet | Plots Seismic Data on the HP LaserJet


Exit menu command

Exit command Under SeisNet's File Menu

The Exit menu command allows you to exit the SeisNet system. When you use click on the Exit command, a dialog box is displayed asking you if you want to save you flows. If there have been no changes made in any of the active flows, you would answer No. However, if one or more of your flows have been modified, you would want to answer Yes.


File Open dialog box

The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open. This box lists files with the extension you select in the List Files of Type box.
List Files of Type
Select the type of file you want to open:

*.FLW

All Files[*.*]

Drives
Select the drive in which the SeisNet system stores the file that you want to open.
Directories
Select the directory in which the SeisNet system stores the file that you want to open.
Network...
Choose this button to connect to a network location, assigning it a new drive letter.


File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:

File Name
Type a new filename to save a flow with a different name. A filename can contain up to eight characters and an extension of up to three characters. The SeisNet system adds the extension you specify in the Save File As Type box.
Drives
Select the drive in which you want to store the flow.
Directories
Select the directory in which you want to store the flow.
Network...
Choose this button to connect to a network location, assigning it a new drive letter.

Save File as Type

Select the correct extension for the type of file you are saving.


File 1, 2, 3, 4 command

1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four flows you closed. Choose the number that corresponds with the flow you want to open.


Processing menu commands

SeisNet--Filter Modules

The following modules can be used to filter data in the SeisNet system:

Filter | Specifies the Type of Filter:
Lowpass | Butterworth IIR Lowpass Filter
Highpass | Butterworth IIR Highpass Filter
Notch | IIR Notch Filter
Correlation | Crosscorrelates Data Traces in SeisNet Data Object


Context Help command

SeisNet: Context Help command

Use the Context Help command to obtain help on a particular portion of the SeisNet system. When you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark. Then click somewhere in a SeisNet window, such as another Toolbar button, or menu item. The Help topic will be shown for the item you clicked.

Shortcut

Keys: SHIFT+F1


Processing OEM Module 10 Parms

Parameters

OEM GUI Module 10 command (Processing menu)


Processing OEM Module 9 Parms

Parameters

OEM GUI Module 9 command (Processing menu)


Processing OEM Module 8 Parms

Parameters

OEM Module 8 command (Processing menu)


Processing OEM Module 9 Description

Description

OEM GUI Module 9 command (Processing menu)


Processing OEM Module 10 command

OEM GUI Module #10 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 10 Description

Description

OEM GUI Module 10 command (Processing menu)


Processing OEM Module 6 Parms

Parameters

OEM Module 6 command (Processing menu)


Processing OEM Module 8 Description

Description

OEM Module 8 command (Processing menu)


Processing OEM Module 5 Parms

Parameters

OEM Module 5 command (Processing menu)


Processing OEM Module 4 Parms

Parameters

OEM Module 4 command (Processing menu)


Processing OEM Module 6 Description

Description

OEM Module 6 command (Processing menu)


Processing OEM Module 3 Parms

Parameters

OEM Module 3 command (Processing menu)


Processing OEM Module 5 Description

Description

OEM Module 5 command (Processing menu)


Processing OEM Module 4 Description

Description

OEM Module 4 command (Processing menu)


Processing OEM Module 1 Parms

Parameters

OEM Module 1 command (Processing menu)


Processing OEM Module 3 Description

Description

OEM Module 3 command (Processing menu)


Processing OEM Module 1 Description

Description

OEM Module 1 command (Processing menu)


Processing OEM Module 7 Parms

Parameters

OEM Module 7 command (Processing menu)


Processing OEM Module 7 Description

Description

OEM Module 7 command (Processing menu)


Processing OEM Module 2 Parms

Parameters

OEM Module 2 command (Processing menu)


Processing OEM Module 2 Description

Description

OEM Module 2 command (Processing menu)


Processing OEM Module 1 command

OEM Module #1 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 2 command

OEM Module #2 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 3 command

OEM Module #3 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 4 command

OEM Module #4 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 5 command

OEM Module #5 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 6 command

OEM Module #6 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 7 command

OEM Module #7 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 8 command

OEM Module #8 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing OEM Module 9 command

OEM GUI Module #9 command (Processing menu)

You may learn more about this command by selecting one of the following:

Description

Parameters


Processing menu commands

SeisNet--OEM Modules

The following OEM modules must be supplied by the user:

OEM Module | Specifies module's function:
OEM Module #1 | User Supplied Help for OEM Module #1
OEM Module #2 | User Supplied Help for OEM Module #2
OEM Module #3 | User Supplied Help for OEM Module #3
OEM Module #4 | User Supplied Help for OEM Module #4
OEM Module #5 | User Supplied Help for OEM Module #5
OEM Module #6 | User Supplied Help for OEM Module #6
OEM Module #7 | User Supplied Help for OEM Module #7
OEM Module #8 | User Supplied Help for OEM Module #8
OEM GUI Module #9 | User Supplied Help for OEM GUI Module #9
OEM GUI Module #10 | User Supplied Help for OEM GUI Module #10


Print Setup dialog box

The Print Setup dialog box selects the printer, printer path, and paper setting. The settings you can adjust in this dialog box depend on the printer you have installed. The settings remain in effect until you exit the SeisNet program.


Print dialog box

You can produce a paper copy of what is displayed on you screen. A paper copy is often referred to as a hard copy. Before you print what is displayed on the screen, make sure the printer is turned on and contains a adequate supply of paper. If you have more than one printer, SeisNet allows you to select the printer you want to use to plot the screen image. Furthermore, you can make multiple copies of what is displayed on the screen.

You can also choose Print Setup under SeisNet's File Menu to display a Print Setup dialog box, which lets you select a printer and set its properties.


Print Progress Dialog

The Printing dialog box is shown during the time that the SeisNet system is sending output to the printer. The page number indicates the progress of the printing.

To abort printing, choose Cancel.


Processing menu commands

SeisNet Module List

Data Input | Specifies the source of the input
DC10XX | DC10XX Data Acquisition Card
Tape | SCSI Tape Drive
Disk | Hard Disk
DC20 Card | DC20 Data Acquisition Card
Raw Data In/Out | Raw Data from the DC20 Card is Stored on Disk
Raw Data From Disk | Reads Raw Data Stored on Hard Disk
SEG-2 Files from Disk | Reads SEG-2 Files from Hard Disk
SEG-Y Tape Input | Reads SEG-Y Tapes
SEG-Y Disk Input | Reads SEG-Y Files
DC20 To Disk | Takes Data form DC20 Card and Writes it to Disk
Synthetic Input | Generates synthetic input trace data.
Tape Emulator | Emulates Tape Drives for Data Capture
IO RSR SEGY Disk Input | Reads SEGY Data form a Large Disk File
ARAM Aries Disk Input | Reads ARAM Aries Data, SEGY and SEG-D
IO System 4 SEGY Input | Reads IO System 4 SEGY Data from Disk Files
Data Output | Specifies where and how data is written
Disk | Hard Disk in SeisNet's Data Object Format
Tape | Tape in SEG-D 8048 or 8058 Format
MicroMax Dataset | Hard Disk in MicroMax Format
Tape with Verify | Tape in SEG-D Format with Verify Option
Tape Output Chk EOD Then Verify | Tape with Check for EOD, then Optional Verify
Tape for Syntron 4C Split Recording | Tape for 4C Syntron Recording System
Tape for I/O 2 Split Recording | Tape for 4C I/O 2 Recording System
Disk Output in SEG-Y Format | Hard Disk in SEG-Y Format
GeoRes Tape Output | Tape Output for GeoRes Recording System
SEG-D Tape Image to Disk | Store Tape Image of SEG-D data on Hard Disk
Filters | Specifies the type of filter
Lowpass | Butterworth IIR Lowpass Filter
Highpass | Butterworth IIR Highpass Filter
Notch | IIR Notch Filter
Correlation | Crosscorrelates Data Traces in SeisNet Data Object
Display | Specifies where the data are displayed
Display Trace Data | Displays Seismic Data on the Monitor
Plot Seismic Traces | Plots Seismic Data on a V-80 Compatible Plotter
Display Single Trace Gather | Displays Single Trace Gather on the Monitor
Plot Single Trace Gather (Real Time) | Plots Single Trace Gather on Plotter in Real Time
Capture Screen to Printer | Automatically Captures Screen Image to Printer
Plot Traces on HP LaserJet | Plots Seismic Data on the HP LaserJet
Trace Highlight | Displays Traces in User Selected Colors
Scaling | Specifies type of scaling function
Apply Scale Factor | Apply a Specific Scale Factor
Convert to Microbars | Converts Data to have Units of Microbars
Stacking | Function
Simple Marine Geometry | Add Simple Marine Geometry to SeisNet Data Object
Real-Time Brute Stack | Calculates (Optional Semblance Analysis) a Brute Stack
SPS Geometry | Adds Geometry to Flow from SPS files
Attributes | Specifies the attributes calculated and displayed
Calculate Attributes.htm | Calculates Trace Attributes in a SeisNet Data Object
Display RMS Values Top Window | Displays RMS Values from the Top Time Window
Display RMS Values Bottom Window | Displays RMS Values from the Bottom Time Window
Display Peak Values Top Window | Displays Peak Values from the Top Time Window
Display Peak Values Bottom Window | Displays Peak Values from the Bottom Time Window
Utilities | Specifies the type of function to perform
Detect Dead Traces | Detects Dead Traces and Sets Flag in Trace Header
Remove Dead Trace Flags | Removes the Dead Trace Flags from the Trace Header
Telseis Trace Selection | Selects Traces for Processing from Telseis System
Q.C. Link | Handles Gun Controller Data Stored in Header
Pick First Breaks | Pick First Breaks for Gator System
Vertical Stacking | Performs a Vertical Stack from Acquired Data
Spectrum Attributes | Calculates Spectrum Attributes for Selected Traces
Power Spectrum of Single Trace | Calculates the Amplitude Spectrum of a Single Trace.
Marine QC | Calculates Attributes and Stores in Database.
Save First Break Picks | Save First Break Picks to Hard Disk.
Vib Pro Index File | Generates Cross-Reference File for Vib Pro - SEGD
Marine Source Logging | Logs Information about a Marine Source
Select Traces Based on Sensor Type | Trace Data Select Based on Sensor Type
Split Flow | Splits a processing flow
Split Flow | Module to Split a Processing Flow
End Module | Forces an end to a particular thread
End Module | Mainly used for debugging
OEM Modules | User supplies help for these modules
OEM Module 1 | User supplied help
OEM Module 2 | User supplied help
OEM Module 3 | User supplied help
OEM Module 4 | User supplied help
OEM Module 5 | User supplied help
OEM Module 6 | User supplied help
OEM Module 7 | User supplied help
OEM Module 8 | User supplied help
OEM Module 9 | User supplied help
OEM Module 10 | User supplies help


// ReadAttributes

SeisNet:

Sample Code for Reading Attributes File.

The following is some sample code showing what is require to read the attributes file created by the Calculate Attributes module. This code is a simple console application developed using Microsoft's Visual studio.

// ReadAttributes.cpp : Defines the entry point for the console application.

//

#include "stdafx.h"

#include "ReadAttributes.h"

#include <fcntl.h>

#include <sys/types.h>

#include <sys/stat.h>

#include <io.h>

#include <stdio.h>

#include <time.h>

#ifdef _DEBUG

#define new DEBUG_NEW

#undef THIS_FILE

static char THIS_FILE[] = __FILE__;

#endif

// Define a structure for holding the trace attributes

typedef struct tagATTRIBUTES_STRUCTURE

{

unsigned int id; // Special ID so we know have attributes

int iffid; // FFID of the shot record

int nobytes; // Number of bytes in this structure

int byteoffset; // Byte offset to next record of attributes

int ntraces; // Number of traces in shot record.

int nsamp; // Number of samples in trace.

int scantype; // Scan type number.

int channset; // Channel set number.

int chantrcno; // Trace number within channel set

int trcseqno; // Trace sequential number

time_t datetime; // Date and time in time_t format

float samp; // Sampling interval

float starttime1; // Start time of 1st time window

float endtime1; // End time of 1st time window

float starttime2; // Start time of the 2nd time window

float endtime2; // End time of the 2nd time windw;

float rms1; // RMS value in 1st time window

float rms2; // RMS value in the 2nd time window

float peak1; // Peak value in the 1st time window

float peak2; // Peak value in the 2nd time window

float tim1; // Time of peak value in 1st time window

float tim2; // Time of peak value in 2nd time window

float firstbreak; // First break time.

} ATTRIBUTES_STRUCTURE;

/////////////////////////////////////////////////////////////////////////////

// The one and only application object

CWinApp theApp;

using namespace std;

int _tmain(int argc, TCHAR* argv[], TCHAR* envp[])

{

int i; // Variable to use for indexing.

int nread; // Number of bytes read

// Allocate memory to hold the ATTRIBUTES_STRUCTRUE

ATTRIBUTES_STRUCTURE atrs;

// Set a local variable to hold the name of the file holding the attribute data.

char *filename = "D:\\AttributeData\\MarineAttributes.atr";

// Local variable to hold the sizeof the ATTRIBUTES_STRUCTURE

int lsize = sizeof(ATTRIBUTES_STRUCTURE);

// Declare a local variable to hold the file handle.

int fh;

// Open the file holding the attributes data.

fh = _open (filename, _O_BINARY | _O_RDONLY, _S_IREAD | _S_IWRITE);

if(fh == -1)

{

cout << "Failed to Open File." << endl;

exit(-1);

}

// Read the first 10 structures holding the attribute data.

for(i=0; i<10; i++)

{

// Read the next structure

nread = _read (fh, &atrs, lsize);

// Print out some values

cout << "FFID: " << atrs.iffid << endl;

cout << "Number of Traces in the SeisNet Data Object: " << atrs.ntraces << endl;

cout << "Number of Samples in the Trace: " << atrs.nsamp << endl;

cout << "Channel Set Number: " << atrs.channset <<

" Channel Set Trace Number: " << atrs.chantrcno << endl;

cout << "Trace Sequential Number: "<< atrs.trcseqno << endl;

cout << "Date and Time: " << ctime(&atrs.datetime);

cout << "Sampling Interval (in seconds): " << atrs.samp << endl;

cout << "Start Time (1st Window): " << atrs.starttime1 <<

" End Time (1st Window): " << atrs.endtime1 << endl;

cout << "Start Time (2nd Window): " << atrs.starttime2 <<

" End Time (2nd Window): " << atrs.endtime2 << endl;

cout << "RMS Value (1st Window): " << atrs.rms1 <<

" RMS Value (2nd Window): " << atrs.rms2 << endl;

cout << "Peak Value (1st Window): " << atrs.peak1 <<

" Peak Time (1st Window) " << atrs.tim1 << endl;

cout << "Peak Value (2nd Window): " << atrs.peak2 <<

" Peak Time (2nd Window) " << atrs.tim2 << endl;

// Wait for the user to hit the RETURN key

waitcr();

cout << endl;

}

// Close connection to file.

_close(fh);

return TRUE;

}


Processing menu commands

SeisNet--Scaling Modules

The following modules can be used to scale the data in the SeisNet system:

Module | Specifies the type of scaling:
Apply Scale Factor | Apply a Specific Scale Factor.
Convert to Microbars | Converts Data to have Units of Microbars


Tape Copy

SeisNet Module: SPS QC

The SPS QC module is used compare the information contained in the SPS dataset with the information contained in the actual seismic record. Source position, receiver position and relation information is taken from the SPS dataset to make this comparison.

To learn more about this module select one of the following:

Description

Parameters


Processing menu commands

SeisNet--Stacking Modules

The following modules can be used to perform stacking operations on the SeisNet system:

Module | Function :
Simple Marine Geometry | Adds Simple Marine Geometry to SeisNet Data Object
Real-Time Brute Stack | Calculates (Optional Semblance Analysis) a Brute Stack


Processing menu commands

SeisNet--Utility Modules

The following modules can be used to perform specific operations in SeisNet system:

Utility Function | Specifies the type of function to perform:
Detect Bad Traces | Detects Bad Traces and Sets Flag in Trace Header
Remove Bad Trace Flags | Removes the Bad Trace Flags from the Trace Header
Telseis Trace Selection | Selects Traces for Processing from Telseis System
Q.C. Link | Handles Gun Controller Data Stored in Header